Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I can't compile media-libs/mesa-9999 after update layman..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sun Jun 26, 2011 12:32 pm    Post subject: I can't compile media-libs/mesa-9999 after update layman.. Reply with quote

Hey all..
I just want to set my system up to date, and i press this command:

Code:
layman -S
smart-live-rebuild


But in mesa-9999, i can't compile.
This is my error:

Code:
checking for XML_ParserCreate in -lexpat... yes
checking for LIBUDEV... yes
checking for XCB_DRI2... yes
checking for xcb_dri2_connect_alignment_pad in -lxcb-dri2... yes
checking for LIBUDEV... yes
configure: error: gbm_dri requires --enable-shared-glapi

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-libs/mesa-9999/work/Mesa-9999/config.log
 * ERROR: media-libs/mesa-9999 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 5945:  Called econf '--disable-option-checking' '--with-driver=dri' '--disable-glut' '--without-demos' '--enable-xcb' '--disable-debug' '--disable-glw' '--disable-motif' '--enable-glx-tls' '--enable-asm' '--disable-shared-dricore' '--with-dri-drivers=,swrast,radeon,r200,r300,r600' '--enable-texture-float' '--disable-gles1' '--disable-gles2' '--enable-egl' '--disable-openvg' '--enable-gallium' '--with-egl-platforms=drm,x11' '--with-state-trackers=glx,dri,egl' '--enable-gallium-llvm' '--disable-gallium-svga' '--disable-gallium-nouveau' '--disable-gallium-i915' '--disable-gallium-i965' '--enable-gallium-r300' '--enable-gallium-r600' '--disable-gallium-i915' '--disable-gallium-i965' '--enable-gallium-r300' '--enable-gallium-r600'
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *


/var/tmp/portage/media-libs/mesa-9999/work/Mesa-9999/config.log
http://paste.pocoo.org/show/420147/

Code:
localhost ~ # emerge --version
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, libc-0-r0, 2.6.39-gentoo-r2 x86_64)


What i can to do?
_________________
Yakir.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Sun Jun 26, 2011 4:19 pm    Post subject: Reply with quote

Wait until fixed by upstream or ebuild updated to latest deps. You can't expect live sources to build all the time. ;)

There's already a bug about it.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sun Jun 26, 2011 4:29 pm    Post subject: Reply with quote

Ohh.. nice ! :)
Thanks you.

When i can try it again?
_________________
Yakir.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Sun Jun 26, 2011 4:48 pm    Post subject: Reply with quote

Probably best to check for an update to mesa-9999.ebuild when you do layman -s x11 next time.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Sun Jun 26, 2011 4:50 pm    Post subject: Reply with quote

Thanks.
For now its:
Quote:
* Running... # ( cd /var/lib/layman/x11 && /usr/bin/git pull )
Already up-to-date.


So i am need to wait tomorrow for check it.

Thanks again. ;]
When its compile for me, i update this thread.
_________________
Yakir.
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Mon Jun 27, 2011 7:18 am    Post subject: Reply with quote

OK, I see this is not update on the overlay.. So i just add new line for my conf (Don't know if its good.. i not use with USE flag.. just for global setting)

Code:
# line 262:
+ myconf+=" --enable-shared-glapi"


And its working very good.
_________________
Yakir.
Back to top
View user's profile Send private message
andrewthomas
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2010
Posts: 93

PostPosted: Mon Jun 27, 2011 8:44 pm    Post subject: Reply with quote

I just removed the egl use flag in /etc/portage/package.use.

Seems to be OK.
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Mon Jun 27, 2011 9:32 pm    Post subject: Reply with quote

What is egl use flag? for what is it?
_________________
Yakir.
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 383

PostPosted: Tue Jun 28, 2011 1:37 am    Post subject: Reply with quote

The EGL USE flag enables http://en.wikipedia.org/wiki/EGL_(OpenGL) support. :)

Last edited by mattst88 on Tue Jun 28, 2011 2:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
KingYes
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2008
Posts: 142
Location: Israel

PostPosted: Tue Jun 28, 2011 6:07 am    Post subject: Reply with quote

^^
I enable this and use with my change.

Thanks you.
_________________
Yakir.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum