Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
another compiz compile issue (Solved)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Fri Jul 01, 2011 9:51 pm    Post subject: another compiz compile issue (Solved) Reply with quote

hello all,


First the answers so you dont have to browse till the end, Compiz does not work with nouveau


I am following this (old) guide to install compiz : http://en.gentoo-wiki.com/wiki/Compiz

everything goes well, I am installing version 0.9.2 but when I arrive to dev-python/compizconfig-python-0.9.2 I encouter this error :

Code:
compizconfig.pyx:1075:4: __new__ method of extension type will change semantics in a future version of Pyrex and Cython. Use __cinit__ instead.
building 'compizconfig' extension
creating build-2.7
creating build-2.7/temp.linux-x86_64-2.7
creating build-2.7/temp.linux-x86_64-2.7/src
x86_64-pc-linux-gnu-gcc -pthread -march=native -O2 -pipe -fPIC -I/usr/include/compizconfig -I/usr/include/libxml2 -I/usr/include/startup-notification-1.0 -I/usr/include/boost-1_42 -I/usr/include/compiz -I/usr/include/python2.7 -c src/compizconfig.c -o build-2.7/temp.linux-x86_64-2.7/src/compizconfig.o
src/compizconfig.c:1:2: error: #error Do not use this file, it is the result of a failed Cython compilation.
error: command 'x86_64-pc-linux-gnu-gcc' failed with exit status 1
 * ERROR: dev-python/compizconfig-python-0.9.2 failed (compile phase):
 *   Building failed with CPython 2.7 in distutils_building() function
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3399:  Called distutils_src_compile
 *   environment, line  921:  Called python_execute_function 'distutils_building'
 *   environment, line 2008:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *
 * If you need support, post the output of 'emerge --info =dev-python/compizconfig-python-0.9.2',
 * the complete build log and the output of 'emerge -pqv =dev-python/compizconfig-python-0.9.2'.
 * This ebuild is from an overlay named 'desktop-effects': '/var/lib/layman/desktop-effects/'
 * The complete build log is located at '/var/tmp/portage/dev-python/compizconfig-python-0.9.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/compizconfig-python-0.9.2/temp/environment'.
 * S: '/var/tmp/portage/dev-python/compizconfig-python-0.9.2/work/compizconfig-python-0.9.2'


I googled a bit and found this https://forums.gentoo.org/viewtopic-t-860521.html?sid=23c709ce69ba397d368e8d6decdabf00

Quote:
Downgrading cython and FEATURES="-sandbox -usersandbox" worked with:


unfortunately, I cannot downgrade cython, there is only one version in the tree :
Code:
eix cython
[I] dev-python/cython
     Available versions:  0.14.1 {doc examples}
     Installed versions:  0.14.1(23:34:58 07/01/11)(-doc -examples)
     Homepage:            http://www.cython.org/ http://pypi.python.org/pypi/Cython
     Description:         The Cython compiler for writing C extensions for the Python language



any idea anyone ??

thanks

reup
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"


Last edited by reup on Sat Jul 09, 2011 11:47 am; edited 2 times in total
Back to top
View user's profile Send private message
andrewthomas
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2010
Posts: 93

PostPosted: Sat Jul 02, 2011 3:35 am    Post subject: Reply with quote

It has to do with: Use __cinit__ instead of __new__ since its removed in Cython 0.14

I haven't tried this since I am still using 0.8.6, but it may work:


Code:
commit 53d5da274e4d6327b75ed233d3e6f74c8b123296
Author: Sam Spilsbury <sam.spilsbury@canonical.com>
Date:   Sat Feb 12 23:13:08 2011 +0800

    Use __cinit__ instead of __new__ since its removed in Cython 0.14

diff --git a/src/compizconfig.pyx b/src/compizconfig.pyx
index d31f372..146f02b 100644
--- a/src/compizconfig.pyx
+++ b/src/compizconfig.pyx
@@ -570,7 +570,7 @@ cdef class Setting:
     cdef object extendedStrRestrictions
     cdef object baseStrRestrictions
 
-    def __new__ (self, Plugin plugin, name):
+    def __cinit__ (self, Plugin plugin, name):
         cdef CCSSettingType t
         cdef CCSSettingInfo * i
 
@@ -674,7 +674,7 @@ cdef class Setting:
 cdef class SSGroup:
     cdef object screen
 
-    def __new__ (self, screen):
+    def __cinit__ (self, screen):
         self.screen = screen
 
     property Screen:
@@ -692,7 +692,7 @@ cdef class Plugin:
     cdef object ranking
     cdef object hasExtendedString
     
-    def __new__ (self, Context context, name):
+    def __cinit__ (self, Context context, name):
         self.ccsPlugin = ccsFindPlugin (context.ccsContext, name)
         self.context = context
         self.screen = {}
@@ -1007,7 +1007,7 @@ cdef class Profile:
     cdef Context context
     cdef char * name
 
-    def __new__ (self, Context context, name):
+    def __cinit__ (self, Context context, name):
         self.context = context
         self.name = strdup (name)
 
@@ -1029,7 +1029,7 @@ cdef class Backend:
     cdef Bool profileSupport
     cdef Bool integrationSupport
 
-    def __new__ (self, Context context, info):
+    def __cinit__ (self, Context context, info):
         self.context = context
         self.name = strdup (info[0])
         self.shortDesc = strdup (info[1])
@@ -1072,7 +1072,7 @@ cdef class Context:
     cdef object currentBackend
     cdef Bool integration
 
-    def __new__ (self, screenNum = 0, plugins = [], basic_metadata = False):
+    def __cinit__ (self, screenNum = 0, plugins = [], basic_metadata = False):
         cdef CCSPlugin * pl
         cdef CCSList * pll
         if basic_metadata:
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sat Jul 02, 2011 5:29 am    Post subject: Reply with quote

Cython 0.14 is supported in dev-python/compizconfig-python-0.9.4. There are ebuilds you can try for compiz v0.9.4 related packages at b.g.o. Other than that, you have to wait for desktop-effects overlay to be updated. Don't hold your breathe for that. It is a long wait. It seems the overlay needs more devs who really use compiz-fusion.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 7:45 am    Post subject: Reply with quote

thanks all,

I will try this now and will report the result here

reup
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 8:31 am    Post subject: Reply with quote

ooops !
Code:
>>> Emerging (4 of 8) x11-libs/compizconfig-backend-kconfig4-0.9.4 from my_local_overlay
 * compiz-compizconfig-backend-kconfig4-0.9.4.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                 [ ok ]
 * Package:    x11-libs/compizconfig-backend-kconfig4-0.9.4
 * Repository: my_local_overlay
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
>>> Unpacking compiz-compizconfig-backend-kconfig4-0.9.4.tar.bz2 to /var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/x11-libs/compizconfig-backend-kconfig4/files/fix_cmake_order.patch
 *   ( fix_cmake_order.patch )

 * ERROR: x11-libs/compizconfig-backend-kconfig4-0.9.4 failed (unpack phase):
 *   Cannot find $EPATCH_SOURCE!
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 2827:  Called epatch '/usr/local/portage/x11-libs/compizconfig-backend-kconfig4/files/fix_cmake_order.patch'
 *   environment, line 1383:  Called die
 * The specific snippet of code:
 *               die "Cannot find \$EPATCH_SOURCE!";
 *
 * If you need support, post the output of 'emerge --info =x11-libs/compizconfig-backend-kconfig4-0.9.4',
 * the complete build log and the output of 'emerge -pqv =x11-libs/compizconfig-backend-kconfig4-0.9.4'.
 * This ebuild is from an overlay named 'my_local_overlay': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4'

>>> Failed to emerge x11-libs/compizconfig-backend-kconfig4-0.9.4, Log file:

>>>  '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/build.log'

 * Messages for package x11-libs/compizconfig-backend-kconfig4-0.9.4:

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/x11-libs/compizconfig-backend-kconfig4/files/fix_cmake_order.patch
 *   ( fix_cmake_order.patch )
 * ERROR: x11-libs/compizconfig-backend-kconfig4-0.9.4 failed (unpack phase):
 *   Cannot find $EPATCH_SOURCE!
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 2827:  Called epatch '/usr/local/portage/x11-libs/compizconfig-backend-kconfig4/files/fix_cmake_order.patch'
 *   environment, line 1383:  Called die
 * The specific snippet of code:
 *               die "Cannot find \$EPATCH_SOURCE!";
 *
 * If you need support, post the output of 'emerge --info =x11-libs/compizconfig-backend-kconfig4-0.9.4',
 * the complete build log and the output of 'emerge -pqv =x11-libs/compizconfig-backend-kconfig4-0.9.4'.
 * This ebuild is from an overlay named 'my_local_overlay': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4'



investigating !
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 8:33 am    Post subject: Reply with quote

yes, I should read before I post

Code:
/usr/local/portage/x11-libs/compizconfig-backend-kconfig4/files/fix_cmake_order.patch


I forgot to add a patch to the ebuild
:-(
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 10:13 am    Post subject: Reply with quote

but still :
Code:
-- Generating done
-- Build files have been written to: /var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4-0.9.4_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4-0.9.4_build"
make -j1
CMake Error: Parse error in cache file /var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/work/compizconfig-backend-kconfig4-0.9.4_build/CMakeCache.txt. Offending entry: ()]
-- Found Qt-Version 4.7.2 (using /usr/bin/qmake)
-- Found X11: /usr/lib64/libX11.so
-- Found Threads: TRUE (found version "0.9.4")
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl (found version "0.9.4")
CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:188 (MESSAGE):
  Could NOT find Phonon: Found version "0.9.4", but required is at least
  "4.3.80" (found /usr/include)
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/FindPhonon.cmake:35 (find_package_handle_standard_args)
  /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:705 (find_package)
  /usr/share/cmake/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  src/CMakeLists.txt:1 (find_package)


-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
emake failed
 * ERROR: x11-libs/compizconfig-backend-kconfig4-0.9.4 failed (compile phase):
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 2823:  Called cmake-utils_src_compile
 *   environment, line  759:  Called _execute_optionaly 'src_compile'
 *   environment, line  224:  Called enable_cmake-utils_src_compile
 *   environment, line  998:  Called cmake-utils_src_make
 *   environment, line  778:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *
 * If you need support, post the output of 'emerge --info =x11-libs/compizconfig-backend-kconfig4-0.9.4',
 * the complete build log and the output of 'emerge -pqv =x11-libs/compizconfig-backend-kconfig4-0.9.4'.
 * This ebuild is from an overlay named 'my_local_overlay': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/compizconfig-backend-kconfig4-0.9.4/temp/environment'.

I had to emerge wi9th USE="-kde -gtk"(I do not have gnome) so that it skipped compizconfig-backend-kconfig4. However now, I cannot start compiz. I set it as the system default in kde4 systemsetting, but had to revert to kwin as there was no manager running after that

by the way, the documentation in the wiki is very old, and wrong (there is no such thing as compiz-manager). I will try to contact the doc maintainer and help corrected it
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 10:29 am    Post subject: Reply with quote

Code:
eix -cI phonon
[I] kde-base/phonon-kde (4.6.3(4)@06/23/11): Phonon KDE Integration
[I] media-libs/phonon (4.5.0@06/23/11): KDE multimedia API
[I] media-libs/phonon-gstreamer (4.5.0@06/23/11): Phonon GStreamer backend
[I] media-libs/phonon-xine (4.4.4@06/23/11): Phonon XINE backend
Found 4 matches.

_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sat Jul 02, 2011 11:39 am    Post subject: Reply with quote

reup wrote:
I had to emerge wi9th USE="-kde -gtk"(I do not have gnome) so that it skipped compizconfig-backend-kconfig4. However now, I cannot start compiz.

if you emerge it with USE="-kde -gtk", you won't be able to use it under kde or gnome. Since emerald is also not updated to use with version 0.9.4, I suggest to use compizconfig-backend-kconfig4-0.9.2 for now, so you can use it for kde, kwin.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 3:43 pm    Post subject: Reply with quote

keenblade, thanks you for your reply

as pointed higher, I cannot emerge the compizconfig-backend-kconfig4. it fails at a phonon error :

Code:
Could NOT find Phonon: Found version "0.9.4", but required is at least "4.3.80" (found /usr/include)


while I have phonon installed :
Code:
eix -cI phonon
[I] kde-base/phonon-kde (4.6.3(4)@06/23/11): Phonon KDE Integration
[I] media-libs/phonon (4.5.0@06/23/11): KDE multimedia API
[I] media-libs/phonon-gstreamer (4.5.0@06/23/11): Phonon GStreamer backend
[I] media-libs/phonon-xine (4.4.4@06/23/11): Phonon XINE backend
Found 4 matches.


if I could resolve this error, I believe all would be well :-)
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 3:45 pm    Post subject: Reply with quote

oooops, my fault, I just noticed that you talk about compizconfig-backend-kconfig4-0.9.2, I see, 0.9.2, not 0.9.4

I will try to see if it emerge with compiz 0.9.4. I cannot revert to compiz 0.9.2 as it failed to emerge for some other reason
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Jul 02, 2011 3:51 pm    Post subject: Reply with quote

nope, no go
Code:

emerge -av =x11-libs/compizconfig-backend-kconfig4-0.9.2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/compizconfig-backend-kconfig4-0.9.2  0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/desktop-effects

Would you like to merge these packages? [Yes/No]

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-libs/compizconfig-backend-kconfig4-0.9.2 from desktop-effects
 * compizconfig-backend-kconfig4-0.9.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...          [ ok ]
 * Package:    x11-libs/compizconfig-backend-kconfig4-0.9.2
 * Repository: desktop-effects
 * Maintainer: desktop-effects@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
............
............

--   found compiz, version 0.9.4.0
CMake Error at src/CMakeLists.txt:6 (include):
  include could not find load file:

    KDE4Defaults


CMake Error at src/CMakeLists.txt:8 (include):
  include could not find load file:

    MacroLibrary


-- Performing Test HAVE_SCANDIR_POSIX
-- Performing Test HAVE_SCANDIR_POSIX - Success
-- checking for module 'libcompizconfig'
--   found libcompizconfig, version 0.9.4.0

************************************************************
* Compiz        Buildsystem                                *
*                                                          *
* Package : compizconfig-backend-kconfig4                  *
* Version : 0.9.0                                          *
************************************************************
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -march=native -O2 -pipe
C++             -march=native -O2 -pipe
Linker flags:
Executable      -Wl,-O1 -Wl,--as-needed
Module          -Wl,-O1 -Wl,--as-needed
Shared          -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
 * ERROR: x11-libs/compizconfig-backend-kconfig4-0.9.2 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2817:  Called cmake-utils_src_configure
 *   environment, line  752:  Called _execute_optionaly 'src_configure'

_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sat Jul 02, 2011 4:56 pm    Post subject: Reply with quote

reup wrote:
nope, no go

Ok, I created an ebuild for you to try. It will work I guess. Needs the same patch, also notice the version is different, :)
compizconfig-backend-kconfig4-0.9.2.1.ebuild
Code:

# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="3"

inherit cmake-utils

DESCRIPTION="Compizconfig Kconfig Backend"
HOMEPAGE="http://www.compiz.org/"
SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
RESTRICT="nomirror"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""

DEPEND="
   x11-libs/qt-dbus:4
   >=x11-libs/libcompizconfig-${PV}
   >=x11-wm/compiz-${PV}
"
RDEPEND="${DEPEND}"

src_unpack() {
   unpack ${A}
   cd "${S}"
      epatch ${FILESDIR}/fix_cmake_order.patch
}

src_configure() {
   mycmakeargs=(
      "-DCOMPIZ_DISABLE_SCHEMAS_INSTALL=ON"
   )
   cmake-utils_src_configure
}

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Mon Jul 04, 2011 9:20 am    Post subject: Reply with quote

thank you keenblade,

I emerged the new ebuild and it worked with no fault,

compiz still does not work, when I run it (changing the default wm in kde systemsettings) I just loose the windows decoration but it is still kwin. I can see that because I have a shortcut to activity and it still works, compiz does not know activit.

I will now mask all 0.9.4 packages and reemerge compiz to 0.9.2

again, I will post my findings, I hope it will help someone having the same issue. I really like compiz and have been using it for a long time, I would like to test its new feature in version 0.9.x
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Mon Jul 04, 2011 1:51 pm    Post subject: Reply with quote

well, it seems that the issue is related to this f$%^& NVIDIA card that I have

I just installed version 0.8.4 off all package and fusion-icon as a launcher. still no compiz

when selecting compiz, I loose the windows decoration and that is all

I try emerald and kde4-windows-decoration, not only do I not have decoration, but I do not have compiz (no cube, no move windows) yes, all are setup in ccsm

I will investigate more in the direction of NVIDIA
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Mon Jul 04, 2011 2:07 pm    Post subject: Reply with quote

update,

using Option "AddARGBGLXVisuals" "True" in xorg.conf, I have compiz 0.8.4.

now I will try to upgrade to 0.9.4
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Tue Jul 05, 2011 2:37 am    Post subject: Reply with quote

@keenblade

Your ebuild has some errors in it.
Code:
   >=x11-libs/libcompizconfig-${PV}
   >=x11-wm/compiz-${PV}

Both of those lines will be looking for '*-0.9.2.1' respectively
which do not exist.

@reup
The 'Option AddARGBGLXVisuals" "True" hasn't
been needed for a few years now to prevent
black screen of death. If your having to use that
option then there is a broken compiz as nvidia fixed
their end of the issue a few years back.

@everone
Emerald and fusion-icon were never ported and
won't be ported to compiz++ '0.9.x' unfortunately.
Let's hope devs change their minds
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Tue Jul 05, 2011 8:10 am    Post subject: Reply with quote

@Jupiter1TX,

I could emerge the keenblade ebuild because I already had compiz 0.9.4 emerged. I pass the block by using -kde the first time

I realise that compiz was not working with version 0.8.4 because ccsm was suddenly empty, probably incompatibility between 0.9 and 0.8 settings

I have removed the NVIDIA option now

so what I have now is a functional version of compiz-0.8.4 with emerald and fusion-icon, but if I upgrade to 0.9.4 I will encounter 2 errors, one with compizconfig-backend-kconfig4-0.9.4 and Phonon, or one with compizconfig-backend-kconfig4-0.9.2.1 that will install but gives me no compiz.

ps aux shows compiz running, but no decoration are available, no effects and I still can see the activity from kwin, this been the proof that I remove kwin but do not load compiz

by the way, I tried -9999 from desktop effect but it fails on emerge compiz as well
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue Jul 05, 2011 9:32 pm    Post subject: Reply with quote

reup wrote:
...
ps aux shows compiz running, but no decoration are available, no effects and I still can see the activity from kwin, this been the proof that I remove kwin but do not load compiz

by the way, I tried -9999 from desktop effect but it fails on emerge compiz as well

If you emerge x11-wm/compiz-0.9.4 with "kde" useflag, you can use compiz with kwin decorator. I use it like that. Everything works here desktop cube, etc. Only compizconfig-backend-kconfig4 is v0.9.2.1, all the others are v0.9.4.
Jupiter1TX wrote:
@keenblade

Your ebuild has some errors in it.
Code:
   >=x11-libs/libcompizconfig-${PV}
   >=x11-wm/compiz-${PV}

Both of those lines will be looking for '*-0.9.2.1' respectively
which do not exist.

Ebuild is fine, but you must adjust other ebuilds for v0.9.2.1 , if you want to install lesser than v0.9.4 ones. Or just remove the version specification on that string in ebuild.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Wed Jul 06, 2011 5:20 pm    Post subject: Reply with quote

I unmasked 0.9.4 and reemerged it all keeping compizconfig-backend-kconfig4-0.9.2.1.

everything emerged ok, but still no matter how I start compiz, it kicks out kwin, it shows in 'ps aux' but no effect neither decoration are available

I checked that ccsm is showing all wanted effects enables, that decoration is selected and shows kde4-window-decorator

I tried different settings backend in ccsm (flat or kde, integrated in the desktop or not)

I have to admit that I am running out of ideas. what to try, how to test !
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Wed Jul 06, 2011 5:46 pm    Post subject: Reply with quote

keenblade wrote:

Ebuild is fine, but you must adjust other ebuilds for v0.9.2.1 , if you want to install lesser than v0.9.4 ones. Or just remove the version specification on that string in ebuild.

Ebuild is NOT fine. Both of those lines are looking for '*-.0.9.4' OR GREATER '>='.

Not only that but the naming convention for compiz has changed AFTER '0.9.2'
so that ALL compononents now have 'compiz-' before it's name.
For example 'x11-libs/libcompizconfig' is now called 'x11-libs/compiz-libcompizconfig'.
I'm no code monkey but i have worked with compiz since the beginning and used
to help write ebuilds, so i do know a little as to what i speak of.

You can see for yourself which components now have a diff name by going to
http://releases.compiz-fusion.org/
Quote:
ccsm-0.9.2.1.tar.bz2 2010-Nov-07 06:37:40 1.0M application/octet-stream
ccsm-0.9.2.1.tar.gz 2010-Nov-07 06:38:07 1.1M application/octet-stream
compiz-0.9.2.1.sha1 2010-Nov-08 13:35:51 1.3K application/octet-stream
compiz-0.9.2.1.sha1.asc 2010-Nov-08 13:39:05 0.1K text/plain
compiz-core-0.9.2.1.tar.bz2 2010-Nov-07 06:38:50 844.5K application/octet-stream
compiz-core-0.9.2.1.tar.gz 2010-Nov-07 06:39:19 1.3M application/octet-stream
compiz-plugins-extra-0.9.2.1.tar.bz2 2010-Nov-07 06:39:55 2.0M application/octet-stream
compiz-plugins-extra-0.9.2.1.tar.gz 2010-Nov-07 06:38:30 2.1M application/octet-stream
compiz-plugins-main-0.9.2.1.tar.bz2 2010-Nov-07 06:40:03 370.3K application/octet-stream
compiz-plugins-main-0.9.2.1.tar.gz 2010-Nov-07 06:40:13 432.1K application/octet-stream
compiz-plugins-unsupported-0.9.2.1.tar.bz2 2010-Nov-07 06:40:29 866.7K application/octet-stream
compiz-plugins-unsupported-0.9.2.1.tar.gz 2010-Nov-07 06:38:54 0.9M application/octet-stream
compizconfig-backend-gconf-0.9.2.1.tar.bz2 2010-Nov-07 06:38:12 18.5K application/octet-stream
compizconfig-backend-gconf-0.9.2.1.tar.gz 2010-Nov-07 06:37:41 20.2K application/octet-stream
compizconfig-backend-kconfig4-0.9.2.1.tar.bz2 2010-Nov-07 06:38:17 21.4K application/octet-stream
compizconfig-backend-kconfig4-0.9.2.1.tar.gz 2010-Nov-07 06:38:23 21.9K application/octet-stream
compizconfig-python-0.9.2.1.tar.bz2 2010-Nov-07 06:38:28 15.5K application/octet-stream
compizconfig-python-0.9.2.1.tar.gz 2010-Nov-07 06:37:45 16.6K application/octet-stream
libcompizconfig-0.9.2.1.tar.bz2 2010-Nov-07 06:37:42 58.1K application/octet-stream
libcompizconfig-0.9.2.1.tar.gz 2010-Nov-07 06:37:48 67.7K application/octet-stream

Quote:
compiz-0.9.4.sha1 2011-Mar-07 12:39:46 0.6K application/octet-stream
compiz-0.9.4.sha1.asc 2011-Mar-07 12:39:44 0.1K text/plain
compiz-ccsm-0.9.4.tar.bz2 2011-Mar-07 12:40:04 938.5K application/octet-stream
compiz-ccsm-0.9.4.tar.gz 2011-Mar-07 12:44:50 1.1M application/octet-stream
compiz-compizconfig-backend-gconf-0.9.4.tar.bz2 2011-Mar-07 12:40:06 18.7K application/octet-stream
compiz-compizconfig-backend-gconf-0.9.4.tar.gz 2011-Mar-07 12:44:53 20.2K application/octet-stream
compiz-compizconfig-backend-kconfig4-0.9.4.tar.bz2 2011-Mar-07 12:40:09 21.5K application/octet-stream
compiz-compizconfig-backend-kconfig4-0.9.4.tar.gz 2011-Mar-07 12:44:55 21.9K application/octet-stream
compiz-compizconfig-python-0.9.4.tar.bz2 2011-Mar-07 12:40:11 15.6K application/octet-stream
compiz-compizconfig-python-0.9.4.tar.gz 2011-Mar-07 12:44:58 16.7K application/octet-stream
compiz-core-0.9.4.tar.bz2 2011-Mar-07 12:40:27 859.4K application/octet-stream
compiz-core-0.9.4.tar.gz 2011-Mar-07 12:45:23 1.4M application/octet-stream
compiz-libcompizconfig-0.9.4.tar.bz2 2011-Mar-07 12:40:31 58.3K application/octet-stream
compiz-libcompizconfig-0.9.4.tar.gz 2011-Mar-07 12:45:27 67.6K application/octet-stream
compiz-plugins-extra-0.9.4.tar.bz2 2011-Mar-07 12:42:17 6.3M application/octet-stream
compiz-plugins-extra-0.9.4.tar.gz 2011-Mar-07 12:47:16 6.5M application/octet-stream
compiz-plugins-main-0.9.4.tar.bz2 2011-Mar-07 12:43:14 3.3M application/octet-stream
compiz-plugins-main-0.9.4.tar.gz 2011-Mar-07 12:48:17 3.5M application/octet-stream
compiz-plugins-unsupported-0.9.4.tar.bz2 2011-Mar-07 12:44:29 4.4M application/octet-stream
compiz-plugins-unsupported-0.9.4.tar.gz 2011-Mar-07 12:49:33 4.5M application/octet-stream


I know i have not sounded very positive about compiz lately BUT things are looking
up and should be changing for the better as new devs 'should' be joining the effort
now that MS AND APPLE have decided to use Compiz.
Quote:
Currently they both use proprietary desktop technologies called DWM and WindowServer, however after some consultation with the compiz developers, it has been decided that Aero and Quartz for Microsoft (R) Windows [TM] 8 and Apple (R) Mac OS [TM] X Lion [TM] will be moving to will now use compiz as a base instead of DWM and WindowServer. Most notably this was done for performance reasons, but also because a number of the new interfaces provided in compiz 0.9x allow for some great new stuff to happen with both Aero and Quartz. With Quartz’ and Aero’s transition to compiz, we now have the full backing and support (and developer base) given to us as an upstream from the Apple and Microsoft developers.

Quote:
This means that compiz development will not be as slow paced as it has been over the past year or so, and it means that we will be making much more rapid releases. Much attention will be paid to instability of core and prototyping of great new bugs and misfeatures. With Aero and Quartz behind us, we now also get a number of key technologies which will be appearing in the newfangled computer desktop stack over the next few months.

_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
dwbowyer
Apprentice
Apprentice


Joined: 18 Apr 2008
Posts: 154

PostPosted: Wed Jul 06, 2011 6:05 pm    Post subject: Reply with quote

reup: I am just wondering, from reading your thread posts where you are playing with different versions and options to compiz, if you had looked at the lower X11 layers. I'm still using compiz-0.8.4, and LXDE, but I recently had an issue after upgrade to xorg-server-10.2 and nvidia-drivers-27x. that sounds very similar to yours. In fact this thread was helpful in me tracking down my problem.

/etc/portage/package.mask:

>x11-base/xorg-server-1.9.5
>x11-drivers/nvidia-drivers-260.19.44
>media-video/nvidia-settings-260.19.44
>sys-apps/dbus-1.4.6


Put me back in working order. The biggest issue seemed to stem from Dbus.

I also discovered a slight error in /usr/bin/compiz-manager, tests relying on a system tool that had changed name/package, but this is likely irrelevant to a maintained 0.9.2 or 0.9.4 series.
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Wed Jul 06, 2011 6:14 pm    Post subject: Reply with quote

dwbowyer wrote:
The biggest issue seemed to stem from Dbus.

Indeed any >sys-apps/dbus-1.4.6 will break compiz-.8.4.x. So either
downgrade to sys-apps/dbus-1.4.6 or disable dbus plugin in compiz
ccsm.

Am using these with compiz-0.8.4 with no problem
Code:
x11-base/xorg-server-1.10.2
x11-drivers/nvidia-drivers-275.09.07
sys-apps/dbus-1.4.6


P.S. by the way guys i also hacked up some ebuilds for 0.9.2.1 and
0.9.4 and tried them but alas there are sooo many bugs and breakage
in those compiz revs that it just wasn't worth the hassle and time available
to me currently.
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Wed Jul 06, 2011 6:38 pm    Post subject: Reply with quote

thanks all for your replies.

this is dbus version
Code:

[I] sys-apps/dbus
     Available versions:  1.4.6 ~1.4.8-r1 ~1.4.10 1.4.12 {X debug doc selinux static-libs test}
     Installed versions:  1.4.12(21:17:17 06/22/11)(X -debug -doc -selinux -static-libs -test)


I have compiz 0.8.4 working perfectly well, that is never been an issue
I have one laptop with intel card using compiz 0.8.4 on wich I never could upgrade to 0.9.4 because of emerge errors

I have also this station, a NVIDIA based system
Code:

lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
CPU socket(s):         1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Stepping:              11
CPU MHz:               2403.000
BogoMIPS:              4799.57
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
NUMA node0 CPU(s):     0-3


# lspci
00:00.0 Host bridge: nVidia Corporation Device 07c3 (rev a2)
00:00.1 RAM memory: nVidia Corporation nForce 630i memory controller (rev a2)
00:01.0 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.1 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.2 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.3 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.4 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.5 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:01.6 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:02.0 RAM memory: nVidia Corporation nForce 630i memory controller (rev a1)
00:03.0 ISA bridge: nVidia Corporation MCP73 LPC Bridge (rev a2)
00:03.1 SMBus: nVidia Corporation MCP73 SMBus (rev a1)
00:03.2 RAM memory: nVidia Corporation MCP73 Memory Controller (rev a1)
00:03.3 Co-processor: nVidia Corporation MCP73 Co-processor (rev a2)
00:03.4 RAM memory: nVidia Corporation MCP73 Memory Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation GeForce 7100/nForce 630i USB (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP73 [nForce 630i] USB 2.0 Controller (EHCI) (rev a1)
00:08.0 IDE interface: nVidia Corporation MCP73 IDE (rev a1)
00:09.0 Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)
00:0a.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0b.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0c.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0d.0 PCI bridge: nVidia Corporation MCP73 PCI Express bridge (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP73 IDE (rev a2)
00:0f.0 Ethernet controller: nVidia Corporation MCP73 Ethernet (rev a2)
01:07.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
02:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9600 GT] (rev a1)


on it I can install and use compiz 0.8.4, but I cannot install and use 9999, I can install 0.9.4 but see no effect and no decoration

I am in fact trying to progress in my knowledge of Gentoo and rather have an unstable system than give up (this is a secondary system, my laptop is my main system)

this is also probably relevant, I am not using the nvidia driver, but the nouveau kernel driver

also, I have noticed that the 0.9.2.1 ebuild was trying to pull wrong version of the other package, so I have hardset the version in the ebuild itself
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Wed Jul 06, 2011 7:09 pm    Post subject: Reply with quote

Jupiter1TX wrote:

Ebuild is NOT fine. Both of those lines are looking for '*-.0.9.4' OR GREATER '>='.

Not only that but the naming convention for compiz has changed AFTER '0.9.2'
so that ALL compononents now have 'compiz-' before it's name.
For example 'x11-libs/libcompizconfig' is now called 'x11-libs/compiz-libcompizconfig'.
I'm no code monkey but i have worked with compiz since the beginning and used
to help write ebuilds, so i do know a little as to what i speak of.

Upss you are right. But, I did not changed the ebuild names from x11-libs/libcompizconfig' to x11-libs/compiz-libcompizconfig. But they are adjusted to checkout the right tar-balls in the ebuild. So the src uri parts needs to be edited for ex libcompizconfig like this:
Code:

SRC_URI="http://releases.compiz.org/${PV}/compiz-${P}.tar.bz2"

So ebuild is fine in my overlay :)
Jupiter1TX wrote:

I know i have not sounded very positive about compiz lately BUT things are looking
up and should be changing for the better as new devs 'should' be joining the effort
now that MS AND APPLE have decided to use Compiz.
Quote:
Currently they both use proprietary desktop technologies called DWM and WindowServer, however after some consultation with the compiz developers, it has been decided that Aero and Quartz for Microsoft (R) Windows [TM] 8 and Apple (R) Mac OS [TM] X Lion [TM] will be moving to will now use compiz as a base instead of DWM and WindowServer. Most notably this was done for performance reasons, but also because a number of the new interfaces provided in compiz 0.9x allow for some great new stuff to happen with both Aero and Quartz. With Quartz’ and Aero’s transition to compiz, we now have the full backing and support (and developer base) given to us as an upstream from the Apple and Microsoft developers.

Quote:
This means that compiz development will not be as slow paced as it has been over the past year or so, and it means that we will be making much more rapid releases. Much attention will be paid to instability of core and prototyping of great new bugs and misfeatures. With Aero and Quartz behind us, we now also get a number of key technologies which will be appearing in the newfangled computer desktop stack over the next few months.

These are april 1 jokes.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum