Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
chromium-13.0.782.41 failed (configure phase)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Tue Jul 05, 2011 4:45 pm    Post subject: chromium-13.0.782.41 failed (configure phase) Reply with quote

Wouldn't this mean Chromium won't compile with linux-3.0-rc*'s?
Code:
>>> Emerging (1 of 1) www-client/chromium-13.0.782.41
 * chromium-13.0.782.41.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                   [ ok ]
 * Package:    www-client/chromium-13.0.782.41
 * Repository: gentoo
 * Maintainer: chromium@gentoo.org
 * USE:        cups elibc_glibc gnome kernel_linux userland_GNU x86
 * FEATURES:   preserve-libs sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.0.0-rc4/build
 * Found sources for kernel version:
 *     3.0.0-rc4
 * Checking for suitable kernel configuration options...                                                                          [ ok ]
>>> Unpacking source...
>>> Unpacking chromium-13.0.782.41.tar.bz2 to /var/tmp/portage/www-client/chromium-13.0.782.41/work
>>> Source unpacked in /var/tmp/portage/www-client/chromium-13.0.782.41/work
>>> Preparing source in /var/tmp/portage/www-client/chromium-13.0.782.41/work/chromium-13.0.782.41 ...
 * Applying chromium-system-vpx-r4.patch ...                                                                                      [ ok ]
 * Applying chromium-perl-5.14-r0.patch ...                                                                                       [ ok ]
 * Applying chromium-glibc-2.14-r0.patch ...                                                                                      [ ok ]
 * Applying chromium-libgcrypt-r0.patch ...                                                                                       [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/www-client/chromium-13.0.782.41/work/chromium-13.0.782.41 ...
build/gyp_chromium --depth=. -Ddisable_sse2=1 -Duse_system_bzip2=1 -Duse_system_flac=1 -Duse_system_icu=1 -Duse_system_libevent=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libwebp=1 -Duse_system_libxml=1 -Duse_system_speex=1 -Duse_system_vpx=1 -Duse_system_xdg_utils=1 -Duse_system_yasm=1 -Duse_system_zlib=1 -Duse_cups=1 -Duse_gconf=1 -Duse_gnome_keyring=0 -Dlinux_link_gnome_keyring=0 -Dlinux_sandbox_path=/usr/lib/chromium-browser/chrome_sandbox -Dlinux_sandbox_chrome_path=/usr/lib/chromium-browser/chrome -Dtarget_arch=ia32 -Dwerror=
Updating projects from gyp files...
Traceback (most recent call last):
  File "build/gyp_chromium", line 171, in <module>
    sys.exit(gyp.main(args))
  File "/var/tmp/portage/www-client/chromium-13.0.782.41/work/chromium-13.0.782.41/tools/gyp/pylib/gyp/__init__.py", line 323, in main
    'sunos5':   'make',}[sys.platform] ]
KeyError: 'linux3'
 * ERROR: www-client/chromium-13.0.782.41 failed (configure phase):
 *   (no error message)
I have a 2.6.39 kernel that I'll try, but is this going to be a problem until a chromium and/or kernel dev updates it?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5733

PostPosted: Tue Jul 05, 2011 6:33 pm    Post subject: Reply with quote

It's broken on Chromium's side (their script should not be version-sniffing that way), so you'll have to wait for them to fix it.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Tue Jul 05, 2011 9:19 pm    Post subject: Reply with quote

Ant P.,
Thanks for the feedback! :)
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
phajdan.jr
Retired Dev
Retired Dev


Joined: 23 Mar 2006
Posts: 1777
Location: Poland

PostPosted: Mon Jul 18, 2011 1:01 am    Post subject: Reply with quote

See also http://code.google.com/p/chromium/issues/detail?id=85845.
_________________
http://phajdan-jr.blogspot.com/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum