Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Attempt to compile mars_nwe fails with 'missing seperator'
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
milamontagne
n00b
n00b


Joined: 01 Oct 2005
Posts: 41

PostPosted: Thu Jul 07, 2011 1:15 pm    Post subject: Attempt to compile mars_nwe fails with 'missing seperator' Reply with quote

Hi i downloaded mars_nwe from here:

ftp://ftp.gwdg.de/pu/linux/misc/ncpfs/mars_nwe/

Unfortunately, i cant get the compile to run as per the directions. the output of make:

make[1]: Entering directory `/root/mars_nwe/obj'
rm -f Makefile.o
cp ../makefile.unx makefile.c
cc -E -DLINUX -DQTAINSYS -DUSE_GDBM -I.. makefile.c > Makefile.o
rm -f makefile.c
make -f Makefile.o n_all
make[2]: Entering directory `/root/mars_nwe/obj'
Makefile.o:86: *** missing separator. Stop.
make[2]: Leaving directory `/root/mars_nwe/obj'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/mars_nwe/obj'

Can anyone help me out here?
Back to top
View user's profile Send private message
Geos_One
Apprentice
Apprentice


Joined: 15 Sep 2005
Posts: 250
Location: Austria,Graz

PostPosted: Sat Nov 12, 2011 10:50 pm    Post subject: compile Reply with quote

i am working also on compiling mars_nwe
just give me some time and i will get a ebuild to my personal overlay

thx
Mario
Back to top
View user's profile Send private message
Geos_One
Apprentice
Apprentice


Joined: 15 Sep 2005
Posts: 250
Location: Austria,Graz

PostPosted: Sun Nov 13, 2011 7:54 pm    Post subject: ok done Reply with quote

i have finished the work on mars_nwe (i have replaced the broken sh/make/perl mix with cmake)

https://svn.disconnected-by-peer.at/svn/linamh/trunk/linamh/net-fs/mars-nwe/mars-nwe-0.99_p22.ebuild

here is the ebuild for it

some small things are still missing

init script
reduce the included net$log.dat script
add logrotate script (mars_nwe logs grow really fast)
integrate pegasus mail

but for now if you start nwserv manually it works out of the box
Back to top
View user's profile Send private message
nilreM
n00b
n00b


Joined: 22 Nov 2007
Posts: 19
Location: Voronezh

PostPosted: Sun May 20, 2012 6:59 am    Post subject: Reply with quote

Excuse that I lift such old subject, but it is still actual

The link above to the ebuild is dead. Google by all means brings into the same dead site

Does someone have this ebuild or some other instructions how to build mars_nwe?
Back to top
View user's profile Send private message
Geos_One
Apprentice
Apprentice


Joined: 15 Sep 2005
Posts: 250
Location: Austria,Graz

PostPosted: Sun May 20, 2012 9:17 am    Post subject: Reply with quote

some time ago i moved my ebuilds to git the new location is
http://git.disconnected-by-peer.at/dbp/linamh/tree/net-fs/mars-nwe/mars-nwe-0.99_p22.ebuild

there are still some problems with this

it is only x86 (ore mmre clearly onyl -m32)
it will compile on amd64 but wont run correctly

thx
Mario

by the way you can find here my git repo for mars_new and programms
http://git.disconnected-by-peer.at/mars_nwe/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum