Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pf-sources: after upgrading p3->p4 hibernation doesn't work
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Thu Aug 18, 2011 12:53 am    Post subject: Reply with quote

Quote:
ieve this to be a problem with tuxonice apparently not going well with the bfs patch.


I'm using pf-sources-3.0.1 with BFS and tuxonice works perfectly, and it did in 2.6.39 too
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Odysseus
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 250
Location: Miami, FL. I miss San Francisco!!!

PostPosted: Thu Aug 18, 2011 4:02 am    Post subject: Reply with quote

albright wrote:
Quote:
ieve this to be a problem with tuxonice apparently not going well with the bfs patch.


I'm using pf-sources-3.0.1 with BFS and tuxonice works perfectly, and it did in 2.6.39 too


Are you running 64bit or 32 bit? Stable or ~ arch?

As stated earlier by the OP and myself, 2.6.39_p3 and earlier versions worked fine for me. It's 2.6.39_p4 and 3.0.1 that have issues.

BTW I'm running 32bit ~x86 on this Dell laptop. I find it odd that disabling compression either in the kernel or in the config file works around the problem and that my kernel will fail in to build if I enable lzo instead of gzip to compress the kernel or initramfs.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Thu Aug 18, 2011 11:21 am    Post subject: Reply with quote

Quote:
Are you running 64bit or 32 bit? Stable or ~ arch?



32 bit / a godawful mix of stable and ~x86

BTW, I use LZF compressor, not LZO
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Odysseus
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 250
Location: Miami, FL. I miss San Francisco!!!

PostPosted: Fri Aug 19, 2011 7:11 am    Post subject: Reply with quote

Update---- the newest version 3.0.2 is still broken just like the previous two.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Fri Aug 19, 2011 1:12 pm    Post subject: Reply with quote

Quote:
Update---- the newest version 3.0.2 is still broken just like the previous two.


Not for me; working fine
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Small_Penguin
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2005
Posts: 137

PostPosted: Sat Aug 27, 2011 10:18 am    Post subject: Reply with quote

albright wrote:
Not for me; working fine


It's fine when it works for you, but you're not using tuxonice with lzo compression, so you won't be hitting this issue.
Someone over at the arch linux forum recently confirmed my assumption that the bfs patch screws up lzo compression:
https://bbs.archlinux.org/viewtopic.php?pid=980278

In fact, I couldn't even get bfs to work with tuxonice and lzf compression, and did never try without any compression at all.

While this may be a problem specific to lzo compression which is not or at least very seldomly caused when using the cfs, I ran into other problems when having bfs applied, like xfce4-cpu-graph plugin suddenly causing 100% cpu load etc. So, while it would be nice and I'd prefer it very much to the cfs, I believe bfs is not ready for primetime in 3.0 kernels. Let's hope Kolivas' patch for linux-3.1 solves all this.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum