Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zahlenblock tut nicht in gnome [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Fri Jul 15, 2011 10:53 am    Post subject: Zahlenblock tut nicht in gnome [solved] Reply with quote

Hallo zusammen,

ich hab folgendes Problem:

Der Zahlenblock der Tastatur fabriziert unter gnome alles mögliche außer Zahlen.

Hier die Konfig:

xorg.conf:
Code:
Section "InputClass"
   Identifier "keyboard"
   Driver "evdev"
   Option "XkbLayout" "de"
   Option "XkbModel" "evdev"
   Option "XkbOptions" "terminate:ctrl_alt_bksp"
   MatchIsKeyboard "on"
EndSection

Section "InputClass"
   Identifier "pointer"
   Driver "evdev"
   MatchIsPointer "on"
EndSection


unter /etc/X11/xorg.conf.d hab ich folgendes :
Code:

li77x111 xorg.conf.d # pwd
/etc/X11/xorg.conf.d
li77x111 xorg.conf.d # ls -l
insgesamt 8
-rw-r--r-- 1 root root  96 15. Jul 12:39 30-mouse.conf
-rw-r--r-- 1 root root 252 15. Jul 12:42 99-keyboard-de.conf
li77x111 xorg.conf.d #



30-mouse.conf
Code:
Section "InputClass"
   Identifier "mouse-all"
   Driver "evdev"
   MatchIsPointer "on"
EndSection


99-keyboard-de.conf
Code:
Section "InputClass"
   Identifier "german keyboard"
   Driver "evdev"
   MatchIsKeyboard "on"
   Option "xkbmodel" "evdev"
   Option "xkblayout" "de-latin1"
   Option "xkbvariant" "nodeadkeys"
   Option "xkbrules" "base"
EndSection


xinput --list liefert das
Code:

xinput --list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ <default pointer>                          id=6   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ <default keyboard>                         id=7   [slave  keyboard (3)]


Alles andere der Tastatur (normaler Bereich, Multimediakeys) funktioniert.
Es ändert nichts wenn ich NUM-Lock ein oder ausschalte.
Ich hab auch mal die Tastatur gewechselt, um auszuschließen, dass diese kaputt ist.

In Gnome hab ich Belegung Deutsch und Tastaturmodell "Logitech Media Elite Keyboard" eingestellt.
Es ist ein Logitech Media Keyboard 600.
Auch wenn ich hier auf eine "Generische PC Tastatur mit 105 Tasten (Intl)" umstelle, ändert das nix.

Achso, das Ding ist per USB dran.

Irgendwelche Tipps?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes


Last edited by tazinblack on Wed Aug 24, 2011 2:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Tue Jul 19, 2011 8:33 am    Post subject: Reply with quote

----> schieb ---->

76 Aufrufe und keiner hat eine Idee?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
wols
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2005
Posts: 90
Location: Franken

PostPosted: Tue Jul 19, 2011 6:07 pm    Post subject: Reply with quote

Code:
grep 'key' /var/log/Xorg.0.log

...was Interessantes?
_________________
Mit freundlichen Grüßen
*WOL*fgang *S*chricker
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Tue Jul 19, 2011 7:18 pm    Post subject: Reply with quote

Wegen des Titels.. läuft der Zahlenblock denn unter einer anderen Desktop Umgebung wie fluxbox?

Verwendest du das alte Gnome oder Gnome 3.0?
Auf der tty funktioniert der Ziffernblock?
Deine Tastatur Verhält sich in einem aktuellen Live-DVD Linux normal?

Ich würde verschiedene Konfigurationen des X-Servers probieren. Am besten erst mal so minimal wie möglich. Vielleicht gar keine. Anschließend Stück für Stück aktualisieren.

Mit verschiedenen selbst angepassten "xmodmap" Konfigurationen hatte ich in letzter Zeit Probleme. Aber auch wieder nur unter Gnome 3.0
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Wed Jul 20, 2011 10:12 am    Post subject: Reply with quote

wols wrote:
Code:
grep 'key' /var/log/Xorg.0.log

...was Interessantes?


Code:

[100397.571] (==) |-->Input Device "<default keyboard>"
[100397.571] (==) The core keyboard device wasn't specified explicitly in the layout.
   Using the default keyboard configuration.
[100398.751] (**) <default keyboard>: always reports core events
[100398.751] (II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD)

_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Wed Jul 20, 2011 10:14 am    Post subject: Reply with quote

ChrisJumper wrote:
Wegen des Titels.. läuft der Zahlenblock denn unter einer anderen Desktop Umgebung wie fluxbox?

Verwendest du das alte Gnome oder Gnome 3.0?
Auf der tty funktioniert der Ziffernblock?
Deine Tastatur Verhält sich in einem aktuellen Live-DVD Linux normal?

Ich würde verschiedene Konfigurationen des X-Servers probieren. Am besten erst mal so minimal wie möglich. Vielleicht gar keine. Anschließend Stück für Stück aktualisieren.

Mit verschiedenen selbst angepassten "xmodmap" Konfigurationen hatte ich in letzter Zeit Probleme. Aber auch wieder nur unter Gnome 3.0


Fluxbox müsste ich extra bauen.

Gnome ist Version 2.32.1.
Auf der tty geht alles.
Die Konfig des X-Servers ist oben und ich denke viel ist es nicht.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Wed Jul 20, 2011 1:10 pm    Post subject: Reply with quote

Hmm.., ich hab zwar keine Ahnung von Gnome und auch nicht von Zahlenblöcken..
aber,
ich denke du konfigurierst einfach zu viel.
Normal sollten die meisten defaults schon passen
dann kommt deine /etc/X11/xorg.conf.d/99-keyboard-de.conf
dann noch Settings aus der xorg.conf (die anderswo gesetztes wieder überschreibt)
und dann womöglich auch noch eine Konfiguration des Keyboards von Gnome aus,
ich denke das ist einfach zu viel des guten und auch nicht nötig.
Versuche es doch mal mit weniger Konfiguration.

btw
Beachte auch das es eine passende Keymap für dein "Logitech Media Elite Keyboard" gibt, wenn du diese nutzen möchtest dann setze sie mit
Code:
Option         "XkbModel" "logimel"


Die jeweiligen Bezeichnungen können zb in der /usr/share/X11/xkb/rules/base.lst eingesehen werden.
Code:
grep "Media Elite" /usr/share/X11/xkb/rules/base.lst
  logimel         Logitech Media Elite Keyboard
Back to top
View user's profile Send private message
TheSmallOne
Guru
Guru


Joined: 22 Jan 2005
Posts: 461
Location: Germany

PostPosted: Thu Jul 21, 2011 6:31 am    Post subject: Re: Zahlenblock tut nicht in gnome Reply with quote

tazinblack wrote:

99-keyboard-de.conf
Code:
Section "InputClass"
   Identifier "german keyboard"
   Driver "evdev"
   MatchIsKeyboard "on"
   Option "xkbmodel" "evdev"
   Option "xkblayout" "de-latin1"
   Option "xkbvariant" "nodeadkeys"
   Option "xkbrules" "base"
EndSection



Hm, sind die Optionen case-sensitive, oder nicht?

Wie auch immer, ich denke es wäre vielleicht ganz gut sich an das Problem heranzuarbeiten und mit:
Code:
Option "XkbLayout" "de"
   Option "XkbVariant" "basic"

anzufangen.
Wenn der Ziffernblock da funktioniert, dann liegt es am geänderten Layout.


Obwohl, da fällt mir ein, das Gnome sich ab irgendeiner der neueren Versionen sowieso nicht mehr an das hält, was für die Tastatur im X-Server konfiguriert wurde, sondern nur die Einstellungen aus System > Einstellungen > Tastatur (im Gnome Menü) berücksichtigt. Vielleicht da mal ein wenig herumspielen.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Wed Aug 24, 2011 2:44 pm    Post subject: Reply with quote

Also nachdem ich vor dem Urlaub noch total dran verzweifelt bin, hab ich jetzt einfach mal die ganze gconf-konfiguration weggeworfen.
Und siehe da, jetzt spurt auch meine Tastatur wieder.
Also, war entweder ne zerschossene oder total veraltete Gnomekonfig.

Danke Euch für die Tipps, hab wieder einiges dazugelernt.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum