Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keyboard und Maus funktionieren nicht nach emerge --updat
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Eisenhorn
n00b
n00b


Joined: 04 Jul 2011
Posts: 20

PostPosted: Sun Jul 17, 2011 11:10 pm    Post subject: Keyboard und Maus funktionieren nicht nach emerge --updat Reply with quote

Hallo,

Ich habe ein emerge --updat --ask world durchgeführt und nun geht die Maus und das Keyboard unter KDE nicht. In der bash (bevor der kdm startet) kann ich noch eingaben tätigen.
Auszug aus xorg.conf

Code:

...

Section "Module"
   Load  "dbe"
   Load  "glx"
   Load  "record"
   #Load  "dri2"
   #Load  "dri"      
   Load  "extmod"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
        Option "XkbLayout"    "us,de"
        Option "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

...



kwinrc

Code:
[$Version]
update_info=kwin_focus2.upd:kwin_focus2,kwin3_plugin.upd:kde3.2,kwin.upd:kde3.0r1,kwin.upd:kde3.2Xinerama,kwin_on_off.upd:kwin_on_off,kwin_focus1.upd:kwin_focus1

[Compositing]
CheckIsSafe=true
Enabled=false
OpenGLIsUnsafe=false

[Desktops]
Name_1=
Name_2=
Name_3=
Name_4=
Number=4

[TabBox]
ListMode=0
ShowTabBox=true

[Windows]
IgnoreFocusStealingClasses=kio_uiserver


Und die /etc/conf.d/xdm

Code:
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | kdm-4.3 | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
#
# KDE-specific note:
# - If you are using kdeprefix go with "kdm-4.Y", e.g. "kdm-4.3".
#     You can find possible versions by looking at the directories in /usr/kde/.
# - Else, if you are using KDE 3 enter "kdm-3.5"
# - Else, if you are using KDE 4 enter "kdm" without a version
DISPLAYMANAGER="kdm"


Hat jemand eine Idee was der Grund dafür sein könnte?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Mon Jul 18, 2011 12:47 am    Post subject: Reply with quote

Klingt danach als hast du den Xorg-Server Aktualisiert. Und dabei die Mitteilung/Hinweise nicht verfolgt die der Emerge-Vorgang am Ende ausgibt.

Der Xserver verwendet verschiedene Pakete/Module die entsprechend gegen die aktuelle Version des Xservers gebaut werden müssen, damit sie "passen". Schau dir z.B. mal die Xorg.0.log Datei an. Sie liegt gewöhnlich im Verzeichnis: /var/log/Xorg.0.log

Hier ein Beispiel für das evdev-Modul, welches in diesem Fall für den Xserver 1.10.2 compiliert wurde.

Quote:
(II) LoadModule: "evdev"
[ 10.355] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 10.355] (II) Module evdev: vendor="X.Org Foundation"
[ 10.355] compiled for 1.10.2, module version = 2.6.0
[ 10.355] Module class: X.Org XInput Driver
[ 10.355] ABI class: X.Org XInput driver, version 12.2


Würde ich jetzt x11-base/xorg-drivers-1.10.3 emerge müsste ich die verwendeten Module neu bauen. Ich vermute genau das ist bei dir der Fall.

Schau nach welche x11-drivers/xf86-input Pakete du installiert hast und emerge diese neue. Also zum Beispiel:

x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-evdev

Welche es genau sind hängt von deinen Treibern und verwendeten Hardware ab.
Back to top
View user's profile Send private message
Eisenhorn
n00b
n00b


Joined: 04 Jul 2011
Posts: 20

PostPosted: Mon Jul 18, 2011 8:27 am    Post subject: Reply with quote

Danke für deine schnelle Antwort. Bin noch ein noob in Linux/Gentoo.

Hier alle (EE) Meldungen aus dem Xorg.0.log
Code:
[    15.471] Current Operating System: Linux OPPENHEIMER_GENTOO 2.6.38-gentoo-r6 #1 SMP PREEMPT Wed Jul 6 14:32:34 CEST 2011 i686
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    17.585] (II) Loading extension MIT-SCREEN-SAVER
[    17.644] (EE) Failed to load module "dri" (module does not exist, 0)
[    17.644] (EE) Failed to load module "dri2" (module does not exist, 0)
[    20.457] (EE) NVIDIA: Failed to load module "dri2" (module does not exist, 0)
[    21.060] (EE) module ABI major version (11) doesn't match the server's version (12)
[    21.060] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[    21.060] (EE) No input driver matching `evdev'
[    21.062] (EE) module ABI major version (11) doesn't match the server's version (12)
[    21.062] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[    21.062] (EE) No input driver matching `evdev'
[    21.075] (EE) module ABI major version (11) doesn't match the server's version (12)
[    21.075] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[    21.075] (EE) No input driver matching `evdev'
[    21.076] (EE) module ABI major version (11) doesn't match the server's version (12)
[    21.076] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[    21.076] (EE) No input driver matching `evdev'
[    21.077] (EE) module ABI major version (11) doesn't match the server's version (12)
[    21.077] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[    21.077] (EE) No input driver matching `evdev'


Hier die Warnung von Relevanz
Code:
  15.621] (**) ModulePath set to "/usr/lib/xorg/modules"
[    15.621] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    15.621] (WW) Disabling Mouse0
[    15.621] (WW) Disabling Keyboard0
[    15.621] (II) Loader magic: 0x81e7d80
[    15.621] (II) Module ABI versions:


Hier die ganze Liste

Code:
[    14.762]
X.Org X Server 1.10.2
Release Date: 2011-05-28
[    14.763] X Protocol Version 11, Revision 0
[    14.763] Build Operating System: Linux 2.6.38-gentoo-r6 i686 Gentoo
[    14.763] Current Operating System: Linux OPPENHEIMER_GENTOO 2.6.38-gentoo-r6 #1 SMP PREEMPT Wed Jul 6 14:32:34 CEST 2011 i686
[    14.763] Kernel command line: root=/dev/sda3
[    14.763] Build Date: 17 July 2011  11:45:58PM
[    14.763] 
[    14.763] Current version of pixman: 0.22.0
[    14.763]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    14.763] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    14.763] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 18 10:02:30 2011
[    14.828] (==) Using config file: "/etc/X11/xorg.conf"
[    14.828] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    14.843] (==) ServerLayout "X.org Configured"
[    14.843] (**) |-->Screen "Screen0" (0)
[    14.843] (**) |   |-->Monitor "Monitor0"
[    14.843] (**) |   |-->Device "Card0"
[    14.843] (**) |-->Input Device "Mouse0"
[    14.843] (**) |-->Input Device "Keyboard0"
[    14.843] (**) Option "AutoAddDevices" "false "
[    14.843] (**) Not automatically adding devices
[    14.843] (==) Automatically enabling devices
[    14.889] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    14.890]    Entry deleted from font path.
[    14.890] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    14.890]    Entry deleted from font path.
[    14.890] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    14.890]    Entry deleted from font path.
[    14.890] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    14.890]    Entry deleted from font path.
[    14.890]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    14.890] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    14.890]    Entry deleted from font path.
[    14.890]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    14.890] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    14.890]    Entry deleted from font path.
[    14.890] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    14.890]    Entry deleted from font path.
[    14.890] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    14.891]    Entry deleted from font path.
[    14.891] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    14.891]    Entry deleted from font path.
[    14.891]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    14.891] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    14.891]    Entry deleted from font path.
[    14.891]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    14.891] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/misc/
[    14.891] (**) ModulePath set to "/usr/lib/xorg/modules"
[    14.891] (II) Loader magic: 0x81e7d80
[    14.891] (II) Module ABI versions:
[    14.891]    X.Org ANSI C Emulation: 0.4
[    14.891]    X.Org Video Driver: 10.0
[    14.891]    X.Org XInput driver : 12.2
[    14.891]    X.Org Server Extension : 5.0
[    14.892] (--) PCI:*(0:1:0:0) 10de:01d8:104d:81e6 rev 161, Mem @ 0xdd000000/16777216, 0xc0000000/268435456, 0xdc000000/16777216
[    14.892] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    14.892] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[    14.892] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[    14.892] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    14.892] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[    14.892] (II) "dri" will be loaded by default.
[    14.892] (II) "dri2" will be loaded by default.
[    14.892] (II) LoadModule: "dbe"
[    14.929] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    14.944] (II) Module dbe: vendor="X.Org Foundation"
[    14.944]    compiled for 1.10.2, module version = 1.0.0
[    14.944]    Module class: X.Org Server Extension
[    14.944]    ABI class: X.Org Server Extension, version 5.0
[    14.944] (II) Loading extension DOUBLE-BUFFER
[    14.944] (II) LoadModule: "glx"
[    14.993] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    16.853] (II) Module glx: vendor="NVIDIA Corporation"
[    16.853]    compiled for 4.0.2, module version = 1.0.0
[    16.853]    Module class: X.Org Server Extension
[    16.853] (II) NVIDIA GLX Module  270.41.06  Mon Apr 18 15:11:28 PDT 2011
[    16.853] (II) Loading extension GLX
[    16.853] (II) LoadModule: "record"
[    16.853] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    16.869] (II) Module record: vendor="X.Org Foundation"
[    16.869]    compiled for 1.10.2, module version = 1.13.0
[    16.869]    Module class: X.Org Server Extension
[    16.869]    ABI class: X.Org Server Extension, version 5.0
[    16.869] (II) Loading extension RECORD
[    16.869] (II) LoadModule: "extmod"
[    16.869] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    16.888] (II) Module extmod: vendor="X.Org Foundation"
[    16.888]    compiled for 1.10.2, module version = 1.0.0
[    16.888]    Module class: X.Org Server Extension
[    16.888]    ABI class: X.Org Server Extension, version 5.0
[    16.888] (II) Loading extension MIT-SCREEN-SAVER
[    16.888] (II) Loading extension XFree86-VidModeExtension
[    16.888] (II) Loading extension XFree86-DGA
[    16.888] (II) Loading extension DPMS
[    16.888] (II) Loading extension XVideo
[    16.888] (II) Loading extension XVideo-MotionCompensation
[    16.888] (II) Loading extension X-Resource
[    16.888] (II) LoadModule: "dri"
[    16.946] (WW) Warning, couldn't open module dri
[    16.946] (II) UnloadModule: "dri"
[    16.946] (II) Unloading dri
[    16.947] (EE) Failed to load module "dri" (module does not exist, 0)
[    16.947] (II) LoadModule: "dri2"
[    16.947] (WW) Warning, couldn't open module dri2
[    16.947] (II) UnloadModule: "dri2"
[    16.947] (II) Unloading dri2
[    16.947] (EE) Failed to load module "dri2" (module does not exist, 0)
[    16.947] (II) LoadModule: "nvidia"
[    16.947] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    17.059] (II) Module nvidia: vendor="NVIDIA Corporation"
[    17.059]    compiled for 4.0.2, module version = 1.0.0
[    17.059]    Module class: X.Org Video Driver
[    17.102] (II) LoadModule: "mouse"
[    17.102] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[    17.111] (II) Module mouse: vendor="X.Org Foundation"
[    17.111]    compiled for 1.9.5, module version = 1.7.0
[    17.111]    Module class: X.Org XInput Driver
[    17.111]    ABI class: X.Org XInput driver, version 11.0
[    17.111] (EE) module ABI major version (11) doesn't match the server's version (12)
[    17.111] (II) UnloadModule: "mouse"
[    17.111] (II) Unloading mouse
[    17.111] (EE) Failed to load module "mouse" (module requirement mismatch, 0)
[    17.111] (II) LoadModule: "kbd"
[    17.111] (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
[    17.120] (II) Module kbd: vendor="X.Org Foundation"
[    17.120]    compiled for 1.9.5, module version = 1.6.0
[    17.120]    Module class: X.Org XInput Driver
[    17.120]    ABI class: X.Org XInput driver, version 11.0
[    17.120] (EE) module ABI major version (11) doesn't match the server's version (12)
[    17.120] (II) UnloadModule: "kbd"
[    17.120] (II) Unloading kbd
[    17.120] (EE) Failed to load module "kbd" (module requirement mismatch, 0)
[    17.121] (II) NVIDIA dlloader X Driver  270.41.06  Mon Apr 18 14:55:51 PDT 2011
[    17.137] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    17.147] (++) using VT number 7

[    17.172] (II) Loading sub module "fb"
[    17.172] (II) LoadModule: "fb"
[    17.172] (II) Loading /usr/lib/xorg/modules/libfb.so
[    17.186] (II) Module fb: vendor="X.Org Foundation"
[    17.186]    compiled for 1.10.2, module version = 1.0.0
[    17.186]    ABI class: X.Org ANSI C Emulation, version 0.4
[    17.187] (II) Loading sub module "wfb"
[    17.187] (II) LoadModule: "wfb"
[    17.187] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    17.200] (II) Module wfb: vendor="X.Org Foundation"
[    17.200]    compiled for 1.10.2, module version = 1.0.0
[    17.200]    ABI class: X.Org ANSI C Emulation, version 0.4
[    17.200] (II) Loading sub module "ramdac"
[    17.200] (II) LoadModule: "ramdac"
[    17.200] (II) Module "ramdac" already built-in
[    17.218] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    17.218] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    17.218] (II) Loading /usr/lib/xorg/modules/libfb.so
[    17.244] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    17.244] (==) NVIDIA(0): RGB weight 888
[    17.244] (==) NVIDIA(0): Default visual is TrueColor
[    17.244] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    18.397] (II) NVIDIA(GPU-0): Display (Nvidia Default Flat Panel (DFP-0)) does not support
[    18.397] (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
[    18.412] (II) NVIDIA(0): NVIDIA GPU GeForce Go 7400 (G72) at PCI:1:0:0 (GPU-0)
[    18.412] (--) NVIDIA(0): Memory: 131072 kBytes
[    18.412] (--) NVIDIA(0): VideoBIOS: 05.72.22.41.19
[    18.412] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    18.412] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    18.412] (--) NVIDIA(0): Connected display device(s) on GeForce Go 7400 at PCI:1:0:0
[    18.412] (--) NVIDIA(0):     Nvidia Default Flat Panel (DFP-0)
[    18.412] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): 330.0 MHz maximum pixel
[    18.412] (--) NVIDIA(0):     clock
[    18.412] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Internal Dual Link LVDS
[    18.412] (II) NVIDIA(0): Assigned Display Device: DFP-0
[    18.412] (==) NVIDIA(0):
[    18.412] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    18.412] (==) NVIDIA(0):     will be used as the requested mode.
[    18.412] (==) NVIDIA(0):
[    18.412] (II) NVIDIA(0): Validated modes:
[    18.412] (II) NVIDIA(0):     "nvidia-auto-select"
[    18.412] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 800
[    18.413] (--) NVIDIA(0): DPI set to (101, 101); computed from "UseEdidDpi" X config
[    18.413] (--) NVIDIA(0):     option
[    18.413] (--) Depth 24 pixmap format is 32 bpp
[    18.420] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    18.420] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    18.420] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    18.420] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    18.420] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    18.420] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    18.420] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    18.420] (II) NVIDIA(0):     Config Options in the README.
[    18.420] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[    19.913] (II) Loading extension NV-GLX
[    19.979] (==) NVIDIA(0): Disabling shared memory pixmaps
[    19.979] (==) NVIDIA(0): Backing store disabled
[    19.979] (==) NVIDIA(0): Silken mouse enabled
[    19.980] (==) NVIDIA(0): DPMS enabled
[    19.980] (II) Loading extension NV-CONTROL
[    19.981] (II) Loading extension XINERAMA
[    19.981] (II) Loading sub module "dri2"
[    19.981] (II) LoadModule: "dri2"
[    19.981] (WW) Warning, couldn't open module dri2
[    19.981] (II) UnloadModule: "dri2"
[    19.981] (II) Unloading dri2
[    19.981] (EE) NVIDIA: Failed to load module "dri2" (module does not exist, 0)
[    19.981] (II) NVIDIA(0): The X server will not be able to send the VDPAU driver name to
[    19.981] (II) NVIDIA(0):     libvdpau.
[    19.981] (==) RandR enabled
[    19.981] (II) Initializing built-in extension Generic Event Extension
[    19.981] (II) Initializing built-in extension SHAPE
[    19.981] (II) Initializing built-in extension MIT-SHM
[    19.981] (II) Initializing built-in extension XInputExtension
[    19.981] (II) Initializing built-in extension XTEST
[    19.981] (II) Initializing built-in extension BIG-REQUESTS
[    19.981] (II) Initializing built-in extension SYNC
[    19.981] (II) Initializing built-in extension XKEYBOARD
[    19.981] (II) Initializing built-in extension XC-MISC
[    19.981] (II) Initializing built-in extension XINERAMA
[    19.981] (II) Initializing built-in extension XFIXES
[    19.981] (II) Initializing built-in extension RENDER
[    19.982] (II) Initializing built-in extension RANDR
[    19.982] (II) Initializing built-in extension COMPOSITE
[    19.982] (II) Initializing built-in extension DAMAGE
[    19.982] (II) Initializing extension GLX
[    20.548] (II) LoadModule: "mouse"
[    20.548] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[    20.548] (II) Module mouse: vendor="X.Org Foundation"
[    20.548]    compiled for 1.9.5, module version = 1.7.0
[    20.548]    Module class: X.Org XInput Driver
[    20.548]    ABI class: X.Org XInput driver, version 11.0
[    20.548] (EE) module ABI major version (11) doesn't match the server's version (12)
[    20.548] (II) UnloadModule: "mouse"
[    20.548] (II) Unloading mouse
[    20.548] (EE) Failed to load module "mouse" (module requirement mismatch, 0)
[    20.548] (EE) No input driver matching `mouse'
[    20.548] (II) LoadModule: "kbd"
[    20.548] (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
[    20.548] (II) Module kbd: vendor="X.Org Foundation"
[    20.548]    compiled for 1.9.5, module version = 1.6.0
[    20.548]    Module class: X.Org XInput Driver
[    20.548]    ABI class: X.Org XInput driver, version 11.0
[    20.548] (EE) module ABI major version (11) doesn't match the server's version (12)
[    20.548] (II) UnloadModule: "kbd"
[    20.548] (II) Unloading kbd
[    20.548] (EE) Failed to load module "kbd" (module requirement mismatch, 0)
[    20.548] (EE) No input driver matching `kbd'
[    20.570] (II) config/udev: Adding input device Sony Vaio Keys (/dev/input/event2)
[    20.571] (II) AutoAddDevices is off - not adding device.
[    20.572] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    20.572] (II) AutoAddDevices is off - not adding device.
[    20.572] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    20.572] (II) AutoAddDevices is off - not adding device.
[    20.585] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[    20.585] (II) AutoAddDevices is off - not adding device.
[    20.585] (II) config/udev: Adding input device PS/2 Mouse (/dev/input/event5)
[    20.585] (II) AutoAddDevices is off - not adding device.
[    20.586] (II) config/udev: Adding input device PS/2 Mouse (/dev/input/mouse1)
[    20.586] (II) AutoAddDevices is off - not adding device.
[    20.586] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event6)
[    20.586] (II) AutoAddDevices is off - not adding device.
[    20.587] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse2)
[    20.587] (II) AutoAddDevices is off - not adding device.
[    20.593] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/event3)
[    20.593] (II) AutoAddDevices is off - not adding device.
[    20.593] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/mouse0)
[    20.593] (II) AutoAddDevices is off - not adding device.



Was mir auffällt ist, dass überall steht compiled for xxx, module version = xxx und die module Version dann kleiner ist, als wie es kompliert wurde.


Wäherend ich hier schreibe habe ich genau die Pakete neu gebaut.
Quote:
Schau nach welche x11-drivers/xf86-input Pakete du installiert hast und emerge diese neue. Also zum Beispiel:

x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-evdev


Jetzt haut es wieder hin!! Vielen Dank!

Schaut emerge also automatisch nach der akutellen Verison?
Würde emerge --update --deep world das automatisch mit erledigen?

Vielen Dank nich einmal!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Mon Jul 18, 2011 10:08 am    Post subject: Reply with quote

Eisenhorn wrote:
Schaut emerge also automatisch nach der akutellen Verison?
Ja, portage wird normal immer die aktuelle Version mergen.

Quote:
Würde emerge --update --deep world das automatisch mit erledigen?
Nein in diesem Fall nicht, denn es sind ja i.d.R schon die x11-drivers in der aktuellen Version installiert, von daher gibt es da nichts upzudaten.

Das "Problem" ist wenn im Nachhinein ein xorg-server mit einer neuen Major Version installiert wird (zb von 1.9 auf 1.10 usw) dann sind die aktuell schon installierten x11-drivers einfach nicht mehr kompatibel (ja auch wenn es die aktuelle Version ist) und müssen neu passend zum ABI des neuen xorg-servers gebaut werden.
Bei den kleineren Updates, zb von xorg-server-1.10.2 auf 1.10.3 ist es nicht nötig die Treiber neu zu übersetzen, denn da gibt es ja kein ABI Wechsel.

Normal sollte in den postinstall-messages aber auch drauf hingewiesen werden wenn es ein ABI wechsel gab.
Laut Ebuild würde folgendes angewendet und ggf eine Warnung ausgegeben
xorg-server-1.10.2.ebuild wrote:
Code:
pkg_postinst() {
        # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
        eselect opengl set xorg-x11 --use-old

        if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
                elog "You should consider reading upgrade guide for this release:"
                elog "  http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-$(get_version_component_range 1-2)-upgrade-guide.xml"
                echo
                ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
                ewarn "because the ABI changed. If you cannot start X because"
                ewarn "of module version mismatch errors, this is your problem."

                echo
                ewarn "You can generate a list of all installed packages in the x11-drivers"
                ewarn "category using this command:"
                ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
                ewarn "or using sets from portage-2.2:"
                ewarn " emerge @x11-module-rebuild"
        fi
}

Das heißt du wirst zwar drauf hingewiesen müsstest dich aber selber darum kümmern
Ein rebuild der schon installierten Treiber kann zb via
Code:
emerge -av --oneshot  $(qlist -I -C x11-drivers)
erledigt werden.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum