Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome3 installation broken after recent update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Thu Jul 21, 2011 10:52 am    Post subject: gnome3 installation broken after recent update Reply with quote

hello there,

i had a nicely running gnome3 installation until last world update (2 days ago). Now just after login with gdm, i can only see mouse cursor on the default gdm background, mouse and keyboard working just fine. There is no useful informations in /var/logs/messages nor ~/.xsession-errors

I also made an experiment and tried to login without gdm, so i made ~/.xinitrc file with "exec gnome-session" content.
After startx command, gnome-shell startup, i can see my wallpaper, everything looks good at 1st sight - but when i press "super key" to enter shell menu, its empty, there isnt any icon on left bar, and when i click "Applications" button gnome-shell crash! :(

as there is no usefull error message i can only ask if someone have a simmilar problem.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5618
Location: Removed by Neddy

PostPosted: Thu Jul 21, 2011 11:22 am    Post subject: Reply with quote

Did you by any chance also update nvidia-drivers to 275-19? THese drivers have an issue with gdm at the moment
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Thu Jul 21, 2011 12:40 pm    Post subject: Reply with quote

That's it!
After downgrade to nvidia-drivers-275.09 everything working as usual.

Thanks
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Sun Jul 24, 2011 2:51 pm    Post subject: Reply with quote

Do you emerge icu?

Some problem in gnome-2.3

solution revdep-rebuild.
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Sun Jul 24, 2011 7:40 pm    Post subject: Reply with quote

No, I didn't
As I mentioned in post above, problem was in latest nvidia-drivers.

Thanks for interest.
Back to top
View user's profile Send private message
newfuntek
n00b
n00b


Joined: 28 Jun 2006
Posts: 30
Location: Poland

PostPosted: Sat Aug 27, 2011 6:09 pm    Post subject: Reply with quote

Use gnome-next branch from gnome overlay:
http://forums.funtoo.org/viewtopic.php?pid=3368

For gnome-shell crash you need only this unicode date format removal:

https://bugzilla.redhat.com/show_bug.cgi?id=703060
https://bugzilla.mozilla.org/show_bug.cgi?id=508783
_________________
gcc 8.1.0 lto graphite, rpi3 gcc 7.3.0
Tools for easy installation of Gentoo Linux (comments in Polish)
https://github.com/pwasiewi/gentools
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum