Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[AMD64-GNOME] les tracas d'une installation béotienne
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Bruneau
n00b
n00b


Joined: 27 Jul 2011
Posts: 6

PostPosted: Thu Jul 28, 2011 12:16 pm    Post subject: [AMD64-GNOME] les tracas d'une installation béotienne Reply with quote

Bonjour,

Nouveau sur gentoo et sur ce forum merci par avance de votre aide.

Noyau genkernel AMD64 + gnome (emerge gnome)

1) Je n'ai pas de copier/coller d'une fenêtre à l'autre (ex. : d'Epiphanie vers terminal en fenêtre)
2) Le clavier numérique n'est jamais enclenché ni en console ni sous gnome ni en terminal
3) les clé USB sont montées mais pas ouvrable car "unable to mount -Not autorize" et le groupe UDEV n'existe pas
4) le réseau ne monte pas. je dois faire un dhcpcd eth0 en root. Lorsque j'essaie de monter le service il ne trouve pas eth0
5) malgré l'application de la localisation fr du guide, gnome reste bien british

Plus un tas d'insulte au lancement de startx ... comment les récupérer dans un log ?
Je n'ai pas installé HAL cela peut-il venir de là ?

J'ai du manquer quelque chose de balèze et je livre donc toutes ces imperfections pour vous permettre d'identifier le manque.

Merci.


Last edited by Bruneau on Thu Jul 28, 2011 2:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8129
Location: ~Brussels - Belgique

PostPosted: Thu Jul 28, 2011 12:33 pm    Post subject: Reply with quote

Bonjour,

Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et donne-nous des informations supplémentaires, comme la sortie de
Code:
emerge --info

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Thu Jul 28, 2011 1:10 pm    Post subject: Re: les tracas d'une installation béotienne AMD64 + gnome Reply with quote

Bruneau wrote:
Nouveau sur gentoo et sur ce forum merci par avance de votre aide.

<trolling>Nouveau et Béotien ? Ya pas un forum dédié grec dans le coin ?</trolling>

1) Je n'y connais rien !
2) Si tu peux lire l'anglais, je te suggère la lecture de : http://en.gentoo-wiki.com/wiki/Numlock
3) Depuis la déprécation de hal, il y a un certain nombre de conditions particulières pour autoriser cela. Je te suggère la lecture de : http://www.funtoo-quebec.org/wiki/index.php/Delestage_de_hal. Il existe un topic sur le forum gentoo mais en Anglais. Si tu préfères, je te le retrouverai.
4) Je n'y connais rien.
5) Je n'y connais rien.

Bruneau wrote:
Je n'ai pas installé HAL cela peut-il venir de là ?
cf 3.
Bruneau wrote:
Plus un tas d'insulte au lancement de startx ... comment les récupérer dans un log ?

Tout devrait logiquement se trouver dans /var/log/xorg.0.log
Back to top
View user's profile Send private message
Bruneau
n00b
n00b


Joined: 27 Jul 2011
Posts: 6

PostPosted: Thu Jul 28, 2011 3:07 pm    Post subject: Reply with quote

OK XavierMiller, le titre est conforme mantenant ?

Le emerge --info
Code:
Portage 2.1.10.3 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 28 Jul 2011 12:45:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -mno-avx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mno-avx"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr en"
MAKEOPTS="-j16"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync3.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk iconv ipv6 jpeg lcms libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline sdl session spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel intel8x0 intel8x0m usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint radeon vesa v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


aCOSwt :
Quote:
2) Si tu peux lire l'anglais, je te suggère la lecture de : http://en.gentoo-wiki.com/wiki/Numlock

Effectivement je vais voir car cela semble correspondre au problème, je n'avais rien vu sur le sujet dans le doc d'installation.

Quote:
3) Depuis la déprécation de hal, il y a un certain nombre de conditions particulières pour autoriser cela. Je te suggère la lecture de : http://www.funtoo-quebec.org/wiki/index.php/Delestage_de_hal. Il existe un topic sur le forum gentoo mais en Anglais. Si tu préfères, je te le retrouverai.

J'ai vu ce document mais en bon débutant l'explication et toutes les options sont interessante mais ... j'installe ou pas ? Y a les pour, les contres et les indécis et, à la réflexion je pense que les difficultés que j'évoque viennent plutot de paramètrage (cf. point 2).

Le /var/log/xorg.0.log retrace le lancement qui se passe trés bien. C'est aprés que cela se gate, par ex. :
Code:
Messages : Numlock remembering disable because hostname is set to "localhost"
(gdm-notification-deamon :18701): libgdu **warning** unhandled property "DeviceAutoMountHint"
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 744
Location: S.O. France

PostPosted: Thu Jul 28, 2011 4:08 pm    Post subject: Reply with quote

Salut,

Que de problemes en un post.
Peux-tu poster:

rc-update show
/etc/locale.gen
/etc/env.d/02locales
ifconfig

Quote:
Je n'ai pas installé HAL cela peut-il venir de là ?

Non

Tu as suivi quel guide pour installer?

1-2-3 ) Devrait etre liés a udev/polkit/consolekit...
4) On verra en fonction des réponses
5) Idem
Back to top
View user's profile Send private message
Bruneau
n00b
n00b


Joined: 27 Jul 2011
Posts: 6

PostPosted: Thu Jul 28, 2011 5:11 pm    Post subject: Reply with quote

Effectivement, de nombreux problèmes mais une finalité l'installation. C'est la limite et je partage que cela fasse auberge espagnole ...

Quote:
#rc-update show
bootmisc | boot
consolekit | default
dbus | default
devfs | sysinit
dmesg | sysinit
fsck | boot
hostname | boot
hwclock | boot
keymaps | boot
killprocs | shutdown
local | default
localmount | boot
modules | boot
mount-ro | shutdown
mtab | boot
net.lo | boot
netmount | default
numlock | default
procfs | boot
root | boot
savecache | shutdown
swap | boot
sysctl | boot
syslog-ng | default
termencoding | boot
udev | sysinit
udev-postmount | default
urandom | boot
vixie-cron | default


Nota : le numlock que j'ai appliqué suite au précédent échange n'a rien changé.

Quote:
cat /etc/locale.gen
en_US ISO-8859-1
en_US.UTF-8 UTF-8
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15
fr_FR.UTF-8 UTF-8


Je n'ai pas de /etc/env.d/02locales. Put... j'étais persuadé l'avoir créé. Je corrige tout de suite.

Pour l'installation j'ai suivi le guide AMD64 http://www.gentoo.org/doc/fr/handbook/handbook-amd64.xml calé avec le même en anglais pour vérifier.
Back to top
View user's profile Send private message
Bruneau
n00b
n00b


Joined: 27 Jul 2011
Posts: 6

PostPosted: Sat Jul 30, 2011 2:20 pm    Post subject: Reply with quote

[...]

C'est réglé, ... je suis retourné à xfce. Au moins ma V0 fonctionne 8) je n'ai plus qu'à l'optimiser :P et je reviendrai vous solliciter :roll:

A+
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum