Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(solved)Problem mit dem mounten eines USB-Gerätes
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Thu Jul 28, 2011 7:59 am    Post subject: (solved)Problem mit dem mounten eines USB-Gerätes Reply with quote

Hallo Gemeinschaft,

ich habe ein kleines Problem zu dem ich leider noch keine Lösung gefunden habe.

Folgendes:
Ich habe ein Handy, das ich per USB ans Notebook anschließe. Udev funktioniert, es wird ein device /dev/legend1 erstellt.
Ich habe Verzeichnis /mnt/legend. Dahin möchte ich es gerne als normaler user mounten.

Eintrag in die /etc/fstab:
Code:

/dev/legend1    /mnt/legend   auto   noauto,users,iocharset=utf8,codepage=850,rw 0 0


Wenn ich als user oder root in der shell
Code:
mount /mnt/legend
eingebe bekomme ich folgende Fehlermeldung:
Code:
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing coepage or helperprogram or other error


Wenn ich als root in der shell aber eingebe:
Code:

mount /dev/legend1 -t auto /mnt/legend

funktioniert es einwandfrei.

Hat jemand einen Tip, was ich verändern muß?

Grüße
aleph


Last edited by aleph-muc on Fri Jul 29, 2011 7:15 pm; edited 2 times in total
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Thu Jul 28, 2011 8:05 am    Post subject: Reply with quote

Hi

1. mount /dev/legend kann nicht gehen. Du versuchst die ganze Platte zu mounten und nicht die Partition. Du musst wenn dann schon mount /dev/legend1 oder mount /mnt/legend eingeben

Was passiert denn wenn du als User folgendes eingibst

Code:
# mount /dev/legend1 /mnt/legend


Funktioniert das?

Sebastian
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Thu Jul 28, 2011 8:10 am    Post subject: Reply with quote

Hi Hollowman,

danke für Deine schnelle Reaktion.

Ist mir ein Tippfehler unterlaufen. Ich gebe in der shell
Code:
mount /mnt/legend
ein.
Habe das oben berichtigt.

grüße
aleph
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3691
Location: Hamburg

PostPosted: Thu Jul 28, 2011 1:29 pm    Post subject: Re: Problem mit dem mounten eines USB-Gerätes Reply with quote

aleph-muc wrote:

Wenn ich als root in der shell aber eingebe:
Code:

mount /dev/legend1 -t auto /mnt/legend

funktioniert es einwandfrei.
Dann tipp doch mal "mount" auf der Kommandozeile ein und schau nach, welche mount Option tatsächlich funktioniert (entweder mit utf8 oder mit der codepage 850 scheint es auf Deinem System Probleme zu geben).
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Thu Jul 28, 2011 3:06 pm    Post subject: Reply with quote

Hi toralf,

ich habe jetzt das Handy als root mit
Code:
mount /dev/legend1 -t auto /mnt/legend
eingehängt.
Wenn ich nun nur das Kommando
Code:
mount
eingebe, kommt folgende Ausgabe:
Code:
rootfs on / type rootfs (rw)
/dev/root on / type ext4 (rw,noatime,commit=0)
devtmpfs on /dev type devtmpfs (rw,relatime,size=4064624k,nr_inodes=1016156,mode=755)
proc on /proc type proc (rw,relatime)
rc-svcdir on /lib64/rc/init.d type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
none on /tmp type tmpfs (rw,noatime)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sdb1 on /mnt/legend type vfat (rw)


Hilft mir aber glaube ich nicht wirklich.

Grüße
aleph
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3691
Location: Hamburg

PostPosted: Thu Jul 28, 2011 3:43 pm    Post subject: Reply with quote

Na dann fang doch mal damit an, einen der beiden Parameter "iocharset=utf8,codepage=850" zu entfernen und es dann schrittweise zu versuchen ...
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Fri Jul 29, 2011 6:58 am    Post subject: Reply with quote

Das habe ich auch schon versucht. Es ändert leider nichts am Ergebnis.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3691
Location: Hamburg

PostPosted: Fri Jul 29, 2011 7:40 am    Post subject: Reply with quote

aleph-muc wrote:
Das habe ich auch schon versucht. Es ändert leider nichts am Ergebnis.
genau, ich befürchte, daß "0 0" stören könnte, die sind - glaube ich - bei FAT nicht notwendigigerweise sinnvoll.
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Fri Jul 29, 2011 8:25 am    Post subject: Reply with quote

Auch das Entfernen dieser Parameter hat leider nicht geholfen.

Ich habe es jetzt auch mit ein paar USB-Sticks versucht. Das gleiche Phänomen. Es liegt also nicht am Handy.
Der zuletzt ausprobierte Eintrag in der fstab lautet:
Code:
/dev/legend1    /mnt/legend    vfat   noauto,users,rw


Ich bin echt ratlos.

Grüße
aleph
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Fri Jul 29, 2011 10:52 am    Post subject: Reply with quote

Hi

was mich irritiert ist die Device-Bezeichnung /dev/legend1
Gibt es in der dmesg Ausgabe, nachdem du dein Laufwerk angesteckt hast keine "normale" Device Benennung wie /dev/sdXX ?
Poste doch ansonsten bitte mal die relevanten Zeilen aus dmesg nachdem du den Stick (oder das Telefon) angesteckt hast.
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Fri Jul 29, 2011 1:14 pm    Post subject: Reply with quote

Hi Josef.95

das Device wird durch eine udev-Regel von mir angelegt.

Wenn ich das Gerät mit:
Code:
mount /dev/legend1 /mnt/legend
als root gemountet habe und dann
Code:
mount
eingebe meldet die shell, dass /dev/sdb1 nach /mnt/legend gemounted ist.

Was ich inzwischen noch gemacht habe:

Ich habe als root die Optionen, die in der fstab stehen in der shell als option zum mount-befehl mitgegeben - Ergebnis, es wird einwandfrei gemounted. Das Problem scheint damit zusammen zu hängen, dass wenn ich kein device im Mountbefehl angebe (egal ob als root oder user) kommt die Fehlermeldung. Wenn ich das device (/dev/legend1) angebe, (was nur als root möglich ist) funktioniert es.

Grüße
aleph
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Fri Jul 29, 2011 1:36 pm    Post subject: Reply with quote

Dann liegt es vermutlich an der udev Regel (und deren mitgegebenen Rechten)

Dein erster (korrigierter) Ansatz aus dem ersten Beitrag sollte so normal eigentlich funktionieren.
Ich hab das mal kurz mit einem vfat Dateisystem auf einem USB-Stick getestet:
fstab
Code:
/dev/sde1                     /mnt/gentoo       vfat  noauto,users,iocharset=utf8,codepage=850,rw 0 0
lässt sich als User problemlos einhängen:
Code:
$ mount /mnt/gentoo

$ mount | grep vfat
/dev/sde1 on /mnt/gentoo type vfat (rw,noexec,nosuid,nodev,iocharset=utf8,codepage=850)
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Fri Jul 29, 2011 1:57 pm    Post subject: Reply with quote

Ich habe auch schon versuchsweise die udev-regel auskommentiert.

Es wird dann das device /dev/sdb1 erstellt. Aber auch das kann ich (nach Korrektur der fstab) nicht mit dem normalen user über
Code:
mount /mnt/legend

mounten.

Grüße
aleph
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Fri Jul 29, 2011 7:18 pm    Post subject: Reply with quote

Oh Mann,

ich traue mich es ja fast nicht zu schreiben, aber es bewahrheitet sich mal wieder der Satz: Wer lesen kann ist im Vorteil.

Ich habe in den optionen der fstab nouat statt noauto geschrieben. :oops:

Vielen Dank für eure Bemühungen.

Grüsse
aleph
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum