Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
flash video will not play through Firefox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
angry_arctic_avian
n00b
n00b


Joined: 24 Oct 2009
Posts: 59

PostPosted: Tue Aug 09, 2011 7:08 am    Post subject: flash video will not play through Firefox Reply with quote

This problem started with the second to last emerge -uDa world. Flash websites, and other flash content work within the capability of my x86 system, yet flash video seems to have gotten progressively worse with each update, to the point that I can no longer play flash video through Firefox. Youtube provides "An error has occured. Please try again later," and before the last world update, even other flash video hosting site gave a message akin to "error loading video url."

Code:

emerge --info
Portage 2.1.10.3 (default/linux/x86/10.0/desktop, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-i686-Intel-R-_Pentium-R-_4_CPU_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 05 Aug 2011 17:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/*****************/Build"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa berkdb bluetooth branding bzip2 cairo canna caps cdda cddb cdinstall cdr clamav cli consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac foomaticdb fortran gdbm gdm gdu gif gimp gnome gpm gtk hald hardened iconv ipv6 java joystick jpeg lcms ldap libcaca libnotify mad matroska mng modules mp3 mp4 mpeg mudflap ncurses nls nocd nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline samba sdl session sockets socks5 spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vdpau vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Adobe Flash has been unmerged and remerged, it is enabled under Firefox, and I have done a myriad of searches on Google, yet haven't found an answer that pertains to my problem. Thank you for reading.
Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 223
Location: France

PostPosted: Wed Aug 10, 2011 9:57 am    Post subject: Reply with quote

Hi angry_arctic_avian,

Before I start answering, I would like to know a few things :
- could you post the url of your Youtube videos which aren't working ?
- what's the exact version of your flash player, with your USE flags ?

Thank you and good luck :]
_________________
Main laptop : T8300 cpu | 200 GB hard drive | 2 GB of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 cpu | 250 GB hard drive | 2 GB of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
angry_arctic_avian
n00b
n00b


Joined: 24 Oct 2009
Posts: 59

PostPosted: Fri Aug 12, 2011 2:15 am    Post subject: Reply with quote

Sorry it took so long to post a response. I got caught up dealing with something else. Here are links to videos that did work before the recent update:

Code:

http://www.youtube.com/watch?v=p1XMr9er6-8

http://www.youtube.com/watch?v=AaEmCFiNqP0


And here are the USE flags that are in my make.conf file:

Code:


USE="X a52 aac aalib acl acpi alsa berkdb bluetooth branding bzip2 cairo canna caps cdda cddb cdinstall cdr clamav cli consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac foomaticdb fortran gdbm gdm gdu gif gimp gnome gpm gtk hald hardened iconv ipv6 java joystick jpeg lcms ldap libcaca libnotify mad matroska mng modules mp3 mp4 mpeg mudflap ncurses nls nocd nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline samba sdl session sockets socks5 spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vdpau vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib"

Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 223
Location: France

PostPosted: Fri Aug 12, 2011 2:23 pm    Post subject: Reply with quote

For now, I have some ideas :

1) Maybe that's an USE flags issue for this package : could you post the ouput of this command ?
Code:
$ emerge -pv adobe-flash


2) Did you try to :
- unmerge flash player
- try to download the player from the official site here
- (only) extract the libflashplayer.so to your firefox's plugin directory : ~/.mozilla/plugins/ (create the plugin/ directory if it doesn't exists)
- test the flash player here and here


Good luck :]
_________________
Main laptop : T8300 cpu | 200 GB hard drive | 2 GB of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 cpu | 250 GB hard drive | 2 GB of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
angry_arctic_avian
n00b
n00b


Joined: 24 Oct 2009
Posts: 59

PostPosted: Sat Aug 13, 2011 8:29 am    Post subject: Reply with quote

Code:

emerge -vp adobe-flash

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-plugins/adobe-flash-10.3.181.34  USE="vdpau -kde" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


I got the same results from unmerging flash and copying the libflashplayer.so from the tar file, from Adobe's site. I think I might try to re-emerge Firefox after I get some sleep and have some time to work on this. I appreciate the help so far.
Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 223
Location: France

PostPosted: Sat Aug 13, 2011 9:31 am    Post subject: Reply with quote

Yeah, try re-emergin Firefox, maybe it could help.

Also, try re-emerging your flash-player without the vdpau USE flag.
_________________
Main laptop : T8300 cpu | 200 GB hard drive | 2 GB of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 cpu | 250 GB hard drive | 2 GB of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Wed Aug 17, 2011 3:58 pm    Post subject: Reply with quote

Hi,

would you give a try to firefox-bin ?

please post
Code:
emerge -pv firefox


Thx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum