Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Paketkonflikte der emul* - libs
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Fri Aug 26, 2011 4:44 pm    Post subject: Paketkonflikte der emul* - libs Reply with quote

Hi,
Mein neuestes World Update bringt folgendes:

Code:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/libmowgli-0.9.50 [0.7.0] USE="-examples" 103 kB
[ebuild     U  ] sys-process/cronbase-0.3.3 [0.3.2-r1] 0 kB
[ebuild     U  ] app-arch/unrar-4.0.7 [3.9.10] 150 kB
[ebuild     U  ] app-misc/editor-wrapper-4 [3] 0 kB
[ebuild     U  ] dev-libs/gmp-5.0.2 [4.3.2] USE="-nocxx" 1,978 kB
[ebuild     U  ] dev-libs/mpfr-3.0.1_p4 [3.0.0_p3] 1,128 kB
[ebuild     U  ] app-emulation/emul-linux-x86-baselibs-20110722 [20110129] USE="-development" 34,381 kB
[ebuild     U  ] app-emulation/emul-linux-x86-compat-20110722 [20100611] USE="(multilib) -development%" 693 kB
[ebuild     U  ] dev-db/sqlite-3.7.7.1 [3.7.6.3] USE="extensions fts3 readline threadsafe -debug -doc -icu -secure-delete -soundex -tcl -test -unlock-notify" 1,708 kB
[ebuild     U  ] sys-apps/busybox-1.19.0 [1.17.4] USE="ipv6 mdev pam -debug -make-symlinks -nfs% -savedconfig (-selinux) -static" 2,118 kB
[ebuild     U  ] sys-devel/binutils-2.21.1-r1 [2.21.1] USE="nls -multislot -multitarget -test -vanilla" 9 kB
[ebuild     U  ] sys-process/vixie-cron-4.1-r11 [4.1-r10] USE="pam -debug (-selinux)" 0 kB
[ebuild  N     ] virtual/cron-0  0 kB
[ebuild     U  ] media-sound/audacious-2.5.4 [2.4.4] USE="nls session sse2 (-altivec) -chardet" 1,193 kB
[ebuild     U  ] media-plugins/audacious-plugins-2.5.4 [2.4.4-r1] USE="aac alsa cdda ffmpeg flac ipv6 libnotify libsamplerate mp3 nls oss sdl sndfile sse2 vorbis -adplug (-aqua) -bs2b -cue -fluidsynth -gnome (-jack) -lame -lirc -midi -mms -mtp -pulseaudio -scrobbler -sid -wavpack" 3,419 kB                       
[ebuild     U  ] app-emulation/emul-linux-x86-opengl-20110722 [20110129-r1] USE="-development" 44,036 kB
[ebuild     U  ] app-emulation/emul-linux-x86-xlibs-20110722 [20110129] USE="opengl -development" 2,586 kB
[ebuild     U  ] app-emulation/emul-linux-x86-gtklibs-20110722 [20110129] USE="-development" 4,714 kB
[ebuild     U  ] app-emulation/emul-linux-x86-medialibs-20110722 [20110129] USE="-development" 7,874 kB
[ebuild     U  ] app-emulation/emul-linux-x86-soundlibs-20110722 [20110129] USE="alsa -development -pulseaudio" 5,966 kB
[ebuild     U  ] app-emulation/emul-linux-x86-sdl-20110722 [20110129] USE="-development -pulseaudio%" 829 kB
[ebuild     U  ] app-emulation/emul-linux-x86-qtlibs-20110722 [20110129] USE="-development" 16,626 kB

Total: 22 packages (21 upgrades, 1 new), Size of downloads: 129,502 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/emul-linux-x86-xlibs:0

  (app-emulation/emul-linux-x86-xlibs-20110129::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20110129 required by (app-emulation/emul-linux-x86-motif-20110129::gentoo, installed)

  (app-emulation/emul-linux-x86-xlibs-20110722::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20110722 required by (app-emulation/emul-linux-x86-sdl-20110722::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

app-emulation/emul-linux-x86-baselibs:0

  (app-emulation/emul-linux-x86-baselibs-20110722::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20110722 required by (app-emulation/emul-linux-x86-medialibs-20110722::gentoo, ebuild scheduled for merge)
    (and 5 more with the same problem)

  (app-emulation/emul-linux-x86-baselibs-20110129::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20110129 required by (app-emulation/emul-linux-x86-xlibs-20110129::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Ich mit mir, ehrlich gesagt, nicht ganz im klaren, wie ich das am besten lösen soll. Deshalb bin ich mal so frei und frag hier mal nach :oops:

vielen Dank
Erdie
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Fri Aug 26, 2011 9:26 pm    Post subject: Reply with quote

app-emulation/emul-linux-x86-motif-20110722 in die package.keywords eintragen, das solltest du zumindest mit der version 20110129 bereits getan haben.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Sat Aug 27, 2011 6:58 am    Post subject: Reply with quote

Das ist ja der Witz: Ich habe keines der Pakete in meine package.keywords eingetragen .. :?

Ich hab das jetzt gemacht, es hilft ;) Danke. Die Motif libs werden vom ICA client gebraucht.
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sat Aug 27, 2011 8:20 am    Post subject: Reply with quote

könnte demnächst auch stable gehen: https://bugs.gentoo.org/show_bug.cgi?id=380507
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum