Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Deutsche Tastatur beim Login
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
gentoo_usr
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jun 2007
Posts: 106

PostPosted: Wed Aug 31, 2011 7:51 pm    Post subject: Deutsche Tastatur beim Login Reply with quote

Ich habe in der Konsole und unter KDM die deutschen Keymaps. Beim Anmeldebildschirm ist jedoch das "us" Keymap eingestellt
Kann mir jemand sagen wie ich das auf "de" ändern kann.

/etc/conf.d/keymaps ist auf "de-latin1"

In xorg.conf:
"XkbLayout" "de"
"XkbModel" "pc105"


mfg
gentoo_usr
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Aug 31, 2011 7:59 pm    Post subject: Reply with quote

Die conf.d/keymap kümmert sich nur um die Login-Konsolen, nicht den DM. Da ist X für zuständig. Entsprechend deines Treibers (input-keyboard, input-evdev) die xorg.conf anpassen.
Ich verwende evdev, zur Konfiguration des evdev liegt in /etc/X11/xorg.conf.d/ die Datei 10-evdev.conf mit folgendem Inhalt für die keyboard-section:
Code:
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option  "XkbLayout" "de(nodeadkeys)"
        Option  "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

// edit:
Sry, deinen Mini-Auszug aus der xorg.conf hab ich übersehen :D
Wenn das nicht funktioniert, hast du irgendwo nen Fehler. Kannst du mal sagen, welchen xf86-input-Treiber du fürs Keyboard verwendest und die komplette Section deiner xorg.conf posten? Danke :)
Back to top
View user's profile Send private message
gentoo_usr
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jun 2007
Posts: 106

PostPosted: Sun Sep 04, 2011 5:17 pm    Post subject: Reply with quote

Hallo hier mal die xorg.conf

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "TouchPad" "CorePointer"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "extmod"
Load "glx"
Load "dbe"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
Identifier "TouchPad"
Driver "synaptics"
Option "SendCoreEvents"
Option "Protocol" "auto-dev"
Option "SHMConfig" "on"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
Option "NoLogo" "true"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



Und ich verwende folgenden Treiber:
x11-drivers/xf86-input-evdev-2.6.0


Dein Beispiel aus der .conf.d hab ich übernommen !

mfg
gentoo_usr
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Mon Sep 05, 2011 2:53 pm    Post subject: Reply with quote

In deiner xorg.conf steht:
Code:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Also stellst du das Layout für "kbd" ein, nicht für evdev.

Bei einem modernen xorg-server sollte es so aussehen:
Code:
Section "InputClass"
    Identifier  "keyboard-all_de"
    Driver      "evdev"
    Option      "XkbLayout"  "de"
    Option      "XkbVariant" "nodeadkeys"
    MatchIsKeyboard "on"
EndSection
Wichtig: InputClass, nicht InputDevice.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
gentoo_usr
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jun 2007
Posts: 106

PostPosted: Mon Sep 05, 2011 7:19 pm    Post subject: Reply with quote

Also hab das mit dem "InputClass" versucht, jedoch funktioniert dann
"/etc/init.d/xdm restart" nichtmehr :(
Hab ich da noch ein Versionsproblem ??
Hab mir die xorg.conf automatisch erstellen lassen !!

mfg
gentoo_usr
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Tue Sep 06, 2011 8:51 am    Post subject: Reply with quote

Also eigentlich brauchst du gar keine xorg.conf mehr, solange du kein spezielles Zeug, wie Dual-Screen, Synaptics-Einstellungen oder eben Tastaturlayouts benötigst. Und letztere brauchst du nur, wenn du einen Fenstermanager (wie OpenBox) verwendest, der keine eigenen Einstellungsmöglichkeiten hat.

Was steht denn in /var/log/Xorg.0.log drin wenn xdm nicht starten will? (egrep "(WW|EE)" /var/log/Xorg.0.log)

Edith merkt noch an: btw.: Ich habe ganz übersehen, dass du KDM benutzt.
Systemeinstellungen -> Anmeldebildschirm -> Sprache
Hier sollte "Deutsch (de)" ausgewählt sein.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Tue Sep 06, 2011 1:19 pm    Post subject: Reply with quote

Yamakuzure wrote:
Also eigentlich brauchst du gar keine xorg.conf mehr, solange du kein spezielles Zeug, wie ....
.....

Für proprietäre Grafik Treiber wie nvidia und fglrx wird afaik auch zwingend eine xorg.conf benötigt.

@gentoo_usr
Es liegt aktuell vermutlich an den nun unpassenden Einträgen in

Section "ServerLayout"
InputDevice "TouchPad" "CorePointer"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

EndSection

Nimm die folgenden ungenutzten Einträge am besten auch noch mit raus:
Code:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
Identifier "TouchPad"
Driver "synaptics"
Option "SendCoreEvents"
Option "Protocol" "auto-dev"
Option "SHMConfig" "on"
EndSection
Back to top
View user's profile Send private message
gentoo_usr
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jun 2007
Posts: 106

PostPosted: Wed Sep 07, 2011 7:35 pm    Post subject: Reply with quote

so hab mal nach deinem Stil auskommentiert... xdm startet nun auch, jedoch ist das layout-Problem immer noch vorhanden :(
woran könnte es noch liegen ??

mfg
gentoo_usr
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Fri Sep 09, 2011 12:54 pm    Post subject: Reply with quote

Ich schau mal heute Abend zu Hause auf meinen Heim-Rechner. Ich hab da ne GeForce-Karte drin und verwende die nvidia-Treiber und alles, inklusive Login, ist brav auf deutsch. Mal schauen, wie es da aussieht.

btw.: Hast du in deine Systemeinstellungen geschaut auf welche Sprache kdm eingestellt ist?
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum