Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Gnome-next how to
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Sun Sep 04, 2011 4:38 pm    Post subject: [Solved] Gnome-next how to Reply with quote

Hi all.
Sorry for the silly question,
I have just reinstalled my gentoo box, I what to use gnome 3 from gnome ovelay in particular gnome-3.1 from gnome-next branch, that I used before I delete all. But now I don't remember how I did, so can you help me?

I have tried with:
git branch gnome-next
git checkout gnome-next
git pull

Gives me error

Code:
You asked me to pull without telling me which branch you
want to merge with, and 'branch.master.merge' in
your configuration file does not tell me either.  Please
name which branch you want to merge on the command line and
try again (e.g. 'git pull  ').
See git-pull(1) for details on the refspec.


But I don't know how to configure git.

Thanks
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870


Last edited by yellowhat on Sun Sep 04, 2011 5:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Sun Sep 04, 2011 5:53 pm    Post subject: Reply with quote

This solved my problem
Code:

git branch gnome-next
git checkout gnome-next
git config branch.gnome-next.remote origin
git config branch.gnome-next.merge refs/heads/gnome-next


Thanks
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
costel78
Guru
Guru


Joined: 20 Apr 2007
Posts: 310

PostPosted: Wed Sep 28, 2011 9:07 pm    Post subject: Reply with quote

I want to test the new Gnome 3.2, but I'm unable to switch to gnome-next
I followed your instructions
Code:
git branch gnome-next
git checkout gnome-next
git config branch.gnome-next.remote origin
git config branch.gnome-next.merge refs/heads/gnome-next

but when I tried to update I got a LOT of conflicts.
Code:
error: refusing to lose untracked file at 'app-accessibility/at-spi2-atk/at-spi2-atk-2.2.0.ebuild'
error: refusing to lose untracked file at 'app-accessibility/at-spi2-core/at-spi2-core-2.2.0.ebuild'
error: refusing to lose untracked file at 'app-accessibility/orca/orca-3.2.0.ebuild'
error: refusing to lose untracked file at 'app-arch/file-roller/file-roller-3.1.90.ebuild'
error: refusing to lose untracked file at 'app-cdr/brasero/brasero-3.2.0.ebuild'
error: refusing to lose untracked file at 'app-crypt/seahorse/seahorse-3.2.0.ebuild'
error: refusing to lose untracked file at 'app-editors/gedit-plugins/gedit-plugins-3.2.0.ebuild'
error: refusing to lose untracked file at 'app-editors/gedit/gedit-3.2.0.ebuild'
error: refusing to lose untracked file at 'app-text/evince/evince-3.2.0.ebuild'
error: refusing to lose untracked file at 'dev-libs/atk/atk-2.2.0.ebuild'
error: refusing to lose untracked file at 'dev-libs/libgweather/libgweather-3.1.3.ebuild'
error: refusing to lose untracked file at 'dev-libs/libpeas/libpeas-1.2.0.ebuild'
error: refusing to lose untracked file at 'dev-python/pyatspi/pyatspi-2.2.0.ebuild'
error: refusing to lose untracked file at 'dev-util/anjuta/anjuta-3.1.90.ebuild'
error: refusing to lose untracked file at 'gnome-base/dconf/dconf-0.10.0.ebuild'
error: refusing to lose untracked file at 'gnome-base/gnome-control-center/gnome-control-center-3.2.0.ebuild'
error: refusing to lose untracked file at 'gnome-base/gnome-desktop/gnome-desktop-3.2.0.ebuild'
error: refusing to lose untracked file at 'gnome-base/gnome-keyring/gnome-keyring-3.2.0.ebuild'
....


The second git pull try give me:
Code:
Pull is not possible because you have unmerged files.
Please, fix them up in the work tree, and then use 'git add/rm <file>'
as appropriate to mark resolution, or use 'git commit -a'.


I am not familiar with git. Could someone, please, advice me ?

[Edit]: One solution is to bypass layman via following steps:
1. delete gnome overlay files, but not from layman database - rm gnome
2. manual add desired branch - git clone -b gnome-next git://git.overlays.gentoo.org/proj/gnome.git
It seems that layman does not complain at all
_________________
Sorry for my English. I'm still learning this language.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum