Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libstdc++ and unofficial rainbowcrack
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
necron
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2010
Posts: 97

PostPosted: Thu Sep 08, 2011 12:38 am    Post subject: libstdc++ and unofficial rainbowcrack Reply with quote

i'd like to try playing around with a version of rainbowcrack that's modified to work with DES (NOT from the portage tree), but it seems to have an issue with my version of libstdc++.so.6

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/32/libstdc++.so.6: version `GLIBCXX_3.4.14' not found


there are RPMs out there for that version of libstdc++, but i'm reluctant to install an rpm like that for fear that playing with libstdc++ too much might break things. glibc seems up to date and i have the latest libstdc++-v3. gcc is 4.4.5

can anyone suggest a safer alternative?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13761

PostPosted: Thu Sep 08, 2011 3:25 am    Post subject: Reply with quote

Set up a local overlay and use that to build a modified rainbowcrack that understands the algorithms you want to use. This will keep the resulting files under Portage control. Building from source is probably sufficient to get the file linked to the proper version of libstdc++.so.
Back to top
View user's profile Send private message
necron
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2010
Posts: 97

PostPosted: Thu Sep 08, 2011 5:23 am    Post subject: Reply with quote

it's not a compiling issue. i didn't issue any commands to build, so far as i know. i did svn checkout and ended up with executables

i probably should have mentioned that earlier :oops:
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 269

PostPosted: Thu Sep 08, 2011 3:37 pm    Post subject: Reply with quote

That's what Hu was talking about. If you compiled the software yourself, it would probably link correctly.
Back to top
View user's profile Send private message
necron
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2010
Posts: 97

PostPosted: Thu Sep 08, 2011 6:53 pm    Post subject: Reply with quote

i'd love to compile it, but that's all i seem to be able to get. the project's website has a link to download a zip file, but it turns out they just give the executables with no permissions to execute, and the readme seems to indicate that that is the suite in itself...

the file i got from issuing the svn did have a makefile, but make isn't touching anything they don't seem to have giving me anything where i could 'make uninstall'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum