Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nm-applet, gnome-shell and permissions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
wizulis
n00b
n00b


Joined: 07 Nov 2010
Posts: 46

PostPosted: Sun Sep 11, 2011 10:03 pm    Post subject: nm-applet, gnome-shell and permissions Reply with quote

As Gnome-Shell and part of my system is from gnome-overlay im asking here.

I saw a thread some time ago, but can't find it anymore.

So basically, when I (as a user) try to connect to a wireless network, the nm-applet will ask my Administrator password twice and then the wpa-passkey (which is not saved by the way). Does anyone know, what permissions needs to be changed to make nm-applet stop asking for administrator password and start saving some passkeys?

Some relevant package info:
gnome-extra/nm-applet-0.9.0
gnome-base/gnome-shell-3.0.2-r1
sys-apps/dbus-1.4.12
sys-auth/polkit-0.101-r1
Back to top
View user's profile Send private message
zoku88
n00b
n00b


Joined: 15 Apr 2011
Posts: 4

PostPosted: Mon Oct 10, 2011 6:43 am    Post subject: Reply with quote

I'm having this same problem, btw, but with wired ethernet instead, so I only get one password prompt.

My NetworkManager.conf
Code:
        <policy group="plugdev">
                 <allow own="org.freedesktop.NetworkManager"/>
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.PPP"/>

                <allow send_interface="org.freedesktop.NetworkManager.SecretAgent"/>

                <!-- Allow NM to talk to known VPN plugins; due to a bug in
                     the D-Bus daemon, when a plugin is installed and the user
                     immediately tries to use it, the VPN plugin's rules aren't
                     always loaded into dbus-daemon.  Those rules allow NM to
                     talk to the plugin.  Oops.  Work around that by explicitly
                     allowing NM to talk to VPN plugins here.
                  -->
                <allow send_destination="org.freedesktop.NetworkManager.openconnect"/>
                <allow send_destination="org.freedesktop.NetworkManager.openswan"/>
                <allow send_destination="org.freedesktop.NetworkManager.openvpn"/>
                <allow send_destination="org.freedesktop.NetworkManager.pptp"/>
                <allow send_destination="org.freedesktop.NetworkManager.vpnc"/>
       </policy>


I notice that there is no nm-applet.conf in /etc/dbus-1/system.d/ anymore.
Back to top
View user's profile Send private message
wizulis
n00b
n00b


Joined: 07 Nov 2010
Posts: 46

PostPosted: Mon Oct 10, 2011 5:51 pm    Post subject: Reply with quote

Jeah, they get those permissions through polkit now, I guess.
Check that user is in the network group and I fixed it with a file with this from archwiki (https://wiki.archlinux.org/index.php/NetworkManager):

"With polkit:
Place the following in /etc/polkit-1/localauthority/50-local.d/10-org-freedesktop-network-manager-settings.pkla
Code:
[Allow user YOURUSERNAME to create wireless connections for all users]
Identity=unix-user:YOURUSERNAME
Action=org.freedesktop.network-manager-settings.system.modify
ResultAny=no
ResultInactive=no
ResultActive=yes

"
Don't know is this the right way, but works for me :)
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 925
Location: Sun City Center, Florida

PostPosted: Sun Dec 04, 2011 8:57 pm    Post subject: Reply with quote

Looks like it has been fixed if you are in the group plugdev.
Code:

intel64 ~ # cat /etc/polkit-1/localauthority/10-vendor.d/01-org.freedesktop.NetworkManager.settings.modify.system.pkla
[Let users in plugdev group modify NetworkManager]
Identity=unix-group:plugdev
Action=org.freedesktop.NetworkManager.settings.modify.system
ResultAny=no
ResultInactive=no
ResultActive=yes

_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum