Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Dolphin-Emu
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
eArquilla
n00b
n00b


Joined: 07 Sep 2011
Posts: 9

PostPosted: Thu Sep 15, 2011 12:33 am    Post subject: [SOLVED] Dolphin-Emu Reply with quote

Trying to install the Wii emulator "dolphin"

originally followed this: http://code.google.com/p/dolphin-emu/wiki/Linux_Build

Could NOT find SFML (missing: SFML_INCLUDE_DIR) Shared SFML < 2.0 not found, falling back to the static library Shared SOIL not found, falling back to the static library -- Found ZLIB: /usr/include (found version "1.2.5") Using shared zlib GLEW not found Shared GLEW not found, falling back to the static library Cg not found CgGL not found -- Could NOT find wxWidgets (missing: wxWidgets_FOUND) -- Could NOT find wxWidgets (missing: wxWidgets_FOUND) CMake Error at CMakeLists.txt:414 (message):

wxWidgets not found. It is required to build the GUI
-- Configuring incomplete, errors occurred!

I found http://wiki.wxwidgets.org/Installing_and_configuring_under_Gentoo and ran "emerge wxGTK", it successfully installed, however I still get the same error message telling me that wxWidgets is missing.

Next I tried the ebuild listed http://gpo.zugaina.org/games-emulation/dolphin-emu/euscan.
I installed layman
layman -a v-fox
layman -S
emerge games-emulation/dolphin-emu

no ebuilds found

I added the other overlays listed too, all 4 of them, and never found the package.
What am I missing here?


Last edited by eArquilla on Thu Sep 15, 2011 3:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Thu Sep 15, 2011 7:54 am    Post subject: Reply with quote

Tried this ebuild from this thread?
https://281543.bugs.gentoo.org/attachment.cgi?id=284779
https://bugs.gentoo.org/show_bug.cgi?id=281543
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 223
Location: France

PostPosted: Thu Sep 15, 2011 7:55 am    Post subject: Reply with quote

Hi eArquilla,

first off all : use their git. I'm using it for a few months now, and it's working flawlessly :]

It seems that you are blocking on the cmake part; I have :
Code:
$ cmake -D CMAKE_INSTALL_PREFIX=/mnt/Games/dolphin-bin/ ..
OpenMP parallelization enabled
ALSA found, enabling ALSA sound backend
ao NOT found, disabling ao sound backend
bluez NOT found, disabling bluetooth support
PulseAudio NOT found, disabling PulseAudio sound backend
-- Could NOT find OpenAL (missing:  OPENAL_INCLUDE_DIR)
OpenAL NOT found, disabling OpenAL sound backend
X11 found
Xrandr found
libav found, enabling AVI frame dumps
PortAudio not found, disabling mic support
Using shared lzo
Using shared SDL
Could NOT find SFML (missing:  SFML_INCLUDE_DIR)
Shared SFML < 2.0 not found, falling back to the static library
Shared SOIL not found, falling back to the static library
Using shared zlib
GLEW found
Cg found
CgGL found
wxWidgets found, enabling GUI build
-- Configuring done
-- Generating done
-- Build files have been written to: /mnt/Games/dolphin-emu/Build


So, for wxGTK :
1) did you use the X USE flag ?
2) Did you enable the wxWidget profile ?
Code:
$ eselect wxwidgets list
Available wxWidgets profiles:
  [1]   gtk2-unicode-release-2.8 *

3) Did you try something like : env-update && source /etc/profile ?


Then, it seems that you forgot to install media-libs/glew (noted in the build dependencies part), media-gfx/nvidia-cg-toolkit.

PS : if you don't mind, please use the [code] tag (your cmake output was almost unreadable)


Good luck :]
_________________
Main laptop : T8300 cpu | 200 GB hard drive | 2 GB of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 cpu | 250 GB hard drive | 2 GB of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
eArquilla
n00b
n00b


Joined: 07 Sep 2011
Posts: 9

PostPosted: Thu Sep 15, 2011 3:57 pm    Post subject: Reply with quote

Yuu, thanks so much, you helped me figure out my problem. I had originally done 'eselect widgets list', saw the result, figured I was fine. Had to go back and 'eselect widgets set 1'. Installed the two packages you mentioned, everything compiled fine, and my first test run with a burned dvd copy of mario sluggers worked! Now to figure out the wiimotes...

I have a logitech keyboard that came with a bluetooth dongle, should i be able to connect my wiimote to that? or do i need to buy a separate bluetooth adapter?
Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 223
Location: France

PostPosted: Thu Sep 15, 2011 10:00 pm    Post subject: Reply with quote

Hi eArquilla,

It's nice to see that your main problem is solved :]

For your wiimote : as I'm using a cheap gamepad, it can't really tell. But if your wiimote is detected by your Gentoo, you should be able to get your wiimote to work. So, just try installing net-wireless/bluez, recompile dolphin-emu (don't forget to re-run cmake) and try :]
_________________
Main laptop : T8300 cpu | 200 GB hard drive | 2 GB of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 cpu | 250 GB hard drive | 2 GB of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
eArquilla
n00b
n00b


Joined: 07 Sep 2011
Posts: 9

PostPosted: Fri Sep 16, 2011 3:20 am    Post subject: Reply with quote

completely solved, purchased a rocketfish bluetooth adapter, typed in 'lswm', 1+2 on wiimote, after a few tries it connected.

now to celebrate my nailing my last final for summer classes and play twilight princess in 1080p all night
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum