Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
probleme beim Formatieren
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mikl0910
n00b
n00b


Joined: 25 Sep 2011
Posts: 3

PostPosted: Sun Sep 25, 2011 2:17 pm    Post subject: probleme beim Formatieren Reply with quote

Hi Ihr lieben leute,

vorweg ein paar Infos zu mir
Ich befasse mich seit etwas mehr als 4 Jahren mit Linux (openSuse) und bin net wirklich unerfahren.

Mein projekt ist zur Zeit, gentoo in ne VirtualBox zu installieren. Die VBox läuft in openSuse.
Ich habe alle Partitionen, so wie ich sie brauche, angelegt und nun lassen sie sicdzh nicht formatieren.
Hier die meldungen von der Konsole.


entoo-11 ~ # fdisk /dev/sda

Command (m for help): p

Disk /dev/sda: 17.0 GB, 17021534208 bytes
255 heads, 63 sectors/track, 2069 cylinders, total 33245184 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa6d1951c

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 67583 32768 83 Linux
/dev/sda2 67584 4261887 2097152 82 Linux swap / Solaris
/dev/sda3 4261888 20645887 8192000 83 Linux
/dev/sda4 20645888 33245183 6299648 83 Linux

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.
Syncing disks.
Gentoo-11 ~ # mkfs.ext2 /dev/sda1
mke2fs 1.41.14 (22-Dec-2010)
Could not stat /dev/sda1 --- No such file or directory

The device apparently does not exist; did you specify it correctly?
Gentoo-11 ~ #

Ich verstehe net warum das net klappt.
Kann mir jemand erklären was da schief geht?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Sun Sep 25, 2011 3:24 pm    Post subject: Reply with quote

Physische Festplatte oder ein Image auf der Disk?
Dein Gentoo ist in der VM?
Device steht dort auch zur Verfügung?

Notfalls kannst du auch die Platte mit Suse partitionieren...
Back to top
View user's profile Send private message
mikl0910
n00b
n00b


Joined: 25 Sep 2011
Posts: 3

PostPosted: Sun Sep 25, 2011 3:45 pm    Post subject: Reply with quote

Also es ist ein Image auf der Disk, als dynamisch wachsendes medium kofiguriert. Ja gentoo läuft in der VM und das Image wird als 17gb grosse platte erkannt. Ich probiere es mal die partitionen vorab mit parted magig zu erstellen. Villeicht klappt das ja.
seltsam iss es schon Das einerseits gentoo die partitionen anlegt und andererseits sagt da iss nix zu formatieren.
Back to top
View user's profile Send private message
mikl0910
n00b
n00b


Joined: 25 Sep 2011
Posts: 3

PostPosted: Sun Sep 25, 2011 5:05 pm    Post subject: Reply with quote

pmagic hatt geholfen. kann nun mit der installation forntfahren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum