Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg config
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Thu Sep 29, 2011 1:42 pm    Post subject: xorg config Reply with quote

Hallo,
hab mir einen neuen PC zugelegt und Gentoo neu installiert.
verwende dzt.: linux-2.6.39-gentoo-r3, gcc 4.4.5
sowie xorg-x11 7.4-r1
also alles aktuelle Versionen wie sie halt so in Stable vorkommen.

Hab jetzt aber Probleme das Verhalten der Maus und des Keyboards
zu kontrollieren.

Wollte mich im Internet über die Gentoo-Documentation
(X-Server HOTOW) schlau machen, aber das Ergebnis war
auch etwas verwirrend.

das deutsche X-Server HOTOW empfiehlt in der /etc/make.conf
#X11 Settings
INPUT_DEVICES="evdev"
zu verwenden.
weiter wird dann auch die Konfiguration von HAL beschrieben
zitat:"Standardmäßig verwendet Xorg HAL (Hardware Abstraction Layer)"
und nur in besonders hartnäckigen Fällen soll man
über /etc/X11/xorg.conf konfigurieren.

im englischen X-Server HOTOW wird auch die Option
INPUT_DEVICES="evdev" in der /etc/make.conf empfohlen
von HAL ist aber keine Rede mehr
auch nicht von /etc/X11/xorg.conf
im Notfall sollen dann die Dateien in /etc/X11/xorg.conf.d/
angepasst werden.

Hab in meiner Installation aber kein /etc/X11/xorg.conf.d/
Verzeichnis, sondern ein /usr/share/X11/xorg.conf.d Verzeichnis
dort gibts genau eine Datei mit dem Namen 10-evdev.conf
Kann damit aber nichts anfangen.

Suche jetzt eine Datei in der ich meine Einstellungen vornehmen kann.
z.b. Bildschirmauflösung, Mausgeschwindigkeit und Keyboardbelegung.

Noch eine Frage, was hat es mit INPUT_DEVICES="evdev" auf sich
hab die Option in die /etc/make.conf eingetragen
und der xorg-server startet auch.
allerdings bekomm ich beim beenden von xorg immer die Fehlermeldung:
Failed to load module "evdev"

Bitte um Hilfe, wie soll ich da jetzt weitermachen ?
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Thu Sep 29, 2011 1:57 pm    Post subject: Reply with quote

Hallo,

das hier sollte weiter helfen:
https://forums.gentoo.org/viewtopic-t-895418.html

HAL gibt es nicht mehr.
Jetzt wird standard mäßig UDEV verwendet.

Gruss Jörg
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Thu Sep 29, 2011 2:01 pm    Post subject: Reply with quote

hallo,
also das mit hal ist nicht mehr so ganz der neuste stand, jetzt ist udev aktuell.

das mit der konfiguration erfolgt jetzt in /etc/X11/xorg.conf.d/*
falls das verzeichnis nicht existiert einfach anlegen. da drin werden alle dateien ausgewertet in alphabetischer Reihenfolge.
dateien in /usr/share/X11/xorg.conf.d sind sowas wie die standarteinstellungen. auf jeden fall solltest du da nix dran ändern, da änderungen ohne nachfragen beim emergen überschrieben werden.
wenn du die /etc/make.conf geändert hast, solltest du ein update machen, durch den Eintrag input="evdev" sollte dann das Paket xf86-input-evdev mit reingezogen werden, dann sollte evdev funktionieren.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sat Oct 01, 2011 6:41 am    Post subject: Reply with quote

Mit /etc/X11/xorg.conf.d/* war ich nicht glücklich. Ich verwende weiter die xorg.conf.
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Mon Oct 03, 2011 11:22 am    Post subject: Reply with quote

Danke für die Tips,

hab ein /etc/X11/xorg.conf.d/ Verzeichnis angelegt und
die Datei /usr/share/X11/xorg.conf.d/10-evdev.conf dorthin kopiert
und dann an meine Bedürfnisse angepasst.
d.h. hab alles außer keyboard und pointer(Maus) rausgeschmissen,
denn ich hab kein touchpad, keinen touchscreen und auch kein tablet.
dann noch ein paar Optionen mit rein genommen und es hat funktioniert.
hab jetzt eine /etc/X11/xorg.conf.d/10-evdev.conf Datei und die schaut so aus
Code:

# 10-evdev.conf
# Configuration for keyboard and mouse
#
####### Keyboard
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option      "XkbLayout" "de"
        Option      "XkbModel" "pc105"
        Option      "XkbVariant" "nodeadkeys"
EndSection
#
####### Mouse
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
   Option      "Accel"      "on"
   Option   "ZAxisMapping" "4 5 6 7"
EndSection

Danke auch für den Tip zum Problem: Failed to load module "evdev"
Jedenfalls geht jetzt alles.
aber die Konfiguration war früher über xorg.conf schon einfacher,
vor allem weil es dazu sehr gute Dokumentationen gibt.
was man von den /etc/X11/xorg.conf.d/* Dateien nicht behaupten kann,
da kann man u.U. schon lange suchen.

l.g. Oliver
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Mon Oct 03, 2011 5:36 pm    Post subject: Reply with quote

Eigendlich brauchst du die xorg.conf nicht mehr, udev configuriert den x server automatisch,
xorg.conf oder xorg.conf.d sollten nur in Notfaellen genommen werden, wenn die standardkonfiguration zu Fehlern fuehrt.
oder du sonst nicht zu frieden bist.

Ich habe xorg-server 1.10.3, der macht keine Probleme ohne xorg.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum