Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.2 -- net-libs/webkit-gtk-1.6.1-r300-- failed[Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2220
Location: Germany

PostPosted: Mon Oct 03, 2011 9:01 pm    Post subject: Gnome 3.2 -- net-libs/webkit-gtk-1.6.1-r300-- failed[Solved] Reply with quote

Code:
[I] dev-libs/glib
     Available versions: 
   (1)   1.2.10-r5
   (2)   2.28.6 2.28.8 (~)2.30.0 (**)9999[1]
   {debug doc fam hardened +introspection selinux +static-libs systemtap test xattr}
     Installed versions:  1.2.10-r5(1)(16:14:08 11.06.2007)(-hardened) 9999(2)[1](20:51:16 03.10.2011)(fam static-libs -debug -doc -selinux -systemtap -test -xattr)
     Homepage:            http://www.gtk.org/
     Description:         The GLib library of C routines

....
[1] "gnome" /var/lib/layman/gnome
...


If i run: MAKEOPTS="-j1" emerge -u net-libs/webkit-gtk
i got:

Code:
./doltlibtool --silent --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I.  -Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type -Wformat -Wformat-security -Wno-format-y2k -Wundef -Wmissing-format-attribute -Wpointer-arith -Wwrite-strings -Wno-unused-parameter -Wno-parentheses -fno-exceptions -DENABLE_GLIB_SUPPORT=1 -DBUILDING_CAIRO__=1 -DBUILDING_GTK__=1 -DWTF_CHANGES -DXP_UNIX -DWTF_USE_ICU_UNICODE=1   -DWTF_USE_GSTREAMER=1  -DNDEBUG   -I./Source -I./Source/JavaScriptCore -I./Source/JavaScriptCore/API -I./Source/JavaScriptCore/assembler -I./Source/JavaScriptCore/bytecode -I./Source/JavaScriptCore/bytecompiler -I./Source/JavaScriptCore/dfg -I./Source/JavaScriptCore/heap -I./Source/JavaScriptCore/debugger -I./Source/JavaScriptCore/ForwardingHeaders -I./Source/JavaScriptCore/interpreter -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/profiler -I./Source/JavaScriptCore/runtime -I./Source/JavaScriptCore/wtf -I./Source/JavaScriptCore/wtf -I./Source/JavaScriptCore/wtf/gobject -I./Source/JavaScriptCore/wtf/gtk -I./Source/JavaScriptCore/wtf/text -I./Source/JavaScriptCore/wtf/unicode -I./Source/JavaScriptCore/yarr -I./Source/JavaScriptCore -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/runtime  -fno-rtti -fstrict-aliasing -O3  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include   -I/usr/include  -march=native -O2 -pipe  -c -o Source/JavaScriptCore/wtf/libjavascriptcoregtk_3_0_la-CurrentTime.lo `test -f 'Source/JavaScriptCore/wtf/CurrentTime.cpp' || echo './'`Source/JavaScriptCore/wtf/CurrentTime.cpp
In file included from /usr/include/glib-2.0/glib/gasyncqueue.h:34:0,
                 from /usr/include/glib-2.0/glib.h:34,
                 from Source/JavaScriptCore/wtf/CurrentTime.cpp:60:
/usr/include/glib-2.0/glib/gthread.h:55:16: Fehler: Markierung »union« bei Benennung von »struct _GMutex« verwendet
/usr/include/glib-2.0/glib/gthread.h:62:7: Fehler: Markierung »union« bei Benennung von »struct _GMutex« verwendet
make[1]: *** [Source/JavaScriptCore/wtf/libjavascriptcoregtk_3_0_la-CurrentTime.lo] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/net-libs/webkit-gtk-1.6.1-r300/work/webkit-1.6.1'
make: *** [all] Fehler 2
 * ERROR: net-libs/webkit-gtk-1.6.1-r300 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =net-libs/webkit-gtk-1.6.1-r300',
 * the complete build log and the output of 'emerge -pqv =net-libs/webkit-gtk-1.6.1-r300'.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-1.6.1-r300/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-1.6.1-r300/temp/environment'.
 * S: '/var/tmp/portage/net-libs/webkit-gtk-1.6.1-r300/work/webkit-1.6.1'


Without the MAKEOPTS the Error is nearly the same. Something with union and struct _GMutex. Any suggestions?


Last edited by ChrisJumper on Tue Oct 04, 2011 2:32 am; edited 1 time in total
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2220
Location: Germany

PostPosted: Mon Oct 03, 2011 9:56 pm    Post subject: Reply with quote

With glib-2.30.0 it compile fine but i'm sure gnome will fail cause of the missing introspection Useflag.

Oh no.. the updated glib-9999 has no introspection-useflag too. This should by my problem. Something removed my

Code:
cat /etc/portage/profile/use.mask/use.mask.gnome3
-introspection


add this again did not solve the missing introspection Useflag of the glib.
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Tue Oct 04, 2011 1:49 am    Post subject: Reply with quote

1. DO NOT USE dev-libs/glib-9999 unless you are a developer working on gnome-3.3. In particular, do not use glib-9999 to build gnome-3.2 packages. You WILL get errors.

2. The introspection USE flag was finally removed from glib. All ebuilds that need introspection must now depend on dev-libs/gobject-introspection directly, not on dev-libs/glib[introspection].

If after emerge sync you still see an ebuild that wants glib with the introspection USE flag, please file a bug about it.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2220
Location: Germany

PostPosted: Tue Oct 04, 2011 2:31 am    Post subject: Reply with quote

Thank you very much tetromino!

Since i installed Gnome 3 (for testing only), i start to loving this desktop. Don't really know why or how i slide into these 9999-Packages. After masked them and merging the less unstable packages all seems to be fine and work (compile now) again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum