Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing gnome 3.2.0 fails on gnome-settings-daemon-9999
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Tue Oct 04, 2011 3:11 pm    Post subject: installing gnome 3.2.0 fails on gnome-settings-daemon-9999 Reply with quote

I am trying to install gnome 3.2.0 and have already some of the packages installed (74 to go) but for most of these packages I need the gnome-settings-daemon who fails to install.
Code:

emerge -pv gnome-settings-daemon
[ebuild  N    ] gnome-base/gnome-settings-daemon-9999  USE="cups policykit udev -debug -packagekit -short-touchpad-timeout -smartcard -test"


The first and only error I see is:
Code:

gnome-settings-manager.c:34:44: fatal error: libgnome-desktop/gnome-pnp-ids.h: No such file or directory
compilation terminated.
make[3]: *** [gnome_settings_daemon-gnome-settings-manager.o] Error 1
make[3]: *** Waiting for unfinished jobs.


output of emerge -info:
Code:

emerge --info =gnome-base/gnome-settings-daemon-9999

Portage 2.1.10.20 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.12.2-r0, 3.0.4-gentoo x86_64)

=================================================================

                        System Settings

=================================================================

System uname: Linux-3.0.4-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-2.0.3

Timestamp of tree: Tue, 04 Oct 2011 06:45:01 +0000

app-shells/bash:          4.2_p10

dev-java/java-config:     2.1.11-r3

dev-lang/python:          2.7.1-r1, 3.1.3-r1

dev-util/cmake:           2.8.4-r1

dev-util/pkgconfig:       0.26

sys-apps/baselayout:      2.0.3

sys-apps/openrc:          0.8.2-r1

sys-apps/sandbox:         2.4

sys-devel/autoconf:       2.13, 2.68

sys-devel/automake:       1.10.3, 1.11.1-r1

sys-devel/binutils:       2.21.1

sys-devel/gcc:            4.4.6-r1, 4.5.2

sys-devel/gcc-config:     1.4.1-r1

sys-devel/libtool:        2.4-r1

sys-devel/make:           3.82-r1

sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)

sys-libs/glibc:           2.12.2

Repositories: gentoo enlightenment moonrise desktop-effects sunrise gnome

ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"

ACCEPT_LICENSE="* -@EULA"

CBUILD="x86_64-pc-linux-gnu"

CFLAGS="-march=native -O2 -pipe"

CHOST="x86_64-pc-linux-gnu"

CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"

CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"

CXXFLAGS="-march=native -O2 -pipe"

DISTDIR="/usr/portage/distfiles"

FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"

FFLAGS=""

GENTOO_MIRRORS="http://gentoo.tiscali.nl/ http://mirror.leaseweb.com/gentoo/ http://mirror.netcologne.de/gentoo/"

LANG="en_US.UTF-8"

LDFLAGS="-Wl,-O1 -Wl,--as-needed"

MAKEOPTS="-j3"

PKGDIR="/usr/portage/packages"

PORTAGE_CONFIGROOT="/"

PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"

PORTAGE_TMPDIR="/var/tmp"

PORTDIR="/usr/portage"

PORTDIR_OVERLAY="/var/lib/layman/enlightenment /var/lib/layman/moonrise /var/lib/layman/desktop-effects /var/lib/layman/sunrise /var/lib/layman/gnome"

SYNC="rsync://rsync2.nl.gentoo.org/gentoo-portage"

USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cjk cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gnome gpm gtk gtk2 gtk3 iconv inotify ipv6 java jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline sdl session spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Build log:
Code:

#[32;01m * #[39;49;00mPackage:    gnome-base/gnome-settings-daemon-9999
#[32;01m * #[39;49;00mRepository: gnome
#[32;01m * #[39;49;00mUSE:        amd64 cups elibc_glibc kernel_linux multilib policykit udev userland_GNU
#[32;01m * #[39;49;00mFEATURES:   sandbox
>>> Unpacking source...
GIT update -->
   repository:               git://git.gnome.org/gnome-settings-daemon
   at the commit:            92561b405109d5583cd48b9afd1259efe55e600a
   branch:                   master
   storage directory:        "/usr/portage/distfiles/egit-src/gnome-settings-daemon"
   checkout type:            bare repository
Cloning into /var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999...
done.
Branch branch-master set up to track remote branch master from origin.
Switched to a new branch 'branch-master'
>>> Unpacked to /var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999
>>> Source unpacked in /var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work
>>> Preparing source in /var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999 ...
 #[32;01m*#[0m Running intltoolize --force ...
You should add the contents of '/usr/share/aclocal/intltool.m4' to 'aclocal.m4'.
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running eautoreconf in '/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999' ...
 #[32;01m*#[0m Running aclocal ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running libtoolize --copy --force --install --automake ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running aclocal ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running autoconf ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running autoheader ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running automake --add-missing --copy --foreign ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
 #[32;01m*#[0m Running elibtoolize in: gnome-settings-daemon-9999/
 #[32;01m*#[0m   Applying portage/1.2.0 patch ...
 #[32;01m*#[0m   Applying sed/1.5.6 patch ...
 #[32;01m*#[0m   Applying as-needed/2.2.6 patch ...
 #[32;01m*#[0m Fixing OMF Makefiles ...
#[A#[77C #[34;01m[ #[32;01mok#[34;01m ]#[0m
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999 ...
 * econf: updating gnome-settings-daemon-9999/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating gnome-settings-daemon-9999/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-dependency-tracking --disable-static --disable-schemas-compile --enable-gconf-bridge --with-pnpids=/usr/share/libgnome-desktop-3.0/pnp.ids --enable-cups --disable-debug --disable-more-warnings --disable-packagekit --enable-polkit --disable-smartcard-support --enable-gudev --disable-maintainer-mode
configure: WARNING: unrecognized options: --enable-gconf-bridge, --with-pnpids
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to disable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for x86_64-pc-linux-gnu-g++... x86_64-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether x86_64-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of x86_64-pc-linux-gnu-g++... none
checking whether x86_64-pc-linux-gnu-gcc and cc understand -c and -o together... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for x86_64-pc-linux-gnu-objdump... x86_64-pc-linux-gnu-objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-pc-linux-gnu-dlltool... no
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking for archiver @FILE support... @
checking for x86_64-pc-linux-gnu-strip... x86_64-pc-linux-gnu-strip
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib
checking command to parse /usr/bin/nm -B output from x86_64-pc-linux-gnu-gcc object... ok
checking for sysroot... no
checking for x86_64-pc-linux-gnu-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-gcc static flag -static works... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-gcc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking how to run the C++ preprocessor... x86_64-pc-linux-gnu-g++ -E
checking for ld used by x86_64-pc-linux-gnu-g++... /usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) is GNU ld... yes
checking whether the x86_64-pc-linux-gnu-g++ linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking for x86_64-pc-linux-gnu-g++ option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-g++ PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-g++ static flag -static works... yes
checking if x86_64-pc-linux-gnu-g++ supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-g++ supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-g++ linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for ANSI C header files... (cached) yes
checking whether NLS is requested... yes
checking for intltool >= 0.37.1... 0.41.1 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.12.3
checking for XML::Parser... ok
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/gmsgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking what warning flags to pass to the C compiler... -Wall -Wmissing-prototypes
checking what language compliance flags to pass to the C compiler...
checking for x86_64-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for SETTINGS_DAEMON... yes
checking for SETTINGS_PLUGIN... yes
checking for BACKLIGHT_HELPER... yes
checking for glib-genmarshal... /usr/bin/glib-genmarshal
checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for GNOME_DESKTOP... yes
checking for LCMS... yes
checking for LIBNOTIFY... yes
checking for COMMON... yes
checking for AUTOMOUNT... yes
checking for BACKGROUND... yes
checking for MOUSE... yes
checking for CURSOR... yes
checking for FONTCONFIG... yes
checking for KEYBOARD... yes
checking for GIOUNIX... yes
checking for MEDIA_KEYS... yes
checking for COLOR... yes
checking for GUDEV... yes
checking for UPOWER... yes
checking for POLKIT... yes
checking for a sed that does not truncate output... (cached) /bin/sed
checking for cups-config... /usr/bin/cups-config
checking cups/cups.h usability... yes
checking cups/cups.h presence... yes
checking for cups/cups.h... yes
checking cups/http.h usability... yes
checking cups/http.h presence... yes
checking for cups/http.h... yes
checking cups/ipp.h usability... yes
checking cups/ipp.h presence... yes
checking for cups/ipp.h... yes
checking for more warnings... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating gnome-settings-daemon/Makefile
config.status: creating plugins/Makefile
config.status: creating plugins/a11y-keyboard/Makefile
config.status: creating plugins/a11y-settings/Makefile
config.status: creating plugins/automount/Makefile
config.status: creating plugins/background/Makefile
config.status: creating plugins/clipboard/Makefile
config.status: creating plugins/color/Makefile
config.status: creating plugins/common/Makefile
config.status: creating plugins/cursor/Makefile
config.status: creating plugins/datetime/Makefile
config.status: creating plugins/dummy/Makefile
config.status: creating plugins/power/Makefile
config.status: creating plugins/housekeeping/Makefile
config.status: creating plugins/keybindings/Makefile
config.status: creating plugins/keyboard/Makefile
config.status: creating plugins/media-keys/Makefile
config.status: creating plugins/media-keys/cut-n-paste/Makefile
config.status: creating plugins/mouse/Makefile
config.status: creating plugins/orientation/Makefile
config.status: creating plugins/print-notifications/Makefile
config.status: creating plugins/smartcard/Makefile
config.status: creating plugins/sound/Makefile
config.status: creating plugins/updates/Makefile
config.status: creating plugins/wacom/Makefile
config.status: creating plugins/xrandr/Makefile
config.status: creating plugins/xsettings/Makefile
config.status: creating data/Makefile
config.status: creating data/gnome-settings-daemon.desktop.in
config.status: creating data/gnome-settings-daemon.pc
config.status: creating data/gnome-settings-daemon-uninstalled.pc
config.status: creating data/org.gnome.settings-daemon.plugins.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.xsettings.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.keyboard.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.power.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.color.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.media-keys.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.peripherals.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.housekeeping.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.orientation.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.updates.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.xrandr.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.peripherals.wacom.gschema.xml.in
config.status: creating data/org.gnome.settings-daemon.plugins.print-notifications.gschema.xml.in
config.status: creating po/Makefile.in
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing default-1 commands
config.status: executing po/stamp-it commands
configure: WARNING: unrecognized options: --enable-gconf-bridge, --with-pnpids

                    gnome-settings-daemon 3.1.92
                    =============================

        prefix:                   /usr
        exec_prefix:              ${prefix}
        libdir:                   /usr/lib64
        bindir:                   ${exec_prefix}/bin
        sbindir:                  ${exec_prefix}/sbin
        sysconfdir:               /etc
        sysconfsubdir:           
        localstatedir:            /var/lib
        plugindir:                $(libdir)/gnome-settings-daemon-3.0
        datadir:                  /usr/share
        source code location:     .
        compiler:                 x86_64-pc-linux-gnu-gcc
        cflags:                   -march=native -O2 -pipe
        Maintainer mode:          no

        dbus-1 system.d dir:      ${sysconfdir}/dbus-1/system.d
        PolicyKit support:        yes
        LCMS DICT support:        yes

        Libnotify support:        yes
        PackageKit support:       false
        Smartcard support:        false
        Cups support:             
        Profiling support:        no

>>> Source configured.
>>> Compiling source in /var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999 ...
make -j3
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999'
Making all in gnome-settings-daemon
make[2]: Entering directory `/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999/gnome-settings-daemon'
make  all-am
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999/gnome-settings-daemon'
  CC     libgsd_profile_la-gnome-settings-profile.lo
  CC     gnome_settings_daemon-main.o
/bin/sh ../libtool --silent --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_SETTINGS_LOCALEDIR=\""/usr/share/locale"\" -DLIBEXECDIR=\""/usr/libexec"\" -DGNOME_SETTINGS_PLUGINDIR=\""/usr/lib64/gnome-settings-daemon-3.0"\" -Wall -Wmissing-prototypes   -DGSEAL_ENABLE -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gsettings-desktop-schemas   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng14   -DGSEAL_ENABLE -pthread -I/usr/include/gnome-desktop-3.0 -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gsettings-desktop-schemas         -march=native -O2 -pipe -c -o libgsd_profile_la-gnome-settings-profile.lo `test -f 'gnome-settings-profile.c' || echo './'`gnome-settings-profile.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_SETTINGS_LOCALEDIR=\""/usr/share/locale"\" -DLIBEXECDIR=\""/usr/libexec"\" -DGNOME_SETTINGS_PLUGINDIR=\""/usr/lib64/gnome-settings-daemon-3.0"\" -Wall -Wmissing-prototypes   -DGSEAL_ENABLE -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gsettings-desktop-schemas   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng14   -DGSEAL_ENABLE -pthread -I/usr/include/gnome-desktop-3.0 -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gsettings-desktop-schemas       -march=native -O2 -pipe -c -o gnome_settings_daemon-main.o `test -f 'main.c' || echo './'`main.c
  CC     gnome_settings_daemon-gnome-settings-manager.o
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_SETTINGS_LOCALEDIR=\""/usr/share/locale"\" -DLIBEXECDIR=\""/usr/libexec"\" -DGNOME_SETTINGS_PLUGINDIR=\""/usr/lib64/gnome-settings-daemon-3.0"\" -Wall -Wmissing-prototypes   -DGSEAL_ENABLE -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gsettings-desktop-schemas   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng14   -DGSEAL_ENABLE -pthread -I/usr/include/gnome-desktop-3.0 -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gsettings-desktop-schemas       -march=native -O2 -pipe -c -o gnome_settings_daemon-gnome-settings-manager.o `test -f 'gnome-settings-manager.c' || echo './'`gnome-settings-manager.c
  CC     gnome_settings_daemon-gnome-settings-plugin.o
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_SETTINGS_LOCALEDIR=\""/usr/share/locale"\" -DLIBEXECDIR=\""/usr/libexec"\" -DGNOME_SETTINGS_PLUGINDIR=\""/usr/lib64/gnome-settings-daemon-3.0"\" -Wall -Wmissing-prototypes   -DGSEAL_ENABLE -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gsettings-desktop-schemas   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng14   -DGSEAL_ENABLE -pthread -I/usr/include/gnome-desktop-3.0 -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gsettings-desktop-schemas       -march=native -O2 -pipe -c -o gnome_settings_daemon-gnome-settings-plugin.o `test -f 'gnome-settings-plugin.c' || echo './'`gnome-settings-plugin.c
  CC     gnome_settings_daemon-gnome-settings-plugin-info.o
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_SETTINGS_LOCALEDIR=\""/usr/share/locale"\" -DLIBEXECDIR=\""/usr/libexec"\" -DGNOME_SETTINGS_PLUGINDIR=\""/usr/lib64/gnome-settings-daemon-3.0"\" -Wall -Wmissing-prototypes   -DGSEAL_ENABLE -pthread -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gsettings-desktop-schemas   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng14   -DGSEAL_ENABLE -pthread -I/usr/include/gnome-desktop-3.0 -I/usr/include/gtk-3.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/gsettings-desktop-schemas       -march=native -O2 -pipe -c -o gnome_settings_daemon-gnome-settings-plugin-info.o `test -f 'gnome-settings-plugin-info.c' || echo './'`gnome-settings-plugin-info.c
gnome-settings-manager.c:34:44: fatal error: libgnome-desktop/gnome-pnp-ids.h: No such file or directory
compilation terminated.
make[3]: *** [gnome_settings_daemon-gnome-settings-manager.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999/gnome-settings-daemon'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999/gnome-settings-daemon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999'
make: *** [all] Error 2
 #[31;01m*#[0m ERROR: gnome-base/gnome-settings-daemon-9999 failed (compile phase):
 #[31;01m*#[0m   emake failed
 #[31;01m*#[0m
 #[31;01m*#[0m If you need support, post the output of 'emerge --info =gnome-base/gnome-settings-daemon-9999',
 #[31;01m*#[0m the complete build log and the output of 'emerge -pqv =gnome-base/gnome-settings-daemon-9999'.
 #[31;01m*#[0m This ebuild is from an overlay named 'gnome': '/var/lib/layman/gnome/'
 #[31;01m*#[0m The complete build log is located at '/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/temp/build.log'.
 #[31;01m*#[0m The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/temp/environment'.
 #[31;01m*#[0m S: '/var/tmp/portage/gnome-base/gnome-settings-daemon-9999/work/gnome-settings-daemon-9999'



gnome-desktop is installed for as far I could find on Google this should had to have provide me with the blocking file. But thats not the case :(

Who can help me with this issue since Google cannot help me further at this point.

Thanks
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5682
Location: Removed by Neddy

PostPosted: Tue Oct 04, 2011 4:03 pm    Post subject: Reply with quote

how are you trying to install gnome-3.2? from the gnome overlay with 9999 ebuilds? these are broken and have been for a number of months
or from the gnome-next branch of gnome overlay - there are gnome-3.2 ebuilds and they work
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Tue Oct 04, 2011 4:10 pm    Post subject: Reply with quote

I try to install from the gnome overlay and have set the branch to gnome-next

I updates the overlay with layman -S
I emerge gnome with emerge gnome (gnome 2 is merged)
or emerge =gnome-3.2.0 (gnome 3.2 is merged but with allot 9999 files)

What is wrong?
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Tue Oct 04, 2011 5:46 pm    Post subject: Reply with quote

DO NOT USE 9999 versions of gnome libraries or core packages unless you are a gnome developer working on gnome-3.3.

Look at your /etc/portage/package.keywords and make sure that you don't have any gnome packages in there with a "**".

If you see something like "gnome-base/gnome-settings-daemon **", delete the "**".
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Tue Oct 04, 2011 6:30 pm    Post subject: Reply with quote

I have no package.keywords that point to gnome (~amd64 and ~x86).
A fetch of gnome gives me allot of 9999 versions even if the 3.2.0 versions are installed manually.
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Tue Oct 04, 2011 10:40 pm    Post subject: Reply with quote

All version 9999 packages in the gnome overlay have KEYWORDS="". In other words, they will not emerge unless you, or some program or script that you had used, added a setting to portage to allow those packages to be emerged despite not being keyworded for your architecture. Or unless you are using emerge with the "--autounmask-write=y" argument (which you should not be doing if you do not have an excellent understanding of how portage behaves).

Typically, that setting is either the /etc/portage/package.keywords file, or a file in the /etc/portage/package.keywords/ directory.

Quote:
A fetch of gnome gives me allot of 9999 versions even if the 3.2.0 versions are installed manually.


Please pastebin the full portage output that is telling you to install 9999 versions of packages.
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Wed Oct 05, 2011 4:55 am    Post subject: Reply with quote

the output.
Code:

# emerge -pv =gnome-3.2.0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U #] dev-libs/json-glib-0.13.4 [0.12.6] USE="introspection -debug -doc" 0 kB [0]
[ebuild     U #] dev-libs/gobject-introspection-9999 [0.10.8] USE="-doc -test" 0 kB [0=>1]
[ebuild     U #] dev-libs/atk-2.2.0 [1.32.0-r1] USE="introspection nls -doc" 0 kB [0=>1]
[ebuild     U #] dev-libs/gjs-9999 [0.7.14-r1] USE="-examples -test (-xulrunner%*)" 0 kB [1]
[ebuild  N     ] app-mobilephone/obexd-0.42  USE="usb -debug -eds -nokia -server" 0 kB [0]
[ebuild  N    #] media-video/cheese-9999  USE="introspection -doc -vala" 0 kB [1]
[ebuild     U #] app-text/evince-9999 [2.32.0-r3] USE="dbus introspection* tiff -debug -djvu -doc -dvi -gnome-keyring -nautilus -t1lib (-gnome%)" 0 kB [0=>1]
[ebuild  N    #] media-gfx/eog-9999  USE="exif introspection jpeg lcms svg tiff -debug -doc -xmp" 0 kB [1]
[ebuild  N    #] gnome-extra/yelp-3.2.0  USE="-debug" 0 kB [1]
[ebuild     U #] x11-terms/gnome-terminal-9999 [2.32.1] 0 kB [0=>1]
[ebuild  N    #] gnome-extra/gnome-screensaver-9999  USE="pam -debug -doc" 0 kB [1]
[ebuild  N    #] gnome-extra/gnome-games-3.2.0  USE="aisleriot clutter introspection sudoku -artworkextra -glchess (-seed) -test" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-settings-daemon-9999  USE="cups policykit udev -debug -packagekit -short-touchpad-timeout -smartcard -test" 0 kB [1]
[ebuild     U #] x11-misc/notification-daemon-0.7.1 [0.5.0] 0 kB [0]
[ebuild     U  ] sys-apps/gnome-disk-utility-3.0.2 [2.32.1-r1] USE="-avahi -doc -fat -gnome-keyring (-nautilus) -remote-access" 0 kB [0]
[ebuild  N    #] gnome-base/gnome-session-9999  USE="ipv6 -debug -doc" 0 kB [1]
[ebuild  N    #] x11-wm/mutter-9999  USE="introspection -test -xinerama" 0 kB [1]
[ebuild     UD ] x11-wm/metacity-2.30.3 [2.34.1] USE="-test -xinerama" 0 kB [0]
[ebuild  N    #] net-misc/vinagre-9999  USE="ssh telepathy -avahi -test" 0 kB [1]
[ebuild     U #] gnome-base/libgnome-keyring-3.2.0 [2.32.0] USE="-debug -doc -test" 0 kB [0=>1]
[ebuild     U #] gnome-base/gnome-keyring-9999 [2.32.1-r1] USE="caps%* pam -debug -doc -test" 0 kB [0=>1]
[ebuild  N    #] net-misc/vino-9999  USE="crypt ipv6 jpeg libnotify ssl telepathy zlib -avahi -debug -gnome-keyring -networkmanager" 0 kB [1]
[ebuild     U  ] gnome-base/gvfs-1.10.0 [1.6.7] USE="bluetooth cdda* gdu http udev -afp% -archive -avahi -bash-completion -bluray% -doc -fuse -gnome-keyring -gphoto2 -ios (-prefix) -samba (-gnome%)" 0 kB [0=>1]
[ebuild  N     ] dev-libs/libgdata-0.10.0  USE="gnome introspection -debug -doc -static-libs" 0 kB [1]
[ebuild  N    #] dev-libs/libgweather-9999  USE="introspection -doc" 0 kB [1]
[ebuild  N     ] net-libs/rest-0.7.10  USE="gnome introspection -doc -test" 0 kB [0]
[ebuild  N    #] app-crypt/seahorse-9999  USE="ldap -avahi -debug -doc -test" 0 kB [1]
[ebuild  N     ] dev-libs/totem-pl-parser-2.32.6  USE="introspection quvi -archive -doc" 0 kB [0]
[ebuild  N     ] media-libs/libchamplain-0.12.0  USE="gtk introspection -debug -doc -vala" 0 kB [1]
[ebuild  N     ] net-libs/gnome-online-accounts-3.2.0  USE="introspection -debug -doc" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-core-libs-3.2.0  USE="cups python" 0 kB [1]
[ebuild  N    #] app-cdr/brasero-9999  USE="css introspection libburn -doc -nautilus -packagekit -playlist -test -tracker" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-panel-9999  USE="introspection -doc -eds -networkmanager" 0 kB [1]
[ebuild  N    #] media-video/totem-9999  USE="bluetooth introspection python youtube -debug -doc -grilo -iplayer -lirc -nautilus -nsplugin -vala" 0 kB [1]
[ebuild  N     ] net-libs/libsocialweb-0.25.19  USE="gnome introspection networkmanager -connman -doc -vala" 0 kB [0]
[ebuild  N    #] app-editors/gedit-9999  USE="introspection python spell -doc -test" 0 kB [1]
[ebuild  N    #] net-im/empathy-9999  USE="geoloc map networkmanager spell video -debug -eds -gnome-online-accounts -sendto -test" 0 kB [1]
[ebuild  N    #] gnome-extra/evolution-data-server-9999  USE="gnome-online-accounts introspection ipv6 ldap ssl weather -doc -kerberos -test -vala" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-fallback-3.2.0  USE="cups" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-applets-9999  USE="gnome ipv6 policykit -networkmanager" 0 kB [1]
[ebuild  N    #] media-sound/sound-juicer-9999  USE="-debug -test" 0 kB [1]
[ebuild  N    #] mail-client/evolution-9999  USE="crypt gnome-online-accounts ldap python ssl (-clutter) -connman -doc -gstreamer -kerberos -map -networkmanager" 0 kB [1]
[ebuild  N     ] gnome-extra/gnome-contacts-3.2.0.1  0 kB [1]
[ebuild  N    #] gnome-base/nautilus-9999  USE="exif gnome introspection previewer -doc -packagekit -sendto -test -tracker -xmp" 0 kB [1]
[ebuild  N     ] gnome-extra/sushi-0.2.0  0 kB [1]
[ebuild  N    #] gnome-extra/gnome-utils-9999  USE="ipv6 -debug -doc -test" 0 kB [1]
[ebuild  N    #] net-wireless/gnome-bluetooth-9999  USE="introspection -debug -doc -sendto" 0 kB [1]
[ebuild  N    #] gnome-extra/nm-applet-0.9.1.90  USE="bluetooth" 0 kB [1]
[ebuild  N     ] app-misc/tracker-0.12.3-r2  USE="exif flac gif gtk jpeg mp3 pdf tiff vorbis xml (-applet) -doc -eds -firefox-bookmarks -flickr -gnome-keyring -gsf -gstreamer -iptc -laptop -nautilus -networkmanager -playlist -rss -test -thunderbird -upnp -xine -xmp" 0 kB [1]
[ebuild  N     ] gnome-extra/gnome-documents-0.2.0  0 kB [1]
[ebuild  N    #] gnome-base/gnome-control-center-9999  USE="cheese cups networkmanager socialweb -debug" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-shell-9999  0 kB [1]
[ebuild  N    #] gnome-base/gnome-core-apps-3.2.0  USE="bluetooth cdr cups" 0 kB [1]
[ebuild     U #] gnome-base/gdm-3.2.0 [2.20.11] USE="consolekit gnome-shell%* introspection%* ipv6 tcpd xklavier%* -accessibility -debug -fprint% -gnome-keyring (-selinux) -smartcard% -test% -xinerama (-afs%) (-branding%*) (-dmx%) (-pam%*) (-remote%)" 0 kB [0=>1]
[blocks b      ] <gnome-base/gdm-2.91.94 ("<gnome-base/gdm-2.91.94" is blocking gnome-base/gnome-control-center-9999)
[ebuild  N    #] gnome-extra/gnome-tweak-tool-3.2.0  0 kB [1]
[ebuild  N    #] gnome-base/gnome-extra-apps-3.2.0  USE="shotwell" 0 kB [1]
[ebuild  N    #] gnome-base/gnome-3.2.0  USE="cdr cups extras fallback" 0 kB [1]

Total: 57 packages (12 upgrades, 1 downgrade, 44 new), Size of downloads: 0 kB
Conflict: 1 block
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/gnome

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/gjs:0

  (dev-libs/gjs-0.7.14-r1::gnome, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gjs-9999::gnome, ebuild scheduled for merge) pulled in by
    >=dev-libs/gjs-1.29.18 required by (gnome-base/gnome-shell-9999::gnome, ebuild scheduled for merge)

x11-wm/metacity:0

  (x11-wm/metacity-2.34.1::gentoo, installed) pulled in by
    >=x11-wm/metacity-2.34.0 required by (gnome-base/gnome-fallback-3.2.0::gnome, ebuild scheduled for merge)

  (x11-wm/metacity-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/json-glib:0

  (dev-libs/json-glib-0.12.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/json-glib-0.13.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/json-glib-0.13.2 required by (gnome-base/gnome-shell-9999::gnome, ebuild scheduled for merge)

dev-libs/atk:0

  (dev-libs/atk-2.2.0::gnome, ebuild scheduled for merge) pulled in by
    >=dev-libs/atk-2.2 required by (gnome-base/gnome-core-libs-3.2.0::gnome, ebuild scheduled for merge)

  (dev-libs/atk-1.32.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/libgnome-keyring:0

  (gnome-base/libgnome-keyring-3.2.0::gnome, ebuild scheduled for merge) pulled in by
    >=gnome-base/libgnome-keyring-3.2.0 required by (gnome-base/gnome-core-apps-3.2.0::gnome, ebuild scheduled for merge)

  (gnome-base/libgnome-keyring-2.32.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/gnome-keyring:0

  (gnome-base/gnome-keyring-2.32.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-base/gnome-keyring-9999::gnome, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-keyring-3.2.0 required by (gnome-base/gnome-core-apps-3.2.0::gnome, ebuild scheduled for merge)
    (and 2 more with the same problem)

dev-libs/gobject-introspection:0

  (dev-libs/gobject-introspection-0.10.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-9999::gnome, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.29.16 required by (dev-libs/gjs-9999::gnome, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Traceback (most recent call last):
  File "/usr/bin/emerge", line 43, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 1976, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 300, in action_build
    mydepgraph.display_problems()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6152, in display_problems
    self._display_problems()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6179, in _display_problems
    self._display_autounmask()
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 5864, in _display_autounmask
    p_mask_change_msg[root].append(self._get_dep_chain_as_comment(pkg))
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 2871, in _get_dep_chain_as_comment
    dep_chain = self._get_dep_chain(pkg, unsatisfied_dependency=unsatisfied_dependency)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 2786, in _get_dep_chain
    for priority in self._dynamic_config.digraph.nodes[node][0][child]:
KeyError: <_emerge.Package.Package object at 0x20c8d80>
#


When I dont point to the version this is the output:
Code:

# emerge -pv gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-games/libggz-0.0.14.1  USE="-debug -gnutls" 467 kB [0]
[ebuild  N     ] dev-libs/liboil-0.3.17  USE="examples -doc -test" 892 kB [0]
[ebuild     UD ] gnome-extra/gnome-user-docs-2.32.0 [3.2.0.1] USE="-test%" 17,441 kB [1=>0]
[ebuild  N     ] dev-libs/fribidi-0.19.2-r1  654 kB [0]
[ebuild  N     ] media-gfx/gtkimageview-1.6.4  USE="-debug -doc -examples -test" 1,131 kB [0]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.2-r2 [4.1.2-r6, 4.3-r1, 4.4-r2, 4.5-r1] 77 kB [0]
[ebuild   R    ] dev-lang/python-3.2.2  USE="gdbm ipv6 ncurses readline sqlite* ssl threads (wide-unicode) xml -build -doc -examples -tk -wininst" 0 kB [0]
[ebuild  N     ] dev-python/python-ldap-2.4.3  USE="ssl -doc -examples -sasl" 124 kB [0]
[ebuild  N     ] dev-games/ggz-client-libs-0.0.14.1  USE="-debug" 600 kB [0]
[ebuild     UD ] gnome-base/libgnomekbd-2.32.0 [3.2.0] USE="-test (-introspection%*)" 402 kB [1=>0]
[ebuild     UD ] gnome-extra/gconf-editor-2.32.0 [3.0.0] 1,365 kB [0]
[ebuild     UD ] app-arch/file-roller-2.32.2 [9999] USE="-nautilus (-packagekit%)" 1,858 kB [1=>0]
[ebuild     UD ] gnome-extra/gcalctool-5.32.2 [9999] 1,151 kB [1=>0]
[ebuild     UD ] net-analyzer/gnome-nettool-2.32.0 [9999] USE="-debug" 632 kB [1=>0]
[ebuild  N     ] app-text/xmlto-0.0.24-r1  USE="-latex" 114 kB [0]
[ebuild  NS    ] gnome-extra/gtkhtml-3.32.2 [4.2.0] 1,189 kB [0]
[ebuild     U  ] x11-base/xorg-server-1.10.4 [1.10.2] USE="ipv6 kdrive* nptl udev xorg -dmx -doc -minimal -static-libs -tslib -xnest -xvfb" 5,260 kB [0]
[ebuild  N     ] media-libs/freeglut-2.6.0  USE="-debug -mpx -static-libs" 1,098 kB [0]
[ebuild  N     ] dev-python/pyopengl-3.0.1  USE="-tk" 683 kB [0]
[ebuild  N     ] media-libs/swfdec-0.8.4  USE="alsa gtk -doc -ffmpeg -gstreamer -pulseaudio" 9,726 kB [0]
[ebuild  N     ] dev-python/gnome-python-desktop-base-2.32.0  607 kB [0]
[ebuild  N     ] gnome-extra/swfdec-gnome-2.30.1  173 kB [0]
[ebuild  N     ] gnome-extra/yelp-2.30.2-r6  USE="-debug" 1,133 kB [0]
[ebuild  N     ] dev-python/pygtkglext-1.1.0  USE="-examples" 341 kB [0]
[ebuild  N     ] dev-python/gconf-python-2.28.1  USE="-examples" 0 kB [0]
[ebuild  N     ] dev-python/libwnck-python-2.32.0  USE="-examples" 0 kB [0]
[ebuild  N     ] app-editors/gedit-2.30.4  USE="python spell -doc" 4,596 kB [0]
[ebuild  N     ] dev-python/gnome-desktop-python-2.32.0  0 kB [0]
[ebuild  N     ] gnome-base/gnome-settings-daemon-2.32.1-r2  USE="libnotify policykit -debug -pulseaudio -smartcard" 1,327 kB [0]
[ebuild  N     ] gnome-base/gnome-session-2.32.1-r3  USE="ipv6 -debug -doc" 757 kB [0]
[ebuild  N     ] app-crypt/seahorse-2.32.0  USE="introspection ldap libnotify -avahi -debug -doc -test" 2,433 kB [0]
[ebuild  N     ] dev-python/gnome-keyring-python-2.32.0  USE="-examples" 0 kB [0]
[ebuild  N     ] net-misc/vino-2.32.2  USE="crypt ipv6 jpeg libnotify ssl telepathy zlib -avahi -debug -gnome-keyring -networkmanager" 837 kB [0]
[ebuild  N     ] dev-libs/libgweather-2.30.3  USE="python -doc" 7,275 kB [0]
[ebuild  N     ] dev-libs/libgdata-0.10.0  USE="gnome introspection -debug -doc -static-libs" 0 kB [1]
[ebuild  N     ] dev-libs/totem-pl-parser-2.32.6  USE="introspection quvi -archive -doc" 0 kB [0]
[ebuild  N     ] gnome-extra/evolution-data-server-2.32.3-r1  USE="ipv6 ldap weather -doc -gnome-keyring -kerberos -test" 4,245 kB [0]
[ebuild  N     ] gnome-extra/evolution-webcal-2.32.0  160 kB [0]
[ebuild  N     ] dev-python/pycups-1.9.58  USE="-doc -examples" 51 kB [0]
[ebuild  N     ] media-video/totem-2.32.0-r2  USE="bluetooth python youtube -debug -doc -galago -iplayer -lirc -nautilus -nsplugin (-tracker) -upnp" 3,215 kB [0]
[ebuild  NS    ] x11-themes/gtk-engines-2.91.1 [2.20.2] USE="-accessibility" 579 kB [1]
[ebuild  N     ] app-admin/system-config-printer-common-1.3.6  USE="policykit -doc" 966 kB [0]
[ebuild     U  ] sys-apps/gnome-disk-utility-3.0.2 [2.32.1-r1] USE="-avahi -doc -fat -gnome-keyring (-nautilus) -remote-access" 0 kB [0]
[ebuild  NS   #] gnome-base/gnome-menus-3.0.1-r50 [3.2.0.1] USE="introspection python -debug" 464 kB [1]
[ebuild  N     ] gnome-extra/gnome-utils-2.32.0-r2  USE="ipv6 -bonobo -debug -doc -test" 7,675 kB [0]
[ebuild     UD ] x11-wm/metacity-2.30.3 [2.34.1] USE="-test -xinerama" 0 kB [0]
[ebuild  N     ] media-video/cheese-2.32.0  USE="-doc" 5,180 kB [0]
[ebuild  N     ] gnome-extra/gnome-games-2.30.2-r1  USE="opengl -artworkextra (-clutter) -guile -test" 27,035 kB [0]
[ebuild  N     ] mail-client/evolution-2.32.3  USE="crypt ldap python ssl (-clutter) -connman -doc -gstreamer -kerberos -networkmanager" 31,229 kB [0]
[ebuild  N     ] app-admin/system-config-printer-gnome-1.3.6  USE="-gnome-keyring" LINGUAS="-ar -as -bg -bn -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -fa -fi -fr -gu -he -hi -hr -hu -hy -id -is -it -ja -ka -kn -ko -lo -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB [0]
[ebuild  N     ] x11-themes/gnome-themes-3.0.0  USE="-accessibility" 2,632 kB [1]
[ebuild  N     ] media-gfx/eog-2.32.1  USE="dbus exif jpeg lcms python svg tiff -debug -doc -xmp" 2,739 kB [0]
[ebuild  N     ] net-misc/vinagre-2.30.3  USE="ssh telepathy -applet -avahi -test" 2,391 kB [0]
[ebuild  N     ] dev-python/bug-buddy-python-2.32.0  0 kB [0]
[ebuild     U  ] gnome-base/gvfs-1.10.0 [1.6.7] USE="bluetooth cdda* gdu http udev -afp% -archive -avahi -bash-completion -bluray% -doc -fuse -gnome-keyring -gphoto2 -ios (-prefix) -samba (-gnome%)" 0 kB [0=>1]
[ebuild  N     ] gnome-extra/gnome-screensaver-2.30.2-r1  USE="branding libnotify opengl pam -debug -doc" 4,716 kB [0]
[ebuild  N     ] gnome-base/nautilus-2.32.2.1-r1  USE="gnome introspection -doc -test -xmp" 0 kB [0]
[ebuild  N     ] gnome-base/gnome-control-center-2.32.1-r1  USE="-debug -eds" 2,227 kB [0]
[ebuild  N     ] gnome-base/gnome-panel-2.32.1-r3  USE="bonobo introspection -doc -eds -networkmanager" 3,066 kB [0]
[ebuild  N     ] dev-python/gnome-applets-python-2.32.0  USE="-examples" 0 kB [0]
[ebuild  N     ] app-admin/pessulus-2.30.4  183 kB [0]
[ebuild  N     ] x11-misc/alacarte-0.13.2-r50  190 kB [1]
[ebuild  N     ] net-analyzer/gnome-netstatus-2.28.2  USE="-debug" 572 kB [0]
[ebuild  N     ] gnome-extra/deskbar-applet-2.32.0  USE="spell -eds" 1,044 kB [0]
[ebuild  N     ] gnome-extra/hamster-applet-2.32.1  USE="libnotify -eds" 445 kB [0]
[ebuild  N     ] app-admin/sabayon-2.30.1  3,657 kB [0]
[ebuild  N     ] media-video/dvdauthor-0.6.18  384 kB [0]
[ebuild  N     ] app-cdr/brasero-2.32.1-r1  USE="cdr css dvd introspection libburn -doc -nautilus -playlist -test -vcd" 0 kB [0]
[ebuild  N     ] gnome-extra/gnome-media-2.32.0-r1  USE="-pulseaudio" 2,749 kB [0]
[uninstall     ] media-libs/libgnome-media-profiles-3.0.0  [0]
[blocks b      ] <gnome-extra/gnome-media-2.32.0-r300 ("<gnome-extra/gnome-media-2.32.0-r300" is blocking media-libs/libgnome-media-profiles-3.0.0)
[ebuild  N     ] media-sound/sound-juicer-2.32.0-r1  USE="-debug -test" 2,127 kB [0]
[ebuild  NS    ] gnome-extra/gucharmap-2.32.1 [3.2.0] USE="cjk gnome introspection python -debug -doc -test" 3,167 kB [0]
[uninstall     ] gnome-extra/gucharmap-3.2.0  USE="cjk gnome introspection -debug -doc -test"  [1]
[blocks b      ] <gnome-extra/gucharmap-3:0 ("<gnome-extra/gucharmap-3:0" is blocking gnome-extra/gucharmap-3.2.0)
[ebuild  N     ] gnome-base/gnome-applets-2.32.1.1  USE="gnome ipv6 policykit -gstreamer -networkmanager" 9,848 kB [0]
[ebuild     UD ] gnome-extra/gnome-power-manager-2.32.0-r2 [9999] USE="applet%* policykit%* -doc% -test" 3,818 kB [1=>0]
[uninstall     ] x11-themes/gnome-icon-theme-symbolic-3.2.0  [1]
[blocks b      ] <gnome-extra/gnome-power-manager-3.1.92 ("<gnome-extra/gnome-power-manager-3.1.92" is blocking x11-themes/gnome-icon-theme-symbolic-3.2.0)
[ebuild  N     ] gnome-base/gnome-2.32.1-r1  USE="cdr cups dvdr ldap policykit -accessibility -mono" 0 kB [0]

Total: 74 packages (3 upgrades, 8 downgrades, 57 new, 5 in new slots, 1 reinstall, 3 uninstalls), Size of downloads: 191,068 kB
Conflict: 3 blocks
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/gnome

WARNING: One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.11.1::gentoo, ebuild scheduled for merge) conflicts with
    <x11-base/xorg-server-1.10.99 required by (x11-drivers/nvidia-drivers-275.09.07::gentoo, installed)


The following mask changes are necessary to proceed:
#required by x11-misc/alacarte-0.13.2-r50, required by gnome-base/gnome-2.32.1-r1, required by gnome (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (29 Jul 2011)
# GNOME 3.0 mask for upgrade packages, don't add new packages to this list
# unless they pull in one of the masked packages
# The "Better late than never!" release
#
# Libraries
# Core Applications
=gnome-base/gnome-menus-3.0.1-r50

The following USE changes are necessary to proceed:
#required by gnome-extra/hamster-applet-2.32.1, required by gnome-base/gnome-2.32.1-r1, required by gnome (argument)
>=dev-lang/python-3.2.2 sqlite
#required by app-admin/sabayon-2.30.1, required by gnome-base/gnome-2.32.1-r1[ldap], required by gnome (argument)
=x11-base/xorg-server-1.10.4 kdrive

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.
#
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Wed Oct 05, 2011 5:34 am    Post subject: Reply with quote

OK, let's start with a concrete example.

Portage is trying to emerge dev-libs/gobject-introspection-9999. It should not be doing that; gobject-introspection-9999 has KEYWORDS="". Instead, it should be trying to emerge gobject-introspection-1.30.0. So let's see why gobject-introspetion-9999 is being pulled into the dependency tree.

Please give the value of ACCEPT_KEYWORDS (from /etc/make.conf) and the output of the following command:

grep -r gobject-introspection /etc/portage/*

Edit: typo
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Wed Oct 05, 2011 9:03 am    Post subject: Reply with quote

Value of "ACCEPT_KEYWORDS" = ACCEPT_KEYWORDS="~x86 ~amd64"

output of the command showed me that the 9999 files where in /etc/portage/package.keywords/grub2
So I removed them, but still when i emerge gnome 3.2 it pulls in allot of 9999 files.

I have run emerge -uND world, revdep-rebuild, emerge --sync and layman -S but still this and I have no clue anymore.
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Wed Oct 05, 2011 5:44 pm    Post subject: Reply with quote

Choose one -9999 library that is still being pulled in.
Look for it in /etc/portage (grep -r name-of-library /etc/portage/*)
Post the output.
Back to top
View user's profile Send private message
aranth
n00b
n00b


Joined: 05 Oct 2011
Posts: 2

PostPosted: Wed Oct 05, 2011 9:59 pm    Post subject: Reply with quote

Not to butt in, but I get the same build failure. I don't know if there's a main informational page for the gnome overlay, but per some googling I did, I saw http://git.overlays.gentoo.org/gitweb/?p=proj/gnome.git;a=log;h=refs/heads/gnome-next (and the same information in another place I don't recall) that says:

Quote:
The gnome-next branch was merged into master, so gnome-3.2 work will
largely be happening in the master branch now. Users who have been using
the gnome-next branch to try out gnome-3.2 need to switch to master.


So I am not using gnome-next (not even really sure how). It is pulling in many -9999 packages that you say are not required and should not be pulled in, but I have reverted all changes to package.keywords and package.use and simply trying to emerge -av >=gnome-3.2.0 pulls in all of these -9999 packages. (By default, portage tells me I need to let it write these changes using autounmask-write. You say I should not use this unless I have a deep understanding of portage, so maybe portage should not by default tell the user to run this option...) "grep -r gnome /usr/portage" gives no results. Chromium, flash, and libreoffice are the only items in package.unmask, and google-chrome:unstable and adobe-flash are the only items in package.keywords.

See http://pastebin.com/KZNvHZgN for emerge output in my case. (the backtrack option is another that was suggested by emerge to try to get it to automatically resolve some blockers). ACCEPT_KEYWORDS="~amd64"

I did think it was strange that it was pulling -9999 packages in for a supposedly stable (at least upstream) release, so it is somewhat comforting that maybe I just have something configured wrong :)
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Thu Oct 06, 2011 2:41 am    Post subject: Reply with quote

aranth, you are seeing those "The following keyword changes are necessary to proceed" errors because you have not unmasked the gnome-3.2 packages. Have a look at the status/portage-configs directory in the overlay (that's /var/lib/layman/gnome/status/portage-configs/ if you are using a recent install of layman).

It contains files which should be symlinked into appropriate places in your /etc/portage. For example,

ln -s /var/lib/layman/gnome/status/portage-configs/package.unmask.gnome3 /etc/portage/package.unmask/package.unmask.gnome3
ln -s /var/lib/layman/gnome/status/portage-configs/package.use.mask.gnome3 /etc/portage/profile/package.use.mask/package.use.mask.gnome3
etc.

If you don't have the appropriate directories in /etc/portage, you will have to mkdir them. Read "man portage" for details.

white_tiger, my guess is that at some point in the past you saw error messages similar to aranth's pastebin, and then allowed portage to make the changes that it told you were "necessary to proceed". That was not such a good idea; portage is a strange beast, and on occasion has been known to give stunningly bad advice. If you tell portage that you have a headache, portage might recommend you to chop off your head. You must use your own intelligence and knowledge of how portage operates; do not blindly trust the advice of machines! :wink:
Back to top
View user's profile Send private message
aranth
n00b
n00b


Joined: 05 Oct 2011
Posts: 2

PostPosted: Fri Oct 07, 2011 8:20 pm    Post subject: Reply with quote

Thanks, that got me to a more sane set of packages!
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Sat Oct 08, 2011 4:54 pm    Post subject: Reply with quote

Thx a world cleaning and correct keyword file did the trick :)

Working with gnome 3.2 for 2 days now. Totally different from my main desk (E17) but looks promising.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum