Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme beim upgrade mit "parted" und "lvm2" [SOLVED]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mark_doe
n00b
n00b


Joined: 04 Oct 2011
Posts: 9

PostPosted: Sat Oct 08, 2011 7:55 pm    Post subject: Probleme beim upgrade mit "parted" und "lvm2& Reply with quote

Hallo Servermeister,

ein Xen Server bekam sein upgrade mit emerge -avDN world

Ich habe jedoch bei 2 Paketen compiling Probleme, egal was ich auch versuche:
parted und lvm2

ich habe es schon probiert mit einem
Code:
USE="-static" emerge -av lvm2
allerding hat das nun zur Folge, dass ich kein lvm2 mehr habe :o (was mein Xen System aber dringend benötigt, Neustart geht nun auf keinen Fall mehr)

parted und lvm2 brechen ab mit einem:
Code:
x86_64-pc-linux-gnu-gcc -c -I. -I../include -O2 -mno-tls-direct-seg-refs -pipe -O2 -mno-tls-direct-seg-refs -pipe -DLVM1_INTERNAL -DPOOL_INTERNAL -DCLUSTER_LOCKING_INTERNAL -DSNAPSHOT_INTERNAL -DMIRRORED_INTERNAL -DREADLINE_SUPPORT -DDEVMAPPER_SUPPORT -DO_DIRECT_SUPPORT -DHAVE_LIBDL -DHAVE_GETOPTLONG -DHAVE_RL_COMPLETION_MATCHES -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -O2 -O2 -mno-tls-direct-seg-refs -pipe -DLVM1_INTERNAL -DPOOL_INTERNAL -DCLUSTER_LOCKING_INTERNAL -DSNAPSHOT_INTERNAL -DMIRRORED_INTERNAL -DREADLINE_SUPPORT -DDEVMAPPER_SUPPORT -DO_DIRECT_SUPPORT -DHAVE_LIBDL -DHAVE_GETOPTLONG -DHAVE_RL_COMPLETION_MATCHES -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -O2 snapshot/snapshot.c -o snapshot/snapshot.o
x86_64-pc-linux-gnu-gcc -c -I. -I../include -O2 -mno-tls-direct-seg-refs -pipe -O2 -mno-tls-direct-seg-refs -pipe -DLVM1_INTERNAL -DPOOL_INTERNAL -DCLUSTER_LOCKING_INTERNAL -DSNAPSHOT_INTERNAL -DMIRRORED_INTERNAL -DREADLINE_SUPPORT -DDEVMAPPER_SUPPORT -DO_DIRECT_SUPPORT -DHAVE_LIBDL -DHAVE_GETOPTLONG -DHAVE_RL_COMPLETION_MATCHES -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -O2 -O2 -mno-tls-direct-seg-refs -pipe -DLVM1_INTERNAL -DPOOL_INTERNAL -DCLUSTER_LOCKING_INTERNAL -DSNAPSHOT_INTERNAL -DMIRRORED_INTERNAL -DREADLINE_SUPPORT -DDEVMAPPER_SUPPORT -DO_DIRECT_SUPPORT -DHAVE_LIBDL -DHAVE_GETOPTLONG -DHAVE_RL_COMPLETION_MATCHES -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -O2 mirror/mirrored.c -o mirror/mirrored.o
locking/cluster_locking.c: In function '_send_request':
locking/cluster_locking.c:97: error: 'PIPE_BUF' undeclared (first use in this function)
locking/cluster_locking.c:97: error: (Each undeclared identifier is reported only once
locking/cluster_locking.c:97: error: for each function it appears in.)
locking/cluster_locking.c:97: warning: unused variable 'outbuf'
locking/cluster_locking.c: In function '_lock_resource':
locking/cluster_locking.c:381: error: 'PATH_MAX' undeclared (first use in this function)
locking/cluster_locking.c:381: warning: unused variable 'lockname'
make[1]: *** [locking/cluster_locking.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/sys-fs/lvm2-2.01.13/work/LVM2.2.01.13/lib'
make: *** [lib] Error 2
emake failed
 * ERROR: sys-fs/lvm2-2.01.13 failed (compile phase):
 *   compile problem
 *
 * Call stack:
 *     ebuild.sh, line  91:  Called src_compile
 *   environment, line 155:  Called die
 * The specific snippet of code:
 *       emake || die "compile problem"


habe schon das hier versucht:
Code:
emerge -avDN --emptytree world


Hat jemand einen Hinweis? Wie gehe ich am Besten vor?

Hier der Output von emerge --info
Code:
~ # emerge --info =sys-fs/lvm2-2.01.13
Portage 2.1.10.23 (default/linux/amd64/10.0/server, gcc-4.4.5, glibc-2.13-r4, 2.6.34-xen-r4 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.34-xen-r4-x86_64-Intel-R-_Xeon-R-_CPU_E3110_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Sat, 08 Oct 2011 12:00:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-lang/python:          2.7.2-r3, 3.1.3-r1, 3.2.2
dev-util/ccache:          3.1.6
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.33 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mno-tls-direct-seg-refs -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mno-tls-direct-seg-refs -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl acpi agent amd64 api apic berkdb bzip2 ccache cli clvm cman cracklib crypt cxx device-mapper diskio dri extensible fortran fpu gdbm gpm http hvm iconv ilo ioemu ipmi iproute2 ipv6 iscsi lm_sensors lvm lvm2 macvtap mmx modules mudflap multilib ncurses nfs nls nptl nptlonly ntplonly openipmi openmp openssl pam parted pcap pcre perl pkcs11 pppd python qemu readline screen session slang snmp sse sse2 sse4a ssh ssl ssse3 symlink sysfs tcpd truetype uml unicode virt-network vnc xen xml xmlrpc xorg" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Danke für jeden Tip!


Last edited by mark_doe on Tue Nov 01, 2011 7:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
mark_doe
n00b
n00b


Joined: 04 Oct 2011
Posts: 9

PostPosted: Thu Oct 13, 2011 1:09 pm    Post subject: Reply with quote

ein package.mask hat bewirkt, dass sich immer wieder diese eine lvm2 Version installieren wollte mit bekanntem Ergebnis.

Mit einer aktuelleren Version hat es reibungslos geklappt !
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Thu Oct 13, 2011 6:39 pm    Post subject: Reply with quote

1.) Danke für die Rückmeldung.

2.) Ergänze doch bitte den Betreff Deines Postings um "[solved]". Danke.

3.) Das alte/unsaubere Einträge in /etc/portage/package.* üble Seiteneffekte haben können, habe ich auch gerade wieder erfahren dürfen. :)
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum