Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Applying Overlays (specifically GNOME3)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sdz
n00b
n00b


Joined: 26 Sep 2011
Posts: 24

PostPosted: Sat Oct 15, 2011 4:27 am    Post subject: Applying Overlays (specifically GNOME3) Reply with quote

What are the "usual steps" for installing a Gentoo overlay and installing a package from it?

From what I understand, the following is the basic procedure:
layman -a <overlay_name>
copy/symlink portage-configs approprately
append 'source /var/lib/layman/make.conf' to /etc/make.conf
emerge -ND world

When I run 'emerge -av gnome', it does show the new overlay `/var/lib/layman/gnome` but still lists gnome-2.32.1-r1 as the latest version of gnome.

Any thoughts on what I might be doing wrong?
Back to top
View user's profile Send private message
cdstealer
Guru
Guru


Joined: 30 Oct 2005
Posts: 423
Location: Leeds

PostPosted: Sat Oct 15, 2011 6:26 am    Post subject: Reply with quote

You will need to add all the packages to /etc/portage/package.keywords and comment out the packages in /usr/portage/profile/package.mask. There is a specific heading in the package.mask file for gnome3. There are also a few post on this forum that list the packages you need to add to keywords. :)
_________________
# touch it
touch: cannot touch `it': Permission denied
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum