Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] gnome-core-libs requires non existing package
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Wed Oct 19, 2011 1:50 pm    Post subject: [SOLVED] gnome-core-libs requires non existing package Reply with quote

Just ran my daily layman -S and emerge -uD world, and hit a corker.

atk-2.2 has been removed from portage BUT it is needed by gnome-core-libs-3.2.0

Portage wants to downgrade to atk2.0.1{M} but stops as the atk requirement for gnome-core-libs-3.2.0 has not been met.

So does this mean I am waiting on as gnome-core-libs-3.2.1 from the gnome overlay, and it will use atk-2.0.1 ?

Or have I opened a can of worms?

Gnome shell has been broken on this system since the upgrade to 3.2.0 and even the 3.2.1 updates have not resolved it.
_________________
Whatever you do, do it properly!


Last edited by Thistled on Fri Oct 21, 2011 2:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Oct 19, 2011 2:55 pm    Post subject: Reply with quote

as far as i can see atk-2.2.0 is in portage ( masked).

Code:
-->eshowkw atk
Keywords for dev-libs/atk:
             |                           | u   | 
             | a a             p     s   | n   | 
             | l m   h i m m   p s   p   | u s | r
             | p d a p a 6 i p c 3   a x | s l | e
             | h 6 r p 6 8 p p 6 9 s r 8 | e o | p
             | a 4 m a 4 k s c 4 0 h c 6 | d t | o
-------------+---------------------------+-----+-------
   1.32.0    | + + + + + o ~ + + + + + + | o 0 | gentoo
[I]1.32.0-r1 | + + + + + o ~ + + ~ + + + | o   | gentoo
 [M]2.0.1    | ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ ~ | o   | gentoo
 [M]2.2.0    | ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ ~ | o   | gentoo


cheers
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Oct 19, 2011 3:53 pm    Post subject: Reply with quote

O.o

didn't knew about eshowkw (included in gentoolkit)

nice replacement for udept & once eix doesn't work due to failing dependencies :)

thanks !


edit:

it doesn't really seem to work with repositories :(

anyway yet another nice tool


edit2:

I have both atk 1.32.0 and 1.32.0-r1



using an non-outdated rsync mirror might help
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Oct 19, 2011 4:19 pm    Post subject: Reply with quote

just FYI, i have following function in my .bash.functions:

Code:
function kw (){
eshowkw $@ -O -a amd64 x86 ppc
}


output should be quite easy to understand :

Code:
-->kw cairo
Keywords for x11-libs/cairo:
             |       | u   | 
             | a     | n   | 
             | m     | u s | r
             | d p x | s l | e
             | 6 p 8 | e o | p
             | 4 c 6 | d t | o
-------------+-------+-----+--------------
   1.8.10    | + + + | # 0 | gentoo       
[I]1.10.2-r1 | + + + | o   | gentoo       
[I]1.10.2-r1 | ~ ~ ~ | o   | lcd-filtering
  [M]9999    | ~ ~ ~ | o   | gentoo       


cheers guys
Back to top
View user's profile Send private message
tetromino
Retired Dev
Retired Dev


Joined: 02 Dec 2003
Posts: 215

PostPosted: Fri Oct 21, 2011 5:51 am    Post subject: Reply with quote

Thistled, atk-2.2 was moved from the overlay to portage and masked for testing (so that all the gnome-2 users wouldn't be immediately forced to upgrade to it). But if you are using gnome-3.2, you obviously need atk-2.2 unmasked. To do so, there is a package.unmask.gnome3 file in the status/portage-configs directory in the overlay. This file is updated frequently, so for simplicity you should symlink it into your /etc/portage/package.unmask/ directory.

If you are using the default setup with recent versions of layman, simply do
ln -s /var/lib/layman/gnome/status/portage-configs/package.unmask.gnome3 /etc/portage/package.unmask/package.unmask.gnome3
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Fri Oct 21, 2011 2:16 pm    Post subject: Reply with quote

Apologies.

My bad and stupid.

My system updates just after midnight (UK time), and it seems I must have been updating as changes were being made, so I missed some of the "changes".

After running emerge --sync and layman -S my system got the other half so to speak, and atk-2.2 appeared.

In my defence, it is netiquette to only hit the gentoo servers once a day, and I always adhere to that. But in this instance, I broke the rules and synced twice in one day. :lol:
Could a moderator delete this post, as it was due to human (STUPID) error.
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum