Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Asus eee pc wlan karte läuft nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Wed Oct 26, 2011 7:32 pm    Post subject: Asus eee pc wlan karte läuft nicht Reply with quote

Hallöchen

Hab bis jetzt mal rausgefunden das es sich um einen

BCM4313 wlan chip handelt

Code:

# lspci
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)


hab jetzt auch diese seite gefunden mit linux driver
http://www.broadcom.com/support/802.11/linux_sta.php

so nun bin ich laut dem Readme vorgegangen leider bekomme ich immer eine fehlermeldung schon beim entpacken mit tar
Code:
Kann Datei-Eigentümer nicht zu uid 52258, gid 100 ändern: Die Operation ist nicht erlaubt


ich bin mittels der konsole zu root gewechselt und dann per ssh auf den kleinen asus eee pc drauf (auch dort als root)

Kernel wäre 3.1.0
kde4.7.2

Ich habe ne live cd probier (Linux Mint) um zu gucken ob der wlan chip unter linux überhaupt läuft ..
lauft der live cd ja tut sie ... recht ok sogar ... ausgespuckt wurde mir das hier

Code:

mint@mint ~ $ lspci -vv -s 02:00.0
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
   Subsystem: AzureWave Device 2047
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 17
   Region 0: Memory at f9ffc000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: brcm80211
   Kernel modules: brcm80211


leider find ich ein modul brcm80211 nicht.

hmm wenn wer noch infos braucht bitte sagen.

hoffe es kann mir wer helfen dieses wlan zum laufen zu bringen
danke schon mal im vorhinein..

mfg
schatti
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Wed Oct 26, 2011 9:07 pm    Post subject: Reply with quote

Hmm, ist die nun die Fortsetzung aus diesem Foren-Thread ?

Schau doch auch mal ob http://en.gentoo-wiki.com/wiki/Broadcom_43xx
weiterhilft.
Back to top
View user's profile Send private message
hilti_hit
n00b
n00b


Joined: 15 Oct 2011
Posts: 5

PostPosted: Wed Oct 26, 2011 10:10 pm    Post subject: Reply with quote

Hallo!

Bei mir geht es mit net-wireless/broadcom-sta.

Anders habe ich es noch nicht hinbekommen, trotzdem zwei interessante Links zu dem Thema:

https://forums.gentoo.org/viewtopic-p-6814234.html
https://forums.gentoo.org/viewtopic-t-880657-highlight-brcm.html
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Wed Oct 26, 2011 10:24 pm    Post subject: Reply with quote

Josef.95 wrote:
Hmm, ist die nun die Fortsetzung aus diesem Foren-Thread ?

Schau doch auch mal ob http://en.gentoo-wiki.com/wiki/Broadcom_43xx
weiterhilft.


wieso fortsetzung ? .. ich hole mir nur hilfe halt ... ist es verboten auf 2 foren zu fragen ?

mit broadcom-sta geht garnix ... der jammer ständig über die probleme

Code:

* Checking for suitable kernel configuration options...
 *   CONFIG_B43:         should not be set. But it is.
 *   CONFIG_SSB:         should not be set. But it is.
 *   CONFIG_WIRELESS_EXT:        is not set when it should be.
 *   Starting with 2.6.33, it is not possible to set WEXT_PRIV directly. We recommend to set another symbol selecting WEXT_PRIV, for example, PRISM54, IPW2200 and so on. See Bug #248450 comment#98.
 *   CONFIG_MAC80211:    should not be set. But it is.


und ja ich habe den Kernel schon 20 mal neu configuriert ... sogar die config neu erstellen lassen usw..

werd mir die links von heute nochmal anschauen kennen tu ich sie schon..

mfg
schatti
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Thu Oct 27, 2011 5:59 am    Post subject: Reply with quote

Schattenschlag wrote:
Josef.95 wrote:
Hmm, ist die nun die Fortsetzung aus diesem Foren-Thread ?

Schau doch auch mal ob http://en.gentoo-wiki.com/wiki/Broadcom_43xx
weiterhilft.


wieso fortsetzung ? .. ich hole mir nur hilfe halt ... ist es verboten auf 2 foren zu fragen ?

Nein ist vermutlich nicht verboten.
Doch ich verstehe das eigentliche Problem immer noch nicht so recht, ist doch vermutlich nur ne frage der Kernel Konfiguration wie schon vom Ebuild vorgeschlagen?!
Siehe zb auch http://nixbits.net/wiki/Asus_eeepc_1015ped_Gentoo_Linux#wireless_nic
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Thu Oct 27, 2011 9:48 am    Post subject: Reply with quote

tja und genau daran scheitere ich ja, ich kann ja mal die .config datei hochladen aber ich finde echt nicht mehr wo ich was einstellen soll damit diese fehlermeldung nicht kommt..

ich werde jetzt eine neue config nochmal erstellen kann doch ned sein das ich das ned hinbekomme ...gruml
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1792
Location: Oranienburg/Germany

PostPosted: Thu Oct 27, 2011 11:10 am    Post subject: Reply with quote

Schattenschlag wrote:

mit broadcom-sta geht garnix ... der jammer ständig über die probleme

Code:

* Checking for suitable kernel configuration options...
 *   CONFIG_B43:         should not be set. But it is.
 *   CONFIG_SSB:         should not be set. But it is.
 *   CONFIG_WIRELESS_EXT:        is not set when it should be.
 *   Starting with 2.6.33, it is not possible to set WEXT_PRIV directly. We recommend to set another symbol selecting WEXT_PRIV, for example, PRISM54, IPW2200 and so on. See Bug #248450 comment#98.
 *   CONFIG_MAC80211:    should not be set. But it is.


und ja ich habe den Kernel schon 20 mal neu configuriert ... sogar die config neu erstellen lassen usw..

werd mir die links von heute nochmal anschauen kennen tu ich sie schon..

mfg
schatti


Hi,

diese Optionen müssen abgeschaltet sein, damit das Paket broadcom-sta übersetzt/installiert werden kann. Um nach den Optionen zu suchen einfach "make menuconfig" starten und dann mit SHIFT+7 (aka /) nach den Optionen suchen. Das zeigt dir dann auch in welchem Menü die Punkte versteckt sind.

Wenn du den Kernel neu übersetzt hast und installiert hast, einfach nochmal das Paket broadcom-sta installieren. Dann sollte das auch alles funktionieren.

MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Mon Oct 31, 2011 1:52 pm    Post subject: Reply with quote

habs hinbekommen ... und zwar hab ich die driver von der broadcom seite compiliert und dann in den kernel eingeflegt ... das einzige was ich nun noch nicht ganz kapier ist das
es unter root klappt also die verbindung zum internet aber unter dem user nicht ?

Code:
mit dem programm -wpa-supplicant -> als root klappt da findet er die eth1(wlankarte) und zack bin online
das gleiche mit den user findet das prog die eth1 leider nicht .. wieso is mir noch schleierhaft ...


ach ja und das hier ist auch aufgetaucht beim hochfahren ...


Code:
net.eth1 | ioctl[IEEE80211_IOCTL_DELKEY]: Operation not supported


woran dieser fehler nun verknüpft ist weis ich leider nicht ...

so hoffe nun das mit wpa noch in den griff zu bekommen...

mfg
schatti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum