Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED, Gnome 3.2] Block error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mathepic
n00b
n00b


Joined: 23 Jan 2011
Posts: 14

PostPosted: Sat Oct 29, 2011 7:31 pm    Post subject: [SOLVED, Gnome 3.2] Block error Reply with quote

I can't figure out how to resolve the following block:

Code:


gentoo ~ # emerge -uav gnome-panel gnome-light gdm gnome-power-manager gnome-menus pygobject gnome-panel pygtksourceview gnome-desktop pygtk gnome-applets gnome-python-base gnome-control-center

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libical-0.43  1,119 kB [0]
[ebuild  N    ~] media-gfx/shared-color-profiles-0.1.4  18,209 kB [0]
[ebuild  N     ] net-libs/libasyncns-0.7  USE="-debug -doc" 0 kB [0]
[ebuild  N     ] media-libs/libdiscid-0.1.1  325 kB [0]
[ebuild  NS   ~] media-libs/lcms-2.2-r1 [1.19] USE="zlib -doc -jpeg -static-libs -test -tiff" 4,096 kB [0]
[ebuild  N     ] app-text/docbook-dsssl-stylesheets-1.79  272 kB [0]
[ebuild  N     ] app-text/docbook-sgml-dtd-3.0-r3  43 kB [0]
[ebuild  N     ] app-text/docbook-sgml-dtd-4.1-r3  56 kB [0]
[ebuild  N     ] media-libs/libv4l-0.8.5  366 kB [0]
[ebuild  N     ] app-text/docbook-sgml-dtd-3.1-r3  55 kB [0]
[ebuild  N     ] app-text/docbook-sgml-dtd-4.0-r3  55 kB [0]
[ebuild  N     ] app-text/docbook-xml-simple-dtd-4.1.2.4-r2  35 kB [0]
[ebuild  N     ] gnome-extra/gnome-audio-2.22.2  USE="-debug" 0 kB [0]
[ebuild  N     ] dev-perl/SGMLSpm-1.03-r5  92 kB [0]
[ebuild  N     ] dev-libs/libatomic_ops-1.2-r1  0 kB [0]
[ebuild  N     ] media-libs/audiofile-0.3.1  USE="-static-libs" 706 kB [0]
[ebuild  N     ] app-text/opensp-1.5.2-r2  USE="nls -doc -static-libs -test" 1,486 kB [0]
[ebuild  N     ] app-text/openjade-1.3.2-r3  USE="-static-libs" 874 kB [0]
[ebuild  N    ~] media-video/gnome-video-effects-0.3.0  175 kB [0]
[ebuild     U ~] dev-libs/glib-2.30.1-r1 [2.28.8] USE="static-libs -debug -doc -fam (-selinux) -systemtap% -test -utils% -xattr (-introspection%)" 5,674 kB [0]
[ebuild  N     ] app-admin/eselect-esd-20060719  0 kB [0]
[ebuild     U ~] gnome-base/gsettings-desktop-schemas-3.2.0-r1 [3.0.1] 152 kB [0=>1]
[ebuild  N     ] app-admin/apg-2.3.0b-r5  USE="cracklib" 108 kB [0]
[ebuild  N    ~] net-libs/liboauth-0.9.4  USE="nss -bindist -curl -doc" 449 kB [0]
[ebuild  N     ] media-libs/libtheora-1.1.1  USE="encode -doc -examples -static-libs" 1,859 kB [0]
[ebuild     U ~] net-wireless/wpa_supplicant-0.7.3-r5 [0.7.3-r2] USE="dbus readline ssl -debug -eap-sim -fasteap -gnutls -madwifi (-ps3) -qt4 -wimax -wps" 0 kB [0]
[ebuild  N    ~] media-fonts/cantarell-0.0.7  USE="X" 356 kB [0]
[ebuild  N     ] media-libs/speex-1.2_rc1  USE="sse -ogg -static-libs" 0 kB [0]
[ebuild  N     ] media-libs/flac-1.2.1-r3  USE="cxx sse -3dnow (-altivec) -debug -ogg -static-libs" 0 kB [0]
[ebuild  N     ] x11-apps/xhost-1.0.4  USE="ipv6" 113 kB [0]
[ebuild  N     ] dev-libs/openobex-1.5  USE="-bluetooth -debug -irda -syslog -usb" 392 kB [0]
[ebuild  N     ] www-client/lynx-2.8.7_p1  USE="bzip2 ipv6 nls ssl unicode -cjk -gnutls" 2,376 kB [0]
[ebuild  N     ] media-libs/libsndfile-1.0.25  USE="alsa -minimal -sqlite -static-libs" 1,036 kB [0]
[ebuild  N    ~] dev-util/gdbus-codegen-2.30.1  0 kB [0]
[ebuild  N     ] dev-python/dbus-python-0.84.0  USE="-doc -examples -test" 551 kB [0]
[ebuild  N    #] dev-lang/spidermonkey-1.8.5  USE="-static-libs -test" 6,021 kB [0]
[ebuild     U ~] x11-libs/libxklavier-5.1 [5.0] USE="-doc" 339 kB [0]
[ebuild  N     ] app-text/docbook-xml-simple-dtd-1.0-r1  31 kB [0]
[ebuild     U ~] dev-python/pycairo-1.10.0-r2 [1.8.10] USE="svg* -doc -examples -test" 634 kB [0]
[ebuild  N     ] dev-lang/vala-0.14.0  USE="vapigen -test" 2,533 kB [0]
[ebuild  N     ] dev-lang/vala-0.12.1  USE="vapigen -test" 2,233 kB [0]
[ebuild  N     ] app-text/docbook-sgml-utils-0.6.14-r1  USE="-jadetex" 123 kB [0]
[ebuild  N     ] dev-util/gtk-doc-1.18  USE="-debug -doc -emacs -highlight -test -vim" 0 kB [0]
[ebuild  N     ] media-libs/musicbrainz-3.0.2  USE="-test" 97 kB [0]
[ebuild     U ~] x11-themes/gnome-icon-theme-3.2.1.2 [3.0.0] USE="-branding" 13,682 kB [0=>1]
[ebuild  N     ] sys-libs/libcap-2.17  USE="pam" 0 kB [0]
[ebuild  N    ~] x11-themes/gnome-icon-theme-symbolic-3.2.1  144 kB [1]
[ebuild     U #] dev-libs/gobject-introspection-9999 [0.10.8] USE="-doc -test" 0 kB [0=>1]
[ebuild     U ~] x11-libs/pango-1.29.4 [1.28.4] USE="X introspection -debug -doc -test" 1,129 kB [0]
[ebuild     U ~] dev-libs/atk-2.2.0 [1.32.0-r1] USE="introspection nls -doc" 587 kB [0]
[ebuild  N    #] dev-libs/json-glib-0.13.4  USE="introspection -debug -doc" 428 kB [0]
[ebuild  N    ~] net-libs/telepathy-glib-0.16.1  USE="introspection vala -debug -test" 3,059 kB [0]
[ebuild  NS   #] dev-python/pygobject-3.0.2 [2.28.6] USE="cairo threads -examples -test" 533 kB [0]
[ebuild  N     ] dev-libs/libgee-0.6.2.1  USE="introspection" 392 kB [0]
[ebuild  N    ~] x11-misc/colord-0.1.13  USE="introspection udev -doc -examples -scanner" 435 kB [0]
[ebuild  N    #] dev-libs/gjs-9999  USE="-examples -test" 0 kB [1]
[ebuild   R    ] x11-libs/gdk-pixbuf-2.24.0-r1  USE="X introspection jpeg* -debug -doc -jpeg2k -test -tiff" 0 kB [0]
[ebuild  N    ~] app-accessibility/at-spi2-core-2.2.1  USE="introspection -doc" 421 kB [1]
[ebuild     U ~] x11-libs/gtk+-3.2.1 [3.0.12-r1] USE="cups introspection (-aqua) -colord% -debug -doc -examples -packagekit% -test -vim-syntax -xinerama" 12,368 kB [0]
[ebuild  N     ] media-sound/pulseaudio-0.9.22-r2  USE="X alsa asyncns caps dbus glib gnome ipv6 tcpd udev -avahi -bluetooth -doc -jack -libsamplerate -lirc (-oss) -realtime (-system-wide) -test" 0 kB [0]
[ebuild  N    #] media-libs/cogl-9999  USE="introspection pango -debug -doc -examples -test" 0 kB [1]
[ebuild  N     ] net-im/telepathy-logger-0.2.10-r1  USE="introspection -doc -test" 439 kB [0]
[ebuild  N    ~] dev-python/pyatspi-2.2.1  USE="-test" 260 kB [1]
[ebuild  N     ] net-im/telepathy-mission-control-5.8.1  USE="-gnome-keyring" 1,108 kB [0]
[ebuild  N    #] media-libs/clutter-9999  USE="introspection -debug -doc" 0 kB [1]
[ebuild  NS   ~] gnome-base/gnome-desktop-3.2.1 [2.32.1] USE="introspection -debug -doc" 903 kB [1]
[ebuild     U ~] gnome-base/dconf-0.10.0 [0.8.0] USE="X bash-completion -doc -vala" 169 kB [0=>1]
[ebuild  NS   #] gnome-base/gnome-menus-3.2.0.1 [2.30.5] USE="introspection python -debug -test" 393 kB [1]
[ebuild     U #] gnome-base/libgnomekbd-3.2.0 [2.32.0] USE="introspection%* -test" 368 kB [0=>1]
[ebuild     U ~] x11-themes/gnome-themes-standard-3.2.1 [3.0.2] 1,029 kB [0]
[ebuild  NS   ~] x11-libs/libwnck-3.2.1 [2.30.7] USE="introspection -doc -startup-notification" 634 kB [1]
[ebuild  N     ] media-libs/gst-plugins-bad-0.10.22  USE="orc" 0 kB [0]
[ebuild  N     ] media-plugins/gst-plugins-ogg-0.10.35  0 kB [0]
[ebuild  N     ] media-plugins/gst-plugins-vorbis-0.10.35  0 kB [0]
[ebuild  N     ] media-plugins/gst-plugins-pango-0.10.35  0 kB [0]
[ebuild  N     ] media-plugins/gst-plugins-jpeg-0.10.30  0 kB [0]
[ebuild  N     ] media-plugins/gst-plugins-theora-0.10.35  0 kB [0]
[ebuild  N     ] media-plugins/gst-plugins-v4l2-0.10.30  0 kB [0]
[ebuild  N    ~] dev-libs/folks-0.6.4.1  USE="-debug -eds -socialweb -test -tracker -vala" 1,316 kB [1]
[ebuild  NS   ~] dev-libs/libunique-3.0.2 [1.1.6-r1] USE="introspection -debug -doc -test" 288 kB [0]
[ebuild  NS   ~] x11-libs/vte-0.30.1 [0.28.2-r200] USE="introspection -debug -doc -glade" 930 kB [0]
[ebuild  NS   ~] x11-libs/gtksourceview-3.2.2 [2.10.5-r1] USE="introspection -doc -glade -test" 1,185 kB [0]
[ebuild     U #] app-text/evince-9999 [2.32.0-r3] USE="dbus introspection* -debug -djvu -doc -dvi -gnome-keyring -nautilus -t1lib -tiff -xps% (-gnome%*)" 0 kB [0=>1]
[ebuild  N    ~] media-libs/clutter-gtk-1.0.4  USE="introspection -debug -doc -examples" 299 kB [0]
[ebuild  N    ~] media-libs/clutter-gst-1.4.2  USE="introspection -debug -doc -examples" 330 kB [0]
[ebuild  N    #] x11-wm/mutter-9999  USE="introspection -test -xinerama" 0 kB [1]
[ebuild  N    ~] x11-libs/mx-1.3.1  USE="dbus gtk introspection -debug -doc -glade -startup-notification" 1,224 kB [0]
[ebuild  N    ~] app-accessibility/caribou-0.4.1  353 kB [1]
[ebuild     U #] x11-terms/gnome-terminal-9999 [2.32.1] 0 kB [0=>1]
[ebuild     U #] x11-wm/metacity-2.34.1 [2.30.3] USE="-test -xinerama" 1,874 kB [0]
[ebuild  N     ] net-libs/webkit-gtk-1.4.3-r300  USE="gstreamer introspection jit (-aqua) -coverage -debug -doc -spell -test" 8,313 kB [0]
[ebuild  N    #] media-video/cheese-9999  USE="introspection -doc -vala" 0 kB [1]
[ebuild  N    ~] sys-apps/accountsservice-0.6.14  USE="introspection" 280 kB [0]
[ebuild  N    ~] net-print/cups-pk-helper-0.2.1  212 kB [1]
[ebuild     U #] net-misc/networkmanager-0.9.1.90-r3 [0.8.4.0-r2] USE="dhcpcd introspection%* nss* ppp resolvconf -avahi -bluetooth -connection-sharing -dhclient -doc -gnutls -wimax%" 1,709 kB [0=>1]
[ebuild  N     ] net-wireless/bluez-4.96  USE="alsa consolekit cups -caps -debug -gstreamer -health -maemo6 -old-daemons -pcmcia -pnat -test-programs -usb" 1,647 kB [0]
[ebuild     U #] gnome-extra/gnome-power-manager-3.2.1 [2.32.0-r1] USE="-test (-applet%*) (-doc%) (-policykit%)" 718 kB [0=>1]
[blocks b      ] <gnome-extra/gnome-power-manager-3.1.3 ("<gnome-extra/gnome-power-manager-3.1.3" is blocking gnome-base/gnome-settings-daemon-9999)
[blocks b      ] <gnome-extra/gnome-power-manager-3.1.92 ("<gnome-extra/gnome-power-manager-3.1.92" is blocking x11-themes/gnome-icon-theme-symbolic-3.2.1)
[ebuild  N     ] app-mobilephone/obexd-0.42  USE="-debug -eds -nokia -server -usb" 417 kB [0]
[ebuild     U #] gnome-base/gnome-settings-daemon-9999 [2.32.1-r2] USE="cups%* udev%* -debug -packagekit% -policykit -short-touchpad-timeout% -smartcard -test% (-libnotify%) (-pulseaudio%)" 0 kB [0=>1]
[ebuild     U ~] x11-misc/notification-daemon-0.7.3 [0.5.0] 269 kB [0]
[ebuild     U ~] sys-apps/gnome-disk-utility-3.0.2-r200 [2.32.1-r1] USE="-avahi -doc -fat -gnome-keyring -nautilus -remote-access" 1,956 kB [0]
[ebuild     U #] gnome-base/gnome-session-9999 [2.32.1-r3] USE="ipv6 -debug -doc" 0 kB [0=>1]
[ebuild     U #] gnome-extra/nm-applet-0.9.1.90 [0.8.4] USE="-bluetooth" 1,045 kB [0=>1]
[ebuild     U ~] gnome-base/gvfs-1.10.1 [1.6.7-r1] USE="gdu http udev -afp% -archive -avahi -bluetooth -bluray% -cdda -doc -fuse -gnome-keyring -gphoto2 -ios -samba (-bash-completion%*) (-gnome%*) (-prefix%)" 1,265 kB [0]
[ebuild  N    ~] net-libs/rest-0.7.10  USE="gnome introspection -doc -test" 410 kB [0]
[ebuild     U #] dev-libs/libgweather-9999 [2.30.3] USE="introspection%* -doc (-python%)" 0 kB [0=>1]
[ebuild  N    ~] dev-libs/libgdata-0.10.0  USE="gnome introspection -debug -doc -static-libs" 1,101 kB [1]
[ebuild  N    #] gnome-base/gnome-core-libs-3.2.0  USE="cups -python" 0 kB [1]
[ebuild     U #] gnome-base/gnome-panel-9999 [2.32.1-r2] USE="introspection* -doc -eds -networkmanager (-bonobo%*)" 0 kB [0=>1]
[ebuild  N    ~] net-libs/libsocialweb-0.25.19  USE="gnome introspection networkmanager -connman -doc -vala" 460 kB [0]
[ebuild  N    #] gnome-base/gnome-fallback-3.2.0  USE="cups" 0 kB [1]
[ebuild  N    #] net-libs/gnome-online-accounts-9999  USE="introspection -debug -doc" 0 kB [1]
[ebuild  N    #] gnome-extra/evolution-data-server-9999  USE="gnome-online-accounts introspection ipv6 ssl weather -doc -kerberos -ldap -test -vala" 0 kB [1]
[ebuild     U #] gnome-base/nautilus-9999 [2.32.2.1-r1] USE="gnome introspection* previewer%* -doc -exif% -packagekit% -sendto% -test -tracker% -xmp" 0 kB [0=>1]
[ebuild  N    ~] gnome-extra/sushi-0.2.1  290 kB [1]
[ebuild  N    #] net-wireless/gnome-bluetooth-9999  USE="introspection -debug -doc -sendto" 0 kB [1]
[ebuild     U #] gnome-base/gnome-control-center-9999 [2.32.1-r1] USE="cheese%* cups%* networkmanager%* socialweb%* -debug (-eds%)" 0 kB [0=>1]
[ebuild  N    #] gnome-base/gnome-shell-9999  0 kB [1]
[ebuild     U #] gnome-base/gnome-light-3.2.0 [2.32.1] USE="cups%* fallback%* shell%* (-automount%*)" 0 kB [0=>1]
[ebuild     U #] gnome-base/gdm-3.2.1.1-r1 [2.20.11-r1] USE="consolekit gnome-shell%* introspection%* ipv6 tcpd xklavier%* -accessibility -debug% -fprint% -gnome-keyring (-selinux) -smartcard% -test% -xinerama (-afs%) (-branding%*) (-dmx%) (-pam%*) (-remote%)" 1,594 kB [0=>1]
[blocks b      ] <gnome-base/gdm-2.91.94 ("<gnome-base/gdm-2.91.94" is blocking gnome-base/gnome-control-center-9999)
[blocks B      ] <gnome-base/gnome-menus-3.0.1-r50:0 ("<gnome-base/gnome-menus-3.0.1-r50:0" is blocking gnome-base/gnome-menus-3.2.0.1)

Total: 120 packages (30 upgrades, 81 new, 8 in new slots, 1 reinstall), Size of downloads: 120,968 kB
Conflict: 4 blocks (1 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/gnome

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (gnome-base/gnome-menus-2.30.5::gentoo, installed) pulled in by
    >=gnome-base/gnome-menus-2.27.92:0 required by (gnome-base/gnome-panel-2.32.1-r2::gentoo, installed)

  (gnome-base/gnome-menus-3.2.0.1::gnome, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-menus-3.2.0 required by (gnome-base/gnome-light-3.2.0::gnome, ebuild scheduled for merge)
    gnome-menus
    >=gnome-base/gnome-menus-2.29.10:3[introspection] required by (gnome-base/gnome-shell-9999::gnome, ebuild scheduled for merge)
    gnome-base/gnome-menus:3 required by (gnome-base/gnome-control-center-9999::gnome, ebuild scheduled for merge)
    >=gnome-base/gnome-menus-3.1.4:3 required by (gnome-base/gnome-panel-9999::gnome, ebuild scheduled for merge)


The two gnome-menus should slot; why would they conflict/block? Only one has [introspection].

Also the gdm error baffles me because gdm-2.91.94 doesn't exist.


Last edited by mathepic on Sat Oct 29, 2011 10:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
poncho
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2011
Posts: 88

PostPosted: Sat Oct 29, 2011 9:55 pm    Post subject: Reply with quote

If you are not a gnome-dev, you should avoid the live-ebuilds (*-9999).

Take a look at http://oleeekchoff.blogspot.com/2011/10/gnome-3-on-gentoo.html

Especially the section about "USE-,UNMASK- and MASK-flags".
Back to top
View user's profile Send private message
mathepic
n00b
n00b


Joined: 23 Jan 2011
Posts: 14

PostPosted: Sat Oct 29, 2011 10:12 pm    Post subject: Reply with quote

poncho wrote:
If you are not a gnome-dev, you should avoid the live-ebuilds (*-9999).

Take a look at http://oleeekchoff.blogspot.com/2011/10/gnome-3-on-gentoo.html

Especially the section about "USE-,UNMASK- and MASK-flags".


Yeah I foolishly let emerge tell me what to unmask and didn't realize that... I already fixed that though. Right now I'm waiting for freedesktop.org to not be down; one of the packages has to be downloaded from there.

This was solved awhile ago.
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Wed Nov 16, 2011 1:36 pm    Post subject: Reply with quote

I fear I may have foolishly taken the advice of portage, as I can not get both the gnome-menus to install. Keep hitting the block.
Code:
[ebuild  NS    ] gnome-base/gnome-menus-2.30.5 [3.2.0.1] USE="python -debug -introspection"
[blocks B      ] <gnome-base/gnome-menus-3.0.1-r1:0 ("<gnome-base/gnome-menus-3.0.1-r1:0" is blocking gnome-base/gnome-menus-3.2.0.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (gnome-base/gnome-menus-2.30.5::gentoo, ebuild scheduled for merge) pulled in by
    =gnome-base/gnome-menus-2.30.5

  (gnome-base/gnome-menus-3.2.0.1::gentoo, installed) pulled in by
    >=gnome-base/gnome-menus-3.1.4:3 required by (gnome-base/gnome-panel-3.2.1::gentoo, installed)
    gnome-base/gnome-menus:3 required by (gnome-base/gnome-control-center-3.2.2::gentoo, installed)
    >=gnome-base/gnome-menus-2.29.10:3[introspection] required by (gnome-base/gnome-shell-3.2.1-r1::gentoo, installed)
    >=gnome-base/gnome-menus-3.2:3 required by (gnome-base/gnome-core-apps-3.2.1::gentoo, installed)

I have put introspection USE on the latest menu and put -introspection for the older menu, but I am still hitting the block.
I have also followed the guide to the letter, but it's stuck.
As I only have one version of gnome-menus installed, could this be why I can't get gnome-shell to load?
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
mathepic
n00b
n00b


Joined: 23 Jan 2011
Posts: 14

PostPosted: Wed Nov 16, 2011 11:34 pm    Post subject: Reply with quote

Thistled wrote:
I fear I may have foolishly taken the advice of portage, as I can not get both the gnome-menus to install. Keep hitting the block.
Code:
[ebuild  NS    ] gnome-base/gnome-menus-2.30.5 [3.2.0.1] USE="python -debug -introspection"
[blocks B      ] <gnome-base/gnome-menus-3.0.1-r1:0 ("<gnome-base/gnome-menus-3.0.1-r1:0" is blocking gnome-base/gnome-menus-3.2.0.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (gnome-base/gnome-menus-2.30.5::gentoo, ebuild scheduled for merge) pulled in by
    =gnome-base/gnome-menus-2.30.5

  (gnome-base/gnome-menus-3.2.0.1::gentoo, installed) pulled in by
    >=gnome-base/gnome-menus-3.1.4:3 required by (gnome-base/gnome-panel-3.2.1::gentoo, installed)
    gnome-base/gnome-menus:3 required by (gnome-base/gnome-control-center-3.2.2::gentoo, installed)
    >=gnome-base/gnome-menus-2.29.10:3[introspection] required by (gnome-base/gnome-shell-3.2.1-r1::gentoo, installed)
    >=gnome-base/gnome-menus-3.2:3 required by (gnome-base/gnome-core-apps-3.2.1::gentoo, installed)

I have put introspection USE on the latest menu and put -introspection for the older menu, but I am still hitting the block.
I have also followed the guide to the letter, but it's stuck.
As I only have one version of gnome-menus installed, could this be why I can't get gnome-shell to load?


The 3.2.x version blocks the 3.0.x version so you need to either downgrade your 0 slot or remove your 0 slot.
Back to top
View user's profile Send private message
euduca
n00b
n00b


Joined: 08 May 2009
Posts: 17

PostPosted: Mon Nov 28, 2011 4:56 pm    Post subject: Reply with quote

I upgraded the glib ( ~amd64 keyword), and it worked.

Code:
# emerge pygobject
Calculating dependencies... done!
[ebuild     U ~] dev-python/pycairo-1.10.0-r2 [1.8.10] USE="svg*"
[ebuild     U ~] dev-libs/glib-2.30.2 [2.28.8] USE="-systemtap% -utils%"
[ebuild     U ~] dev-libs/gobject-introspection-1.30.0-r1 [0.10.8]
[ebuild  NS   ~] dev-python/pygobject-3.0.2 [2.28.6] USE="cairo threads -examples -test"
[blocks B      ] <dev-python/pygobject-2.28.6-r50:2[introspection] ("<dev-python/pygobject-2.28.6-r50:2[introspection]" is blocking dev-python/pygobject-3.0.2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.30.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.29.7:2 required by (dev-libs/gobject-introspection-1.30.0-r1::gentoo, ebuild scheduled for merge)
  (dev-libs/glib-2.28.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


Code:
fenrir local # emerge dev-libs/glib
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-libs/glib-2.30.2
>>> Installing (1 of 1) dev-libs/glib-2.30.2
>>> Recording dev-libs/glib in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 3.39, 2.30, 1.13



Code:
fenrir ~ # emerge -1av pygobject:3 pygobject:2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-libs/gobject-introspection-1.30.0-r1 [0.10.8] USE="-doc -test" 1,045 kB
[ebuild     U ~] dev-python/pycairo-1.10.0-r2 [1.8.10] USE="svg* -doc -examples -test" 634 kB
[ebuild     U ~] dev-python/pygobject-2.28.6-r50 [2.28.6] USE="introspection -doc -examples -libffi -test (-cairo%*)" 0 kB
[ebuild  NS   ~] dev-python/pygobject-3.0.2 [2.28.6] USE="cairo threads -examples -test" 533 kB

Total: 4 packages (3 upgrades, 1 in new slot), Size of downloads: 2,211 kB

Would you like to merge these packages? [Yes/No]


:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum