Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Enlightenment: DR16 and DR17 installed side by side
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 142
Location: Seffner, Florida

PostPosted: Wed Nov 09, 2011 4:18 pm    Post subject: [SOLVED] Enlightenment: DR16 and DR17 installed side by side Reply with quote

I was wondering if anyone has tried to have both versions of E installed at the same time. I have always loved DR16 but I wanted to try DR17 as well and was curious if they will play alright together.

Thanks in advance.

gjy0724


Last edited by gjy0724 on Sun Nov 13, 2011 12:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Wed Nov 09, 2011 11:58 pm    Post subject: Try jumping or play around with ebuilds Reply with quote

DR17 is not slotted, so, it will replace DR16 when you will try merging it. An easy solution could be modifying the ebuild to install everything (DR17) to `--prefix=/opt' instead of `--prefix=/usr'. You still had to modify a few ebuilds for that if you have the time and energy to do it.
Either way, you could quickpkg your DR16 and merge DR17. It won't take much time to bring back your DR16 if need be if you don't want to play with ebuilds. But hey you could jump to DR17 with no worries, that version is pretty mature even with severals years of "still in development".
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Thu Nov 10, 2011 1:13 am    Post subject: Reply with quote

That's incorrect. DR16 and DR17 have no libraries in common. And DR17 is slotted into the 0.17 slot, whereas DR16 is in slot 0. There shouldn't be any problems in installing them side by side. Backup DR16 though using quickpkg once, just for surety.

EDIT: I am speaking of e17 installed from enlightenment overlay. This is the officially recommended overlay and ebuilds are committed to it by both gentoo devs and e devs.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 142
Location: Seffner, Florida

PostPosted: Sun Nov 13, 2011 3:36 am    Post subject: Reply with quote

Okay, so I have finally been able to actually trying to install E17 today (off and on, naturally) following http://en.gentoo-wiki.com/wiki/E17, but my attempts to emerge E17 are trying to upgrade E16. Through some research I found somewhere that mentioned energe using enlightenment:0.17. That gave me a different result, but still no good.
Code:

!!! All ebuilds that could satisfy "enlightenment:0.17" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-wm/enlightenment-9999::enlightenment (masked by: missing keyword)

I am want to use the snapshot version, but I am really not getting anywhere. In truth I have never had much luck installing anything from overlays, although I doubt that is my problem. Naturally, any suggestions are welcome. Thanks in advance.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sun Nov 13, 2011 4:25 am    Post subject: Reply with quote

Don't use snapshot. It is really old. Since the svn is usually very stable, you have only to gain by using the -9999 packages. As for your keyword problems, try using only the enlightenment overlay and follow the step by step instructions in gentoo wiki.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 142
Location: Seffner, Florida

PostPosted: Sun Nov 13, 2011 4:30 am    Post subject: Reply with quote

<scratchinghead>Okay, well changing to the livecvs did the trick</scratchinghead> :D...as long as all compiles well I will set to solved. DUH!!!

EDIT...on a side note, how does the updating of E17 work? Will it only update when I ask it too, because for the time being that is what I would prefer.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sun Nov 13, 2011 5:27 am    Post subject: Reply with quote

These are all -9999 packages, and are the highest versions of the ebuilds in portage/overlays. The only way to update is when you explicitly emerge these packages. Just one word of advice - when you update, update all the libraries starting right from eina all the way up to enlightenment.

EDIT: There is an "E17 is coming" thread where you may ask e17 related questions: https://forums.gentoo.org/viewtopic-t-873651-highlight-.html
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 142
Location: Seffner, Florida

PostPosted: Sun Nov 13, 2011 12:51 pm    Post subject: Reply with quote

Thanks for the assist...I remember seeing in the wiki to update all packages everytime an update is done. Changing to solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum