Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HDMI Soundausgabe, die dritte
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sat Nov 12, 2011 2:00 pm    Post subject: HDMI Soundausgabe, die dritte Reply with quote

Hallo,
ich habe jetzt meinen Rechner aufgerüstet. Jetzt mit HDMI Ausgang. Der funktioniert allerdings nur unter WindowsXP.
flammenflitzer olaf # uname -r
Code:
3.0.6-gentoo

flammenflitzer olaf # lspci | grep Audio
Code:
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
01:00.1 Audio device: nVidia Corporation Device 0e0c (rev a1)

flammenflitzer olaf # cat /proc/asound/cards
Code:
 0 [SAA7134        ]: SAA7134 - SAA7134
                      saa7134[0] at 0xefdff000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xefff0000 irq 20
 2 [NVidia_1       ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xedffc000 irq 16

Grafikkarte
Code:
 nVidia GeForce GTX560 Ti

flammenflitzer olaf # aplay -l
Code:
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 1: NVidia [HDA NVidia], Gerät 0: ALC888 Analog [ALC888 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 1: NVidia [HDA NVidia], Gerät 1: ALC888 Digital [ALC888 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 7: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 8: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: NVidia_1 [HDA NVidia], Gerät 9: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

flammenflitzer linux # cat /usr/src/linux/.config | grep SND | grep -v \#
Code:
CONFIG_SND=y
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=m
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=

flammenflitzer olaf # lsmod | grep snd
Code:
snd_seq_dummy           1566  0
snd_seq_oss            24382  0
snd_seq_midi_event      5756  1 snd_seq_oss
snd_seq                44361  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5453  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            31178  0
snd_mixer_oss          12805  1 snd_pcm_oss
snd_hda_codec_hdmi     21098  4
snd_hda_codec_realtek   300931  1
snd_hda_intel          21962  4
snd_hda_codec          73076  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               5638  1 snd_hda_codec
snd_pcm                65136  6 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,saa7134_alsa,snd_hda_codec
snd_timer              18677  2 snd_seq,snd_pcm
snd_page_alloc          7002  2 snd_hda_intel,snd_pcm

Nachladen der anderen Module bringt nichts
Code:
flammenflitzer olaf # modprobe snd-hda-codec-realtek
flammenflitzer olaf # lsmod | grep snd-hda-codec-realtek
flammenflitzer olaf # modprobe snd-hda-codec-analog
flammenflitzer olaf # modprobe snd-hda-codec-idt
flammenflitzer olaf # modprobe snd-hda-codec-via
flammenflitzer olaf # modprobe snd-hda-codec-hdmi
flammenflitzer olaf # modprobe snd-hda-codec-cirrus
flammenflitzer olaf # modprobe snd-hda-codec-conexant
flammenflitzer olaf # modprobe snd-hda-codec-ca0110
flammenflitzer olaf # modprobe snd-hda-codec-cmedia
flammenflitzer olaf # modprobe snd-hda-codec-si3054

flammenflitzer linux # lsmod | grep snd
Code:
snd_hda_codec_si3054     3432  0
snd_hda_codec_cmedia     8228  0
snd_hda_codec_ca0110     5481  0
snd_hda_codec_conexant    45002  0
snd_hda_codec_cirrus    10205  0
snd_hda_codec_via      53574  0
snd_hda_codec_idt      54732  0
snd_hda_codec_analog    80473  0
snd_seq_dummy           1566  0
snd_seq_oss            24382  0
snd_seq_midi_event      5756  1 snd_seq_oss
snd_seq                44361  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5453  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            31178  0
snd_mixer_oss          12805  1 snd_pcm_oss
snd_hda_codec_hdmi     21098  4
snd_hda_codec_realtek   300931  1
snd_hda_intel          21962  4
snd_hda_codec          73076  11 snd_hda_codec_si3054,snd_hda_codec_cmedia,snd_hda_codec_ca0110,snd_hda_codec_conexant,
snd_hda_codec_cirrus,snd_hda_codec_via,snd_hda_codec_idt,snd_hda_codec_analog,snd_hda_codec_hdmi,snd_hda_codec_realtek,
snd_hda_intel
snd_hwdep               5638  1 snd_hda_codec
snd_pcm                65136  7 snd_hda_codec_si3054,snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,saa7134_alsa,snd_hda_codec
snd_timer              18677  2 snd_seq,snd_pcm
snd_page_alloc          7002  2 snd_hda_intel,snd_pcm

alsa lässt sich nicht konfigurieren
flammenflitzer olaf #alsaconf
Code:
No supported PnP or PCI card found
...
No legacy drivers are avaiable

Code:
flammenflitzer olaf # cat /etc/modprobe.d/alsa.conf
cat: /etc/modprobe.d/alsa.conf: Datei oder Verzeichnis nicht gefunden

In /etc/make.conf ist USE=" ...pulseaudio ..." gesetzt. kde 4.7.3. Weitere Software
Code:
[ebuild   R   ~] media-sound/pulseaudio-1.1  USE="X alsa asyncns avahi caps dbus equalizer glib ipv6 libsamplerate lirc orc tcpd udev -bluetooth -doc -gnome -jack (-oss) -realtime (-system-wide) -test" 0 kB               
[ebuild   R    ] media-plugins/gst-plugins-pulse-0.10.30  0 kB
[ebuild   R   ~] media-libs/phonon-4.5.1-r1  USE="gstreamer pulseaudio (-aqua) -debug -vlc -xine" 0 kB
[ebuild   R   ~] media-libs/phonon-gstreamer-4.5.1  USE="alsa -debug" 0 kB
[ebuild   R   ~] kde-base/phonon-kde-4.7.3  USE="alsa pulseaudio (-aqua) -debug (-kdeenablefinal) -xine" 0 kB

Wird die Ausgabe von cat /etc/asound.state benötigt?
Ich weiß nicht, ob das eine Rolle spielt? Die Bildschirme sind konfiguriert als separate Monitore. xorg.conf kann ich bei Bedarf posten.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sun Nov 20, 2011 8:01 pm    Post subject: Reply with quote

Ich denke, das es sich um ein Treiberproblem handelt. Ich habe hier etwas gefunden, kann aber damit nichts anfangen.
http://comments.gmane.org/gmane.linux.alsa.devel/82509
http://acm.jhu.edu/git/linux-2.6/commit/…7ba5dec6653ac74
Sollte ich einen 2.6 kernel nehmen?
In der Dokumentation von Kernel 3
Code:
The hd-audio driver reads the file via request_firmware().  Thus,
a patch file has to be located on the appropriate firmware path,
typically, /lib/firmware.  For example, when you pass the option
`patch=hda-init.fw`, the file /lib/firmware/hda-init-fw must be
present.

The patch module option is specific to each card instance, and you
need to give one file name for each instance, separated by commas.
For example, if you have two cards, one for an on-board analog and one
for an HDMI video board, you may pass patch option like below:
------------------------------------------------------------------------
    options snd-hda-intel patch=on-board-patch,hdmi-patch
Und ich habe gelesen, das spezielle Kerneloptionen (unklar welche und wo einzugeben) erforderlich sind
Code:
..
als Kernelparamter angeben werden muss wenn der Linux Kernel 3.X verwendet wird da ab dieser Version die Soundausgabe über HDMI standardmässig abgeschaltet ist.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Wed Nov 30, 2011 5:36 pm    Post subject: Reply with quote

Möglicherweise liegt es daran:
http://http.download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html#gf520_codec_arch_support
Da soll dieser Patch helfen. Gibt es den für Gentoo-sources?
http://kernel.opensuse.org/cgit/kernel/commit/?id=a810364a0424c297242c6c66071a42f7675a5568
Hier
http://dev.gentoo.org/~mpagano/genpatches/releases.htm
habe ich nichts gefunden zu kernelversionen 3.x.x
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Tue Dec 20, 2011 6:26 pm    Post subject: Reply with quote

Ichhabe das hier durchgelesen und abgearbeitet (Versuch). ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html
Dann hatte ich gerade ein Erfolgserlebnis. Testsound auf dem TV. Aber wie kann ich das nutzen?
Ich habe einige hw:x,x durchprobiert.
Code:
flammenflitzer linux # speaker-test -c 2 -r 48000 -D hw:2,7

speaker-test 1.0.24.2

Wiedergabe-Gerät ist hw:2,7
Stream-Parameter sind 48000 Hz, S16_LE, 2 Kanäle
Verwende 16 Oktaven rosa Rauschen
Rate ist 48000 Hz (angefordert: 48000 Hz)
Puffergröße von 64 bis 16384
Periodengröße von 32 bis 8192
Verwende maximale Puffergröße 16384
Perioden = 4
gesetzt: period_size = 4096
gesetzt: buffer_size = 16384
 0 - Vorne links
 1 - Vorne rechts
Zeit pro Periode = 5,633944
 0 - Vorne links
 1 - Vorne rechts
Zeit pro Periode = 5,972947
 0 - Vorne links

!!! jetzt habe ich ein Rauschen auf dem TV !!!
Code:
flammenflitzer olaf # nano /etc/asound.conf
pcm.!default hdmi:CARD=NVidia,DEV=7

Code:
flammenflitzer olaf # /etc/init.d/alsasound restart
alsasound                 | * WARNING: you are stopping a boot service
alsasound                 | * Storing ALSA Mixer Levels ...
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: get_controls:570: snd_ctl_open error: Invalid argument
alsasound                 | * Error saving levels.                                                                                                                                    [ !! ]
alsasound                 | * Loading ALSA modules ...                                                                                                                                [ ok ]
alsasound                 | * Restoring Mixer Levels ...
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: set_controls:1424: snd_ctl_open error: Invalid argument
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: set_controls:1424: snd_ctl_open error: Invalid argument
alsasound                 | * Errors while restoring defaults, ignoring
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: set_controls:1424: snd_ctl_open error: Invalid argument
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: set_controls:1424: snd_ctl_open error: Invalid argument
alsasound                 | * Errors while restoring defaults, ignoring
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: set_controls:1424: snd_ctl_open error: Invalid argument
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |ALSA lib conf.c:1685:(snd_config_load1) _toplevel_:1:23:Unexpected char
alsasound                 |ALSA lib conf.c:3467:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
alsasound                 |ALSA lib conf.c:3326:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
alsasound                 |ALSA lib conf.c:3713:(snd_config_update_r) hooks failed, removing configuration
alsasound                 |alsactl: set_controls:1424: snd_ctl_open error: Invalid argument
alsasound                 | * Errors while restoring defaults, ignoring

Also den Eintrag wieder entfernt. (/etc/asound.conf ist jetzt leer.)
Code:
flammenflitzer olaf # cat /etc/pulse/default.pa | grep module-alsa-sink
#load-module module-alsa-sink

geändert
Code:
flammenflitzer olaf # cat /etc/pulse/default.pa | grep module-alsa-sink
#load-module module-alsa-sink
load-module module-alsa-sink device=hw:2,7


Code:
olaf@flammenflitzer ~ $ pulseaudio --load="module-alsa-sink device=hw:2,7"
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() fehlgeschlagen.


???????????????
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 190
Location: Essen

PostPosted: Tue Dec 20, 2011 7:02 pm    Post subject: Reply with quote

Z.B. mit mplayer so:

mplayer -display :0.1 -ao alsa:device=hw=1.7


Mein Display (TV) ist ein seperates Screen. Konfiguriert mit nvidia-settings.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Dec 21, 2011 8:30 am    Post subject: Reply with quote

Ton ist bei mir ebenfalls auf hw=1,7. Klappt aber irgendwie nur bei mir, wenn ich die Parameter explizit in der Kommandozeile bei Mplayer oder bei sxfe (xineliboutput für VDR) angeb. In der mplayer.conf hab ich's noch nicht hinbekommen - genauso wenig wie in der asound.conf.

Mein Ziel ist irgendwann mal, den Ton systemweit gleichzeitig über Toslink (hw=0,1) und über HDMI (hw=1,7) auszugeben. Hab dazu auch schon die eigentlich passende asound.conf gefunden. Nur dummerweise weigern sich irgendwie sämtliche Applikationen, diese Defaultkonfiguration (HDMI+Toslink).

Ach ja, am Anfang wollte ich auch 2 Screens definieren. Ich hatte damit gerechnet, dass man für HDMI extra die Nvidia-Treiber für X benötigt und der TV im Framebuffer-Modus überhaupt nicht geht. Irgendwann hab ich dann gemerkt, dass die Bildübertragung vom HTPC zum TV via HDMI out of the box funktioniert. Damit wurde der normale Monitor überflüssig. Etwas tricky war der 24p-Modus, wo ich erstmal rausfinden musste, dass damit nicht 24 Hz sondern 23,976 Hz gemeint sind. :)
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Wed Dec 21, 2011 11:29 am    Post subject: Reply with quote

Vielleicht könnte das hier weiterhelfen. Ich hatte auch Probleme mit hdmi an meiner Zotac box und es hat mir geholfen:

https://bbs.archlinux.org/viewtopic.php?id=102354

Grüße
Erdie
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Fri Dec 23, 2011 8:48 am    Post subject: Reply with quote

alsa habe ich nicht konfiguriert. (Fehlermeldungen nach Konfiguration) Vielleicht kann mir jemand mit ähnlicher Konfiguration seine alsa.conf posten
Pulseaudio funktioniert nicht mit geänderter /etc/pulse/default.pa
Code:
olaf@flammenflitzer ~ $ pulseaudio
E: [pulseaudio] main.c: Unknown command: autospawn = no
E: [pulseaudio] main.c: Konnte Daemon nicht initialisieren.

Pulseaudio kommt mit keinem der Einträge in der /etc/pulse/default.pa klar
Code:
autospawn = no

Code:
load-module module-alsa-sink device=hw:2,7

Code:
load-module module-alsa-sink device=hw:2,7 sink_name=hdmi_output

Code:
load-module module-alsa-source device=hw:2,7

Mit keinem der Einträge kommt pulseaudio klar. (pulseaudio 1.1)
Muss ich erst die /etc/conf.d/alsasound oder die /etc/modprobe.d/alsa.conf anpassen?
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Fri Dec 23, 2011 12:35 pm    Post subject: Reply with quote

Erdie wrote:
Vielleicht könnte das hier weiterhelfen. Ich hatte auch Probleme mit hdmi an meiner Zotac box und es hat mir geholfen:

https://bbs.archlinux.org/viewtopic.php?id=102354

Grüße
Erdie


Code:
/usr/share/alsa/alsa.conf. In the  "# defaults" section I replaced the following:

defaults.ctl.card NVidia
defaults.pcm.card NVidia
defaults.pcm.device 7
Hast du jetzt nur noch Sound über HDMI?
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Fri Dec 23, 2011 12:50 pm    Post subject: Reply with quote

Der Zotac hängt am Fernseher und ich nutze den Sound aussschließlich über HDMI, von daher vermuet ich "ja". Alles andere habe ich noch nicht getestet.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Fri Dec 23, 2011 12:56 pm    Post subject: Reply with quote

Ich habe jetzt
Code:
nano /etc/modprobe.d/alsa.conf
# ALSA portion
options snd cards_limit=2
alias snd-card-0 snd_hda_intel
alias snd-card-1 snd_hda_codec_nvhdmi
options snd_hda_codec_realtek index=0
options snd_hda_codec_nvhdmi index=1
Code:
flammenflitzer olaf # update-modules

Code:

lammenflitzer olaf # /etc/init.d/alsasound restart
alsasound                 | * WARNING: you are stopping a boot service
alsasound                 | * Storing ALSA Mixer Levels ...                                          [ ok ]
alsasound                 | * Loading ALSA modules ...
alsasound                 | *   Loading: snd-card-0 ...                                              [ ok ]
alsasound                 | *   Loading: snd-card-1 ...
alsasound                 |FATAL: Module snd_hda_codec_nvhdmi not found.                             [ ok ]
alsasound                 | * Restoring Mixer Levels ...                                             [ ok ]

Code:
flammenflitzer olaf # modprobe snd_hda_codec_nvhdmi
flammenflitzer olaf #
Code:
flammenflitzer olaf # lsmod | grep hdmi
snd_hda_codec_hdmi     21731  4
snd_hda_codec          58271  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_pcm                65104  4 snd_hda_codec_hdmi,saa7134_alsa,snd_hda_intel,snd_hda_codec
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Dec 23, 2011 2:28 pm    Post subject: Reply with quote

Pulseaudio fällt zumindest bei mir aus, da mein Bestreben ganz klar in Richtung bit perfect sound geht.

Bin auch schon an dem Punkt, dass ich mit der Alsa-Only-Lösung soweit leben kann, dass sich XBMC und MPD nicht gegenseitig blockieren, indem ich halt bei XBMC einfach die Klicksounds im Menü deaktiviert hab.

Pulseaudio hat mich insofern zur Weißglut getrieben, dass es sich auf meinen beiden Rechnern (HTPC mit Alsa wegen HDMI, Desktoprechner mit OSS wegen besserer Analog-Qualität) immer irgendwie selbst startet. Eigentlich wollte ich Pulseaudio ausschließlich dafür nutzen, den Sound von einem Rechner nach belieben auf einen anderen zu übertragen. Besonders nervig ist, dass KDE sofort auf Pulseaudio zurückgreifen will, wenn das installiert ist.

Nun gut, diese Netzfunktionalität bleibt jetzt außen vor. Die MP3 krieg ich vom HTPC auf meinen Desktoprechner per NFS, die Steuerung der HTPC mit dortiger Soundausgabe wird per MPD erledigt.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sat Dec 24, 2011 10:02 am    Post subject: Reply with quote

Danke.
ich habe einiges mit alsa ausprobiert. Hat nichts gebracht. Jetzt verlasse ich mich bei alsa auf udev und passe nur noch die pulseaudio Konfiguration an.
Bin da schon ein Stück weiter.
Ich habe in der /etc/pulse/client.conf autospawn = no
und danach in der
/etc/pulse/default.pa load-module module-alsa-sink device=hw:2,7

olaf@flammenflitzer ~ $ pulseaudio -k
olaf@flammenflitzer ~ $ pulseaudio -D

In pavucontrol habe ich zur Auswahl
Wiedergabe -> HDA Nvidia
-> HDA Nvidia Digital Stereo (HDMI)
-> Internes Audio Analog Stereo

Seltsamerweise funktioniert jetzt der Sound auf dem TV wenn ich HDA Nvidia auswähle.
Bei HDA Nvidia Digital Stereo (HDMI) höre ich nichts.
Bei Internes Audio Analog Stereo kommt der Sound, wie es sein soll, aus den PC Lautsprechern.

Frohe Weihnachten.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sun Dec 25, 2011 8:29 am    Post subject: Reply with quote

Nachdem es jetzt 2 Tage funktioniert hat, geht es jetzt nicht mehr, ohne das ich etwas am System geändert habe.
Code:
laf@flammenflitzer ~ $ pulseaudio
E: [pulseaudio] module.c: Failed to load module "module-alsa-sink" (argument: "device=hw:2,7"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Konnte Daemon nicht initialisieren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum