Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -av --depclean
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Tue Nov 22, 2011 12:20 pm    Post subject: emerge -av --depclean Reply with quote

Code:
>> Calculating removal order...

>>> These are the packages that would be unmerged:                                                                                                                                                                             
                                                                                                                                                                                                                               
 sys-devel/automake
    selected: 1.9.6-r3
   protected: none
     omitted: 1.11.1

 dev-lang/swig
    selected: 2.0.2
   protected: none
     omitted: none

 x11-libs/gtkglext
    selected: 1.2.0
   protected: none
     omitted: none

 net-libs/gtk-vnc
    selected: 0.4.3-r1
   protected: none
     omitted: none

 sys-devel/gcc
    selected: 4.4.5
   protected: none
     omitted: 4.5.3-r1

 sys-kernel/gentoo-sources
    selected: 2.6.38-r6
   protected: none
     omitted: 3.0.6

 dev-libs/boost
    selected: 1.42.0-r2
   protected: none
     omitted: 1.46.1-r1

 dev-perl/Text-CSV
    selected: 1.210
   protected: none
     omitted: none

 dev-python/cython
    selected: 0.14.1
   protected: none
     omitted: none

 x11-libs/vte
    selected: 0.28.1-r200
   protected: none
     omitted: none

 net-libs/xulrunner
    selected: 1.9.2.17
   protected: none
     omitted: none

 kde-base/krosspython
    selected: 4.6.3
   protected: none
     omitted: none

                                                                                                                                                                                                                               
!!! 'app-editors/nano' (virtual/editor) is part of your system profile.                                                                                                                                                         
!!! Unmerging it may be damaging to your system.                                                                                                                                                                               
                                                                                                                                                                                                                               
                                                                                                                                                                                                                               
 app-editors/nano
    selected: 2.2.5
   protected: none
     omitted: none

 net-proxy/tsocks
    selected: 1.8_beta5-r5
   protected: none
     omitted: none

 dev-lang/lua
    selected: 5.1.4-r4
   protected: none
     omitted: none

 app-emulation/virtinst
    selected: 0.600.0
   protected: none
     omitted: none

 sys-libs/talloc
    selected: 2.0.1-r1
   protected: none
     omitted: none

 dev-python/gconf-python
    selected: 2.28.1
   protected: none
     omitted: none

 kde-base/kajongg
    selected: 4.6.3
   protected: none
     omitted: none

 app-text/rarian
    selected: 0.8.1-r1
   protected: none
     omitted: none

 dev-util/boost-build
    selected: 1.42.0
   protected: none
     omitted: 1.46.1

 dev-python/urlgrabber
    selected: 3.9.1-r1
   protected: none
     omitted: none

 dev-python/gnome-python-base
    selected: 2.28.1
   protected: none
     omitted: none

 dev-python/twisted
    selected: 11.0.0
   protected: none
     omitted: none

 gnome-base/gconf
    selected: 2.32.3
   protected: none
     omitted: none

 x11-libs/gnome-pty-helper
    selected: 0.28.1
   protected: none
     omitted: none

 app-emulation/libvirt
    selected: 0.9.3-r1
   protected: none
     omitted: none

 dev-python/pycurl
    selected: 7.19.0
   protected: none
     omitted: none

 dev-libs/libnl
    selected: 1.1-r2
   protected: none
     omitted: none

 dev-python/pyopenssl
    selected: 0.12
   protected: none
     omitted: none

 net-zope/zope-interface
    selected: 3.6.2
   protected: none
     omitted: none

 gnome-base/orbit
    selected: 2.14.19-r1
   protected: none
     omitted: none

 dev-libs/yajl
    selected: 1.0.11
   protected: none
     omitted: none

 net-analyzer/netcat6
    selected: 1.0-r2
   protected: none
     omitted: none

 net-misc/bridge-utils
    selected: 1.4
   protected: none
     omitted: none

 net-zope/zope-fixers
    selected: 1.0
   protected: none
     omitted: none

All selected packages: net-libs/xulrunner-1.9.2.17 dev-python/pyopenssl-0.12 x11-libs/vte-0.28.1-r200 dev-python/urlgrabber-3.9.1-r1 gnome-base/gconf-2.32.3 net-analyzer/netcat6-1.0-r2 dev-libs/boost-1.42.0-r2 dev-python/pycurl-7.19.0 dev-python/cython-0.14.1 kde-base/kajongg-4.6.3 sys-devel/gcc-4.4.5 net-libs/gtk-vnc-0.4.3-r1 gnome-base/orbit-2.14.19-r1 dev-lang/lua-5.1.4-r4 sys-libs/talloc-2.0.1-r1 sys-kernel/gentoo-sources-2.6.38-r6 dev-python/gconf-python-2.28.1 x11-libs/gtkglext-1.2.0 net-misc/bridge-utils-1.4 net-zope/zope-interface-3.6.2 x11-libs/gnome-pty-helper-0.28.1 dev-libs/yajl-1.0.11 dev-util/boost-build-1.42.0 dev-perl/Text-CSV-1.210 app-emulation/libvirt-0.9.3-r1 dev-lang/swig-2.0.2 net-zope/zope-fixers-1.0 sys-devel/automake-1.9.6-r3 dev-python/twisted-11.0.0 dev-python/gnome-python-base-2.28.1 net-proxy/tsocks-1.8_beta5-r5 app-text/rarian-0.8.1-r1 dev-libs/libnl-1.1-r2 kde-base/krosspython-4.6.3 app-editors/nano-2.2.5 app-emulation/virtinst-0.600.0

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No]


wenn ich Yes sage, deinstalliert er all die pakete?
ist das wichtig die alle zu deinstallieren?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Tue Nov 22, 2011 1:15 pm    Post subject: Reply with quote

nun, wichtig nicht. aber keines dieser Pakete wird noch von einem anderen gebraucht, und du hast auch keines explizit installiert (in der world file)
Aber Achtung: da ist nano dabei, welches im system-set ist. Das find ich doof, das portage seit ner Weile pakete im system-set deinstallieren will, wenn sie keine abhängigkeit mehr sind. Wenn du nano benutzt, dann setze es in die world file
Ansonsten kannst du es beruhigt löschen.
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Tue Nov 22, 2011 4:02 pm    Post subject: Reply with quote

ich kanns doch durchlaufen lassen, alles inklusive nano deinstallieren lassen, und nano dann erneut installieren?
wie setze ich es in das word file?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Tue Nov 22, 2011 5:42 pm    Post subject: Reply with quote

indem du es danach einfach installierst :)
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Tue Nov 22, 2011 5:46 pm    Post subject: Reply with quote

Hi

Wenn du nano nicht deinstallieren willst, dann mach vor dem depclean erst ein

# emerge -a --noreplace nano

Das fügt dir nano automatisch zum Worldfile hinzu ohne es nochmals zu kompilieren.

Sebastian
Back to top
View user's profile Send private message
SkaaliaN
Veteran
Veteran


Joined: 21 Apr 2005
Posts: 1345
Location: Tranquility

PostPosted: Tue Nov 22, 2011 9:17 pm    Post subject: Reply with quote

http://forums-web1.gentoo.org/viewtopic-t-883521-start-0.html
_________________
-RHP- Respect Honor Passion
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum