Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-4.7.80 blocks [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Mon Nov 21, 2011 10:04 pm    Post subject: kde-4.7.80 blocks [solved] Reply with quote

Layman provides kde-4.7.80, so i tried.

Code:
#emerge -up world
[...]

[ebuild     U #] kde-base/kdepim-meta-4.7.80 [4.7.49.9999]
[ebuild     U #] kde-base/kde-meta-4.7.80 [4.7.49.9999]
[blocks B      ] kde-base/activitymanager:4 ("kde-base/activitymanager:4" is blocking kde-base/kactivities-4.7.80)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-base/kactivities-4.7.80::kde, ebuild scheduled for merge) pulled in by
    kde-base/kactivities required by @selected
    >=kde-base/kactivities-4.7.80:4[-aqua] required by (kde-base/plasma-workspace-4.7.80::kde, ebuild scheduled for merge)
    kde-base/kactivities:4 required by @kdelibs

  (kde-base/activitymanager-4.7.3::gentoo, ebuild scheduled for merge) pulled in by
    kde-base/activitymanager required by @selected
    kde-base/activitymanager:4 required by @kdebase-runtime


That is strange, because there is no activitymanager-4.7.80.ebuild and the kactivities-4.7.80.ebuild says
Code:
add_blocker activitymanager


Ok, next try...
Code:
#emerge @kde-4.8
.. same results as above


That is strange.. there is no activitymanager in @kdebase-runtime-4.8
It is in @kdebase-runtime however.

Ok, moved all sets except *-4.8 to another place
Code:
#emerge @kde-4.8
[...]
[ebuild     U #] kde-base/kdepim-meta-4.7.80 [4.7.49.9999]
[ebuild     U #] kde-base/kde-meta-4.7.80 [4.7.49.9999]
[blocks B      ] kde-base/activitymanager:4 ("kde-base/activitymanager:4" is blocking kde-base/kactivities-4.7.80)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-base/kactivities-4.7.80::kde, ebuild scheduled for merge) pulled in by
    >=kde-base/kactivities-4.7.50 required by @kdelibs-4.8
    >=kde-base/kactivities-4.7.80:4[-aqua] required by (kde-base/plasma-workspace-4.7.80::kde, ebuild scheduled for merge)
    kde-base/kactivities required by @selected

  (kde-base/activitymanager-4.7.49.9999::kde, installed) pulled in by
    kde-base/activitymanager required by @selected


Look at that! No more 'required bij @kdebase-runtime'

So I have 2 questions:

1) is this a bug in portage, that it does not use the proper set?

2) has anybody installed kde-4.7.80 ?

3) Who knows how to solve my problem?


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees


Last edited by houtworm on Fri Nov 25, 2011 5:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
one_and_only
Apprentice
Apprentice


Joined: 13 May 2007
Posts: 250
Location: PL/Krakow

PostPosted: Tue Nov 22, 2011 12:58 am    Post subject: Reply with quote

Quote:
2) has anybody installed kde-4.7.80 ?

Probably nobody, because it's just tagged in the repo: http://websvn.kde.org/tags/KDE/4.7.80/, you'll need to wait probably until 11/23 to be able to fetch the tarballs:
http://techbase.kde.org/Schedules/KDE4/4.8_Release_Schedule

edit:
And I have no blocks while -pvDN @world
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Tue Nov 22, 2011 1:38 am    Post subject: Reply with quote

Thanks for your reply one_and_only !
Of course, I looked at the wrong places :-/
Why didn't I think about that..


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Wed Nov 23, 2011 1:10 am    Post subject: Reply with quote

Tarballs or not, emerge will never do it right. Tarballs will never be downloaded while that error is not solved.
So the only thing I can try is sync the kde overlay and try if the error is gone.
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Fri Nov 25, 2011 1:36 am    Post subject: Reply with quote

Somehow I need to get rid of this activitymanager.
At this moment, with kde-4.7.49.999:
Code:
# equery d activitymanager
 * These packages depend on activitymanager:
kde-base/kdebase-runtime-meta-4.7.49.9999 (>=kde-base/activitymanager-4.7:4[aqua=])
kde-base/plasma-workspace-4.7.49.9999 (>=kde-base/activitymanager-4.7:4[aqua=])


unmerging runtime-meta and plasma-workspace did not help, however equery didn't show anything that depends on activitymanager. But the conflict stays
Code:
(kde-base/activitymanager-4.7.49.9999::gentoo, ebuild scheduled for merge) pulled in by
    kde-base/activitymanager required by @selected


Any hints how to solve this?

portage version is 2.2.0_alpha77
but going back to portage-2.1.10.37 did not make any difference.



--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Fri Nov 25, 2011 6:51 am    Post subject: Reply with quote

how about removing activitymanager directly, and let the upgrade install its replacement (IIRC kactivitymanager)?

It would also help, if you post the error message in context. otherwise we could to the guessing game.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Fri Nov 25, 2011 5:24 pm    Post subject: Reply with quote

yeah!

I have tried that before, unmerging activitymanager and then it didn' t work, but now it works!
Thanks.
now kde-4.8 is emerging..
will take a few hours :-) 2 or 3 I think.


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Fri Nov 25, 2011 8:12 pm    Post subject: Reply with quote

Ok kde-4.80 is installed. Only 3 packages would not compile, but I will look after that later on.
I think it is kwrite, kmail and kdeplasma-addons.

--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
energyman76b
Advocate
Advocate


Joined: 26 Mar 2003
Posts: 2045
Location: Germany

PostPosted: Fri Nov 25, 2011 10:13 pm    Post subject: Reply with quote

houtworm wrote:
Ok kde-4.80 is installed. Only 3 packages would not compile, but I will look after that later on.
I think it is kwrite, kmail and kdeplasma-addons.

--Kees


here too:

* (kde-base/kmail-4.7.80::kde, ebuild scheduled for merge), Log file:
* '/var/tmp/portage/kde-base/kmail-4.7.80/temp/build.log'
* (kde-base/kde-meta-4.7.80::kde, ebuild scheduled for merge)
* (kde-base/kdepim-meta-4.7.80::kde, ebuild scheduled for merge)
* (kde-base/kwrite-4.7.80::kde, ebuild scheduled for merge), Log file:
* '/var/tmp/portage/kde-base/kwrite-4.7.80/temp/build.log'
* (kde-base/kdebase-meta-4.7.80::kde, ebuild scheduled for merge)
* (kde-base/kdeplasma-addons-4.7.80::kde, ebuild scheduled for merge), Log file:
* '/var/tmp/portage/kde-base/kdeplasma-addons-4.7.80/temp/build.log'
_________________
Study finds stunning lack of racial, gender, and economic diversity among middle-class white males

I identify as a dirty penismensch.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Fri Nov 25, 2011 10:17 pm    Post subject: Reply with quote

I confirm that too...

kwrite can be 'fixed' by removing the handbook useflag.
I am still working on the other 2...

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Fri Nov 25, 2011 10:30 pm    Post subject: Reply with quote

ok kwrite build without the handbook useflag :-)

What I noticed in the kdeplasma-addons build log:
Code:
-----------------------------------------------------------------------------                                                         
-- The following OPTIONAL packages could NOT be located on your system.                                                               
-- Consider installing them to enable more features from this software.                                                               
-----------------------------------------------------------------------------                                                         
   * libattica  <http://websvn.kde.org/trunk/kdesupport/attica/>                                                                     
     Attica Library                                                                                                                   
     Needed for building the Open Collaboration Services plasma dataengine and applets                                               
   * Marble  <http://marble.kde.org>                                                                                                 
     Desktop Globe                                                                                                                   
     RECOMMENDED: Marble is used to provide a desktop globe wallpaper for Plasma.                                                     
   * libkexiv2 (0.2.0 or higher)  <http://www.kde.org>                                                                               
     Library to access EXIF information                                                                                               
     RECOMMENDED: Enables automatic rotation for frame applet                                                                         
                                                                                                                                     
----------------------------------------------------------------------------- 


They are all installed!
But as optional packages, they should not break kdeplasma-addons.

But this is the error:
Code:
     from /mnt/data/tmp/portage/kde-base/kdeplasma-addons-4.7.80/work/kdeplasma-addons-4.7.80/applets/icontasks/windowtask
item.cpp:23:                                                                                                                         
/mnt/data/tmp/portage/kde-base/kdeplasma-addons-4.7.80/work/kdeplasma-addons-4.7.80/applets/icontasks/tasks.h:57:20: fout: 'TaskManage
r::StartupPtr' has not been declared                                                                                                 
/mnt/data/tmp/portage/kde-base/kdeplasma-addons-4.7.80/work/kdeplasma-addons-4.7.80/applets/icontasks/tasks.h:58:20: fout: 'TaskManage
r::TaskPtr' has not been declared
[..and some more...]




--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Sat Nov 26, 2011 8:55 am    Post subject: Reply with quote

fixed kmail - they were not extracting all required directories b.g.o.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Sat Nov 26, 2011 2:26 pm    Post subject: Reply with quote

Thanks!
Kmail builds ok now :-)


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Sat Nov 26, 2011 10:50 pm    Post subject: Reply with quote

glad to be of help.
kmail got fixed in the git repo.

I filed another bug for kdeplasma-addons, but I am not sure what the problem is. therefore it might take longer.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Sun Nov 27, 2011 5:23 pm    Post subject: Reply with quote

The patches mentioned by Marian Kyral work!
kdeplasma-addons-4.7.80 is now installed.


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum