Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Neuling Problem - keine Tastatur in KDE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Tue Dec 06, 2011 10:58 am    Post subject: Neuling Problem - keine Tastatur in KDE Reply with quote

Hallo,

als jemand, der bisher nur die schönen bunten Linux Welten a la Opensuse, Fedora etc. kannte, hatte mich der Ehrgeiz gepackt, es auch mal mit Gentoo zu probieren. Ich bin genau nach Handbuch vorgegangen. Neueste Stage3 Version AMD64 installiert, danach X11 und zum Schluß kde-meta. Einen Fehler hatte ich wohl vor der Installation von KDE und X11 gemacht. Ich hatte keinen Eintrag für die Tastatur also weder "evdev" noch "keyboard" in der "make.conf" eingetragen. Nun holte ich dies nach und ließ nach einigen Webrecherchen folgenden Befehl ausführen "emerge -a1 $(qlist -I -C x11-driver)".

Aber es hilft nichts. Vor dem Start der graphischen Oberfläche funktioniert die Tastatur einwandfrei. Sobald das KDE Anmeldefenster erscheint, funktioniert nur noch die Maus. Weitere Webrecherchen führten zu nichts. Es wird häufiger auf "xorg" Konf Dateien verwiesen, die in meinem System nicht existieren, oder das Löschen einer "kaccessrc" Datei empfohlen, die ich aber auch nicht finden kann.
Als Kernel habe ich den automatisch generierten Genkernel im Einsatz (3.0.6).

Hat jemand hier eine Idee, wie ich die Arbeit von mehreren Tagen noch "retten" kann?

vielen Dank
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Tue Dec 06, 2011 11:28 am    Post subject: Reply with quote

Hi Dr. Ames,

davon ausgehend, daß die Einträge in Deiner make.config richtig sind, schon mal den Befehl
Code:
emerge -auDNtv world
ausprobiert?

Grüße
Aleph
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Tue Dec 06, 2011 11:42 am    Post subject: Reply with quote

Das Update sollte wurscht sein - vorauasgesetzt er hat brav ein profile vor dem Installieren ausgewählt.
Code:
eselect profile list

Alles ab default/linux hat
Code:
INPUT_DEVICES="keyboard mouse evdev"

Der evdev-Treiber existiert also schon.
Kopier mal /usr/share/X11/xorg.conf.d/10-evdev.conf nach /etc/X11/xorg.conf.d (Letzteres ist einh Verzeichnis; Wenn es nicht existiert einfach anlegen).
Back to top
View user's profile Send private message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Tue Dec 06, 2011 12:28 pm    Post subject: Reply with quote

Danke an Euch beide. Ich probierte die erste Antwort auch zuerst aus . und siehe da, es funktionierte. Allerdings habe ich keine Ahnung, was der Befehl "emerge -auDNtv world" wirklich bewirkt hat. Er hat wohl einige input-Treiber neu installiert und für die bereits installierten nach Updates gesucht - richtig?

Aber ich möchte noch eine Frage anschließen. Jetzt startet mein frisch installiertes KDE 4.6.5 und ich erhalte direkt folgende Fehlermeldung:
"Warning: Cannot open ConsoleKit session: Failed to connect to socket /var/run/dbus/system_bus_socket: No such File or directory"
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Tue Dec 06, 2011 12:47 pm    Post subject: Reply with quote

Dr. Ames wrote:
Allerdings habe ich keine Ahnung, was der Befehl "emerge -auDNtv world" wirklich bewirkt hat.

-> man emerge
Ausgeschrieben schaut das so aus:
Code:
emerge --ask --update --deep --newuse --tree --verbose world


Quote:
Aber ich möchte noch eine Frage anschließen. Jetzt startet mein frisch installiertes KDE 4.6.5 und ich erhalte direkt folgende Fehlermeldung:
"Warning: Cannot open ConsoleKit session: Failed to connect to socket /var/run/dbus/system_bus_socket: No such File or directory"

Code:
/etc/init.d/consolekit start

Und wenn es jetzt geht, machst du
Code:
rc-update add consolekit default


Kannst du auch nochmal nach deinem profile schauen?
Code:
eselect profile list

oder
Code:
eselect profile show

Wenn es das Update gebracht hat, ist da wohl noch nichts gesetzt worden...
Back to top
View user's profile Send private message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Tue Dec 06, 2011 12:59 pm    Post subject: Reply with quote

Vielen Dank - hat direkt funktioniert. Die Fehlermeldung ist nach dem "rc-update add consolekit default" verschwunden.

Die Abfrage des Profiles gibt aus: "default/linux/amd64/10.0/desktop/kde".

Ist doch so richtig?
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Wed Dec 07, 2011 2:48 pm    Post subject: Reply with quote

Hallo Dr. Ames

und noch ein nachgeschobenes willkommen bei Gentoo.

Zu deiner letzten Frage an Franz, bzgl. des Profiles. Ja, das ist korrekt so.

@Franz
franzf wrote:
Alles ab default/linux hat
Code:
INPUT_DEVICES="keyboard mouse evdev"

Der evdev-Treiber existiert also schon.


Kleine Randnotitz zur Info: keyboard und mouse braucht man hier nicht mehr, wenn man evdev verwendet.
Event-dev kümmert sich dann auch um mouse und keyboard. :wink:

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Dec 07, 2011 3:01 pm    Post subject: Reply with quote

Randy Andy wrote:
Kleine Randnotitz zur Info: keyboard und mouse braucht man hier nicht mehr, wenn man evdev verwendet.
Event-dev kümmert sich dann auch um mouse und keyboard. :wink:

Oh Mann, bin ich fertig :/ (scheiß Winteranfang, scheiß schwerer Schnee...) hab das jetzt 3x lesen müssen um es zu verstehen ^^
Ja, ich weiß, dass sich evdev um Tastatur und Maus kümmert, deshalb steht bei mir auch
Code:
*/* INPUT_DEVICES: -* evdev wacom
in der use.conf
Der Quote in dem anderen Post stammt direkt aus dem profile!
Code:
$ grep INPUT_DEVICES /var/paludis/repositories/gentoo/profiles/default/linux/make.defaults
INPUT_DEVICES="keyboard mouse evdev"

Deshalb auch meine Aussage "bei korrekt gesetztem profile sollte eigentlich der evdev-Treiber schon vorhanden sein, unabhängig von selber gesetztem INTPUT_DEVICES in der make.conf.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Wed Dec 07, 2011 9:05 pm    Post subject: Reply with quote

Hi Franz,

dachte mir schon das du das weißt, hast das aber so komisch formuliert das ich zuvor schon Drei mal lesen musste, und hab doch nicht verstanden wie du das meintest.

OT.
Winteranfang! Verdammt, jetzt geht das schon wieder los. Weiß ja nicht wie weit dein Nirgendwo von Cologne weg ist, hier ist bisher noch nichts angekommen das liegen bleiben könnte.
Diese Schnee schipperei geht einem ja stets von der Consolen-Zeit ab, mir graust davor...

Besten Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum