Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nur teilweise deutsche Tastaturbelegung
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Wed Dec 07, 2011 12:59 am    Post subject: Nur teilweise deutsche Tastaturbelegung Reply with quote

Hallo - als absoluter Gentoo Neuling habe ich es immerhin, auch mit Unterstützung aus diesem Forum, geschafft, ein funktionierendes System mit GenKernel 3.0.6 und KDE 4.6.5 aufzusetzen. Da ja eigentlich alles wunderbar dokumentiert ist, habe ich mich erst einmal einige Stunden lesend und testend mit meinem zur Zeit drängendsten Problem beschäftigt:

Ich bekomme einfach keine wirklich funktionierende Einstellung auf deutsch zustande.

Ich habe alles an Variablen gesetzt, was in dem Online Installationshandbuch stand. Auch in der /etc/make.conf den Eintrag LINGUAS="de".
Dann die "locales"
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
de_DE.UTF-8 UTF-8 (habe ich nachträglich ergänzt - stand in irgendeinem Forum)
en_US ISO-8859-1
en_US.UTF-8 UTF-8

Dann die "Keymaps"
KEYMAP="de"
KEYMAP="de-latin1"
KEYMAP="de-latin1-nodeadkeys"

Das KDE hatte ich direkt mit deutscher Sprachunterstützung installiert. Aber die Menüs sind weiter teilweise in Englisch. Und wenn ich Firefox und Chrome installiere, sind die auch in Englisch und sind nicht für den deutschen Zeichensatz empfänglich. Auch die Konsole hat nur amerikanischen Zeichensatz. Ich habe jetzt versucht, die Vorschläge der häufig genannten Webside "http://www.gentoo.de/doc/de/guide-localization.xml" durchzuarbeiten; ist bisher aber auch im Sande verlaufen, weil etliche der dort genannten Konfig-Dateien auf meiner Installation nicht zu finden sind. z.B" /etc/env.d/02locale" ,. Die genannten Befehle haben auch nicht geholfen.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed Dec 07, 2011 5:55 am    Post subject: Reply with quote

Hallo, wenn einige Programme auf Englisch statt auf deutsch sind, dann liegt das wohl an der Einstellung in /etc/env.d/02locale. Wenn du die Datei nicht hast, dann einfach erstellen. KDE braucht noch zusätlich das paket kde-l10n, welches du auch installieren solltest, damit die kde programme deutsch reden.
Back to top
View user's profile Send private message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Wed Dec 07, 2011 11:10 am    Post subject: Reply with quote

Danke für die schnelle Antwort.
Das Sprachpaket für KDE war bereits installiert und ich bin dem Ratschlag gefolgt und habe die Datei " /etc/env.d/02locale" neu erstellt und die Zeilen dort eingetragen:
LANG="de_DE.UTF-8"
LC_COLLATE="C"

Ich habe überhaupt alles noch einmal ausgeführt, was in dem WIKI steht: "http://de.gentoo-wiki.com/wiki/Lokalisierung", also auch die geforderten Befehle zum Aktualisieren etc.
Ein wirklicher Erfolg will sich aber nicht einstellen. Natürlich ist in KDE selbst alles auf "deutsch" eingestellt und in der make.conf standen von Anfang an: LINGUAS="de" und als USE-Flag "nls"

Dennoch kann ich überall nur weiterhin mit amerikanischer Tastatur eingeben, Konsole, KDE Programme. Tatsächlich sind aber jetzt einige KDE-Menüs jetzt "deutscher". Wenn das Problem sich überhaupt noch lösen lässt - was mache ich mit den bereits installierten englischen Programmen von Firefox, Chrome und Thunderbird?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Dec 07, 2011 1:25 pm    Post subject: Reply with quote

Welchen Keyboard-Treiber verwendest du?
Ich verwende für Tastatur und Maus evdev, meine /etc/X11/xorg.conf.d/10-evdev.conf schaut so aus:
Code:
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option  "XkbLayout" "de(nodeadkeys)"
        Option  "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


Bez. nicht übersetzten Programmen:
Existiert denn diese locale (de_DE.UTF-8)? Wie schaut deine /etc/locale.gen aus? Hast du eine Zeile ala
Code:
de_DE.UTF-8 UTF-8

drinnen?
Danach auch locale-gen ausgeführt?
Back to top
View user's profile Send private message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Wed Dec 07, 2011 1:55 pm    Post subject: Reply with quote

Die Datei "10-evdev.conf" liegt bei mir unter "usr/share/X11/xorg.conf.d" und sieht so aus:

Section "InputClass"
Identifier "evdev pointer catchall"
MatchIsPointer "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev keyboard catchall"
MatchIsKeyboard "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev tablet catchall"
MatchIsTablet "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev touchscreen catchall"
MatchIsTouchscreen "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection


In der "locale.gen" steht diese Zeile:
"de_DE.UTF-8 UTF-8"

Alle anderen Einträge sind auskommentiert, den Befehl "locale-gen" hatte ich auch ausgeführt. Ich habe auch einmal "glibc" auf Version 2.13-r4 erneuert

Ein paar kleine Erfolge hatten meine Bemühungen ja auch bis jetzt. Chromium ist plötzlich in deutsch "da", Firefox und Thunderbird nicht. Auch die KDE-Menüs sind nun fast alle durchgängig deutsch. Aber weder in der Chromium Adressleiste, noch imTerminalfenster oder im Texteditor habe ich deutsche Tastatur.

Ich habe sogar mal in der Kernelkonfiguration nachgesehen - UTF8 ist "drin".
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Dec 07, 2011 2:09 pm    Post subject: Reply with quote

Dr. Ames wrote:
Die Datei "10-evdev.conf" liegt bei mir unter "usr/share/X11/xorg.conf.d" und sieht so aus:

Die in /usr/share ist eine Vorlage, sie enthält auch keine Einträge für deutsches Layout. In /usr/share bringt die auch nichts, da wird beim STarten von X nicht gesucht.
Kopier mal den Inhalt aus meinem Post oben in die /etc/X11/xorg.conf.d/10-evdev.conf, restarte X, dann hast du sicher mal deutsches KbdLayout in X.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Dec 07, 2011 2:21 pm    Post subject: Reply with quote

Dr. Ames wrote:
Firefox und Thunderbird nicht.

ARGH! Firefox und Thunderbird bekommen ihre Lokalisierung über ein Add-On. Irgendwie wird das aber automatisch deaktiviert.
Gehe im Firefox nach
Tools->Addons -> Reiter "Languages", dort das German Languagepack aktivieren. Firefox neu starten und er ist auf Deutsch.
Selbiges Spielchen bitte noch mit Thunderbird :)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Wed Dec 07, 2011 4:08 pm    Post subject: Reply with quote

Wie schaut denn aktuell die Ausgabe von
Code:
locale -a
und
locale
(als User)
aus?

/edit:
Das Keyboard kann ansonsten auch im KDE unter systemsettings --> Eingabegeräte
für den User eingerichtet werden.
Back to top
View user's profile Send private message
Dr. Ames
n00b
n00b


Joined: 06 Dec 2011
Posts: 22

PostPosted: Wed Dec 07, 2011 4:25 pm    Post subject: Reply with quote

Vielen Dank "franzf"! Klasse, es funktioniert!

Das Verzeichnis "xorg.conf.d" existierte bei mir gar nicht - ebensowenig die Datei "10-evdev.conf" an dieser Stelle. Ich habe beides neu angelegt und wie empfohlen, die genannten Zeilen hinzugefügt. Jetzt habe ich tatsächlich, zumindest auf den ersten Blick, überall die deutsche Tastatur.

Mir scheint nun aber der Mauszeiger etwas "hakeliger" geworden zu sein. In der "make.conf" hatte ich von Anfang an für meine Maus den richtigen Eintrag "vmmouse" - ich nutze Gentoo in einem VM Guest System.

Muss ich nun auch die Mausbezeichnung in irgendeiner Konfig-Datei zusätzlich oder neu angeben?

@Josef95.
Der Abruf "locale" wies meiner Meinung nach korrekt auf die de_UTF Einstellung hin, dennoch hatte ich bis jetzt keine dt. Tastatur. Es scheint tatsächlich die fehlende X-Org Konfigurationsdatei gewesen zu sein.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Wed Dec 07, 2011 4:40 pm    Post subject: Reply with quote

Dr. Ames wrote:
Der Abruf "locale" wies meiner Meinung nach korrekt auf die de_UTF Einstellung hin, dennoch hatte ich bis jetzt keine dt. Tastatur. Es scheint tatsächlich die fehlende X-Org Konfigurationsdatei gewesen zu sein.

Die locale und keyboard Settings sind zwei verschiedene paar Schuhe - das hat sicher nichts miteinander zu tun.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum