Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] automount durch Gnome unter KDE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Thu Dec 29, 2011 1:23 pm    Post subject: [gelöst] automount durch Gnome unter KDE Reply with quote

Hallo Leute,

mit meinem letzten Update auf ein aktuelles Gentoo (ich hatte seit Januar es aus Zeitgründen nicht geschafft), werden meine Wechselmedien automatisch gemountet (unter KDE ist automount abgeschaltet). Da sehr viel umgestellt wurde (OpenRC bspw.), meine Frage an Euch, wo ich das deaktivieren kann? Mir wäre das vorhergehende Verhalten lieber: Im KDE wird das neue Medium gezeigt und ich entscheide dann, was damit passieren soll.


Last edited by LinuxTom on Thu Dec 29, 2011 3:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2328
Location: Konradsreuth (Germany)

PostPosted: Thu Dec 29, 2011 1:42 pm    Post subject: Reply with quote

Muß man nicht für gewöhnlich unter Gentoo was dafür tun, daß sowas passiert und nicht was dagegen?! Den Fall hatt ich noch nie, daß ich irgend ein Feature hatte, das ich nicht vorher eigenhändig installiert hab. Evtl. das Gegenteil von http://de.gentoo-wiki.com/wiki/Autofs machen?
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Thu Dec 29, 2011 2:21 pm    Post subject: Reply with quote

Tja, nichts davon installiert und nicht mal im Kernel aktiviert.

Gibt es vielleicht noch andere Ideen?

Hier mal ein Logfileausschnitt, wenn ich einen USB-Stick rein stecke:
Code:
Dec 29 15:21:37 lenovo kernel: usb 1-1: new high speed USB device number 5 using ehci_hcd
Dec 29 15:21:37 lenovo kernel: usb 1-1: New USB device found, idVendor=0781, idProduct=5205
Dec 29 15:21:37 lenovo kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec 29 15:21:37 lenovo kernel: usb 1-1: Product: Extreme Ducati
Dec 29 15:21:37 lenovo kernel: usb 1-1: Manufacturer: SanDisk Corporation
Dec 29 15:21:37 lenovo kernel: usb 1-1: SerialNumber: XXXXXXXXXXXXXXXXXXXX
Dec 29 15:21:37 lenovo kernel: scsi5 : usb-storage 1-1:1.0
Dec 29 15:21:38 lenovo kernel: scsi 5:0:0:0: Direct-Access     SanDisk  Extreme Ducati   0.1  PQ: 0 ANSI: 2
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: Attached scsi generic sg2 type 0
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] 8027712 512-byte logical blocks: (4.11 GB/3.82 GiB)
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] Write Protect is off
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] Mode Sense: 03 00 00 00
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] Assuming drive cache: write through
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] Assuming drive cache: write through
Dec 29 15:21:38 lenovo kernel: sdb: sdb1
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] Assuming drive cache: write through
Dec 29 15:21:38 lenovo kernel: sd 5:0:0:0: [sdb] Attached SCSI removable disk
Dec 29 15:21:52 lenovo kernel: sdb: detected capacity change from 4110188544 to 0
Dec 29 15:21:59 lenovo kernel: usb 1-1: USB disconnect, device number 5
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2328
Location: Konradsreuth (Germany)

PostPosted: Thu Dec 29, 2011 2:40 pm    Post subject: Reply with quote

Sieht doch alles ganz normal aus … gemountet ist dein USB-Stick aber deswegen noch nicht! Auch, wenn da steht „Attached SCSI removable disk“, das heißt nur, daß das Gerät eben jetzt verfügbar ist. Und bei „Dec 29 15:21:59“ hast ihn halt wieder rausgezogen …
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Thu Dec 29, 2011 2:48 pm    Post subject: Reply with quote

Ich habe jetzt herausgefunden, dass der USB-Stick ohne X11/KDE nicht gemountet wird. Selbst unter den Gnome-Komponenten (in denen ich mich nicht recht auskenne) ist unter nautilus der Automounter deaktiviert, doch nur unter nautilus kann ich bspw. CD's wieder auswerfen. Es deutet auf irgend eine Gnome-Einstellung hin.

Aber welche? ???
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Thu Dec 29, 2011 2:57 pm    Post subject: Reply with quote

KDE mounted normal mit den default Einstellungen kein Laufwerk automatisch. (und das ist auch gut so )

Die Einstellungen im KDE findet man unter systemsettings --> Wechselmedien
oder direkt mit
Code:
$ kcmshell4 device_automounter_kcm


Welche Laufwerke aktuell wirklich eingebunden sind kann unter
Code:
cat /proc/mounts
eingesehen werden.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Thu Dec 29, 2011 3:02 pm    Post subject: Reply with quote

Endlich gefunden. Unter KDE ist alles in Ordnung. Es kommt vom Gnome-Nautilus. Ich habe da zwar alles deaktiviert, doch an die Einstellung kommt man von Nautilus selbst gar nicht ran.

Ich habe gnome-extra/gconf-editor installiert und dann dort im Dateibau doch glatt noch die Einstellung unter
Code:
/apps/nautilus/preferences/media_automount

einen Haken gefunden. Den deaktiviert und nun ist wieder alles gut.

Doch wie das dort rein gekommen ist?

Aber trotzdem Danke für die Hinweise. Vielleicht hilft meine Entdeckung dem einen oder anderen auch noch. :)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Thu Dec 29, 2011 3:09 pm    Post subject: Reply with quote

Ja, im Gnome wird per default (alles) automatisch sofort mounted - darüber hab ich mich auch schon geärgert.
Wenn man das nicht möchte kann man es aber deaktivieren.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Thu Dec 29, 2011 3:12 pm    Post subject: Reply with quote

Josef.95 wrote:
Wenn man das nicht möchte kann man es aber deaktivieren.

Und das war die Herausforderung, wenn man eigentlich kein Gnome verwendet.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Thu Dec 29, 2011 3:48 pm    Post subject: Reply with quote

Hehe, wenn du im nachhinein den Thread Titel änderst dann sollte das auch mit einem /edit vermerkt werden...
Ansonsten stehen einige Beiträge ganz schön blöd da - da es die Info das auch gnome genutzt wird zu dem Zeitpunkt noch nicht da war ;)
danke
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Thu Dec 29, 2011 3:54 pm    Post subject: Reply with quote

Dann gib mir bitte ein Beispiel, denn als den Thread gestartet hatte wusste ich es selbst noch nicht. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum