Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kscd, dolphin und Amarok spielen keine Audio-CDs [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sat Dec 31, 2011 7:46 pm    Post subject: kscd, dolphin und Amarok spielen keine Audio-CDs [solved] Reply with quote

Guten Rutsch miteinander.
Wollte mich Heute um die Zusammenstellung einiger Playlists kümmern, und was stell ich dabei fest:
Ich kann mit Amarok keine CD's abspielen und somit auch nicht rippen. Ziemlich dumm wenn man beim abspielen und Zusammenstellen der Playlisten nicht gleichzeitig rippen kann.
Denn solange Amarok aktiv ist, reisst er jedesmal die Kontrolle der Audio-CD's an sich. Anderer Ripper dann parallel zu benutzen ist dann ziemlich nervig solange Amarok läuft...

kscd braucht eigentlich kein Mensch, aber es läuft eben nicht und ich vermute da einen Zusammenhang.
Daher denke ich wenn wir das zum laufen bringen, dann klappt's vielleicht auch in Amarok.
Dolphin's "Vorschau" kann die CDs auch nicht abspielen, rippen per Drag and Drop z.B. nach mp3 geht aber gut.

Xine, Kaffeine, Smplayer, Grip spielen dagegen Audio- CDs.
Bei Grip hör ich allerdings keinen sound.

CDs rippen funktioniert prima mit Soundkonverter, k3b, Grip, Audex, Dolphin u.a.

Geprüft und korrigiert hab ich schon einiges, jedoch ohne Verbesserung bzg. o.g. Problem.

So hab ich mittlerweile symlinks von:

Code:
lrwxrwxrwx 1 root root 3 31. Dez 19:59 /dev/cdrom -> sr0
lrwxrwxrwx 1 root root 3 31. Dez 19:59 /dev/cdrw -> sr0
lrwxrwxrwx 1 root root 3 31. Dez 19:59 /dev/dvd -> sr0
lrwxrwxrwx 1 root root 3 31. Dez 19:59 /dev/dvdrw -> sr0


Zuvor hatte jedes device eine 1 hinter der Bezeichnung wegen doppelter Einträge in der udev-rule, jetzt ist das IMHO korrekt so.

In KDE4 unter Systemeinstellung/Multimedia/Allgemein/ steht:
/dev/cdrom
Das sollte nun so passen, dank der korrigierten Symlinks s.o.
Hab's aber auch schon mal mit /dev/sr0 probiert, jedoch ohne Erfolg.

Hier mal meine gesetzten USE-Flags von Amarok, damit ihr seht dass cdda etc. gesetzt sind:

[[I] media-sound/amarok
Installed versions: 2.5.0-r1(4)!t(16:11:38 31.12.2011)(cdda linguas_de mtp ofa opengl semantic-desktop utils -daap -debug -embedded -ipod -kdeenablefinal -lastfm -mp3tunes)

kscd hat so gut wie keine USE-Flags , die Funktionen werde sicher über KDE bereit gestellt, doch woran genau könnte es liegen.
Als User aus der konsole gestartet mit kscd -s gibt's keine Fehler, aber abgespielt wird nix. Kein Zugriff auf's CD-Laufwerk, aber eine Tracklist über die einzelnen Titel gibt's dagegen schon, wenn auch alle als Unbekannt deklariert sind, aber mit ihrer Spielzeit.

Was sollte ich am dagegen unternehmen?

Andy.
_________________
If you want to see a Distro done right, compile it yourself!


Last edited by Randy Andy on Sun Jan 01, 2012 1:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Jan 01, 2012 8:16 am    Post subject: Reply with quote

Welches phonon-backend verwendest du?
gstreamer? -> gst-plugins-cdio installiert? (Ich hoffe das ist das welches einer...)
vlc? -> vlc mit USE="cdda" gebaut?
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sun Jan 01, 2012 10:39 am    Post subject: Reply with quote

Ein gutes Neues Jahr, Franz.

Dank deiner Antwort wird's vielleicht auch für meiner einer gut :lol:

Na jedenfalls ist bei mir sowohl das cdda als auch gstreamer USE-Flag global gesetzt.
Als Phonon Backend ist gstreamer eingestellt und auch nur noch dieses dort zur Auswahl vorhanden.
Die anderen hab ich irgendwann vor langer Zeit wegen diverser Querelen über Bord geworfen.

gst-plugins-cdio sind jedoch nicht installiert, das mach ich jetzt mal. Wieso eigentlich nicht?
Sollten sie nicht als Abhängigkeit mitgezogen werden, wenn sie erforderlich sind. :roll:

Bis später mal...

[Edit] Prima Franz, nun klappt's. Endlich kann ich auch in Amarok abspielen sowie rippen.
Kscd spielt auch und nun klappt's auch dort mit der cddb-Abfrage und Anzeige.

Interessant fänd ich noch die Frage warum Grip beim Abspielen keine sound ausgibt. Liegt's daran weil's ein Gtk-Programm ist und ein anderes Backend braucht, bzw. weil das seperat zu konfigurieren ist?

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum