Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] libgnomecanvas-python läßt sich nicht kompilieren
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Fri Jan 06, 2012 7:45 pm    Post subject: [SOLVED] libgnomecanvas-python läßt sich nicht kompilieren Reply with quote

Habe Probleme beim Installieren von gnome. Das Packet libgnomecanvas-python läßt sich nicht kompilieren.

python-updater hat nichts geholfen, revdep-rebuild sagt das alles in Ordnung ist.

Kennt einer von euch das Problem und hat eventuell einen Rat parat?

Code:

>>> Emerging (1 of 1) dev-python/libgnomecanvas-python-2.28.1
 * gnome-python-2.28.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                      [ ok ]
>>> Unpacking source...
>>> Unpacking gnome-python-2.28.1.tar.bz2 to /var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work
 * Fixing OMF Makefiles ...                                              [ ok ]
 * Running elibtoolize in: gnome-python-2.28.1/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 * Fixing OMF Makefiles ...                                              [ ok ]
>>> Source unpacked in /var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work
>>> Compiling source in /var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1 ...
 * Building of dev-python/libgnomecanvas-python-2.28.1 with CPython 2.7...
 * econf: updating gnome-python-2.28.1-2.7/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating gnome-python-2.28.1-2.7/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating gnome-python-2.28.1/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating gnome-python-2.28.1/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-allbindings --enable-gnomecanvas
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking dependency style of i686-pc-linux-gnu-gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by i686-pc-linux-gnu-gcc... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/i686-pc-linux-gnu/bin/ld option to reload object files... -r
checking for i686-pc-linux-gnu-objdump... i686-pc-linux-gnu-objdump
checking how to recognize dependent libraries... pass_all
checking for i686-pc-linux-gnu-ar... i686-pc-linux-gnu-ar
checking for i686-pc-linux-gnu-strip... i686-pc-linux-gnu-strip
checking for i686-pc-linux-gnu-ranlib... i686-pc-linux-gnu-ranlib
checking command to parse /usr/bin/nm -B output from i686-pc-linux-gnu-gcc object... ok
checking how to run the C preprocessor... i686-pc-linux-gnu-gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if i686-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for i686-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if i686-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if i686-pc-linux-gnu-gcc static flag -static works... yes
checking if i686-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if i686-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the i686-pc-linux-gnu-gcc linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating ./config.lt
config.lt: creating libtool
checking for a Python interpreter with version >= 2.2... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for headers required to compile python extensions... found
checking for python libraries... -L/usr/lib -lm -lpthread -ldl  -lutil -lpython2.7
checking for i686-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for PYGOBJECT... yes
checking for PYGTK... yes
checking for pygobject-codegen-2.0... /usr/bin/pygobject-codegen-2.0
checking for conflicting pygtk versions... none
checking for pygtk defs... /usr/share/pygtk/2.0/defs
checking for i686-pc-linux-gnu-pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for GLIB - version >= 2.6.0... yes (version 2.28.8)
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.6.0... yes (version 2.24.5)
checking for prctl... yes
checking for setproctitle... no
checking for PYORBIT... yes
checking for GNOMECANVAS... yes
checking whether i686-pc-linux-gnu-gcc -pthread understands -Wall... yes
checking whether i686-pc-linux-gnu-gcc -pthread understands -std=c9x... yes
checking whether i686-pc-linux-gnu-gcc -pthread understands -fno-strict-aliasing... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating docs/Makefile
config.status: creating docs/gnomevfs/Makefile
config.status: creating gconf/Makefile
config.status: creating gnome/Makefile
config.status: creating gnomevfs/Makefile
config.status: creating gnomecanvas/Makefile
config.status: creating bonobo/Makefile
config.status: creating tests/Makefile
config.status: creating gnome-python.spec
config.status: creating gnome-python-2.0.pc
config.status: creating PKG-INFO
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands

The following modules will be built:

gnomecanvas

The following modules will NOT be built:

gnome
gnome.ui
gnomevfs
gnomevfs.bonobo
gnome-vfs python module support
gconf
bonobo
bonobo.activation
bonobo.ui
*****************************************************************************
*** WARNING: You are using a deprecated build system (autotools).
***          You should be using WAF instead; see the file INSTALL.WAF.
***          The autotools build system will be removed in a future version.
*****************************************************************************
 * Building of dev-python/libgnomecanvas-python-2.28.1 with CPython 2.7...
make -j3
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7'
Making all in docs
make[2]: Entering directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/docs'
make[3]: Entering directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/docs'
make[3]: F��r das Ziel ��all-am�� ist nichts zu tun.
make[3]: Leaving directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/docs'
make[2]: Leaving directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/docs'
Making all in gnomecanvas
make[2]: Entering directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/gnomecanvas'
/bin/sh ../libtool  --tag=CC   --mode=compile i686-pc-linux-gnu-gcc -pthread -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.7 -I/usr/include/python2.7 -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/pygtk-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore     -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/libgnomecanvas-2.0 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore   -O3 -march=i686 -pipe -fomit-frame-pointer -Wall -std=c9x -fno-strict-aliasing -MT gnomecanvas_la-canvasmodule.lo -MD -MP -MF .deps/gnomecanvas_la-canvasmodule.Tpo -c -o gnomecanvas_la-canvasmodule.lo `test -f 'canvasmodule.c' || echo './'`canvasmodule.c
(cd . \
 && /usr/bin/pygobject-codegen-2.0 \
    --py_ssize_t-clean \
    --load-types ../bonobo/bonobo-arg-types.py \
    --register /usr/share/pygtk/2.0/defs/pango-types.defs \
    --register /usr/share/pygtk/2.0/defs/gdk-types.defs \
    --register /usr/share/pygtk/2.0/defs/gtk-types.defs \
    --register ../bonobo/bonobo-types.defs \
    --register ../bonobo/bonoboui-types.defs \
    --override canvas.override \
    --prefix pycanvas canvas.defs) > gen-canvas.c \
&& cp gen-canvas.c canvas.c \
&& rm -f gen-canvas.c
libtool: compile:  i686-pc-linux-gnu-gcc -pthread -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.7 -I/usr/include/python2.7 -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/pygtk-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/libgnomecanvas-2.0 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -O3 -march=i686 -pipe -fomit-frame-pointer -Wall -std=c9x -fno-strict-aliasing -MT gnomecanvas_la-canvasmodule.lo -MD -MP -MF .deps/gnomecanvas_la-canvasmodule.Tpo -c canvasmodule.c  -fPIC -DPIC -o .libs/gnomecanvas_la-canvasmodule.o
mv -f .deps/gnomecanvas_la-canvasmodule.Tpo .deps/gnomecanvas_la-canvasmodule.Plo
Warning: Constructor for GnomeCanvas needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasItem needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasGroup needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasClipgroup needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasLine needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasPixbuf needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasRichText needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasShape needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasRE needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasRect needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasEllipse needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasPolygon needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasBpath needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasText needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasWidget needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
***INFO*** The coverage of global functions is 100.00% (1/1)
***INFO*** The coverage of methods is 100.00% (47/47)
***INFO*** There are no declared virtual proxies.
***INFO*** There are no declared virtual accessors.
***INFO*** There are no declared interface proxies.
/bin/sh ../libtool  --tag=CC   --mode=compile i686-pc-linux-gnu-gcc -pthread -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.7 -I/usr/include/python2.7 -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/pygtk-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore     -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/libgnomecanvas-2.0 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore   -O3 -march=i686 -pipe -fomit-frame-pointer -Wall -std=c9x -fno-strict-aliasing -MT gnomecanvas_la-canvas.lo -MD -MP -MF .deps/gnomecanvas_la-canvas.Tpo -c -o gnomecanvas_la-canvas.lo `test -f 'canvas.c' || echo './'`canvas.c
libtool: compile:  i686-pc-linux-gnu-gcc -pthread -DHAVE_CONFIG_H -I. -I.. -I/usr/include/python2.7 -I/usr/include/python2.7 -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/pygtk-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/libgnomecanvas-2.0 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore -O3 -march=i686 -pipe -fomit-frame-pointer -Wall -std=c9x -fno-strict-aliasing -MT gnomecanvas_la-canvas.lo -MD -MP -MF .deps/gnomecanvas_la-canvas.Tpo -c canvas.c  -fPIC -DPIC -o .libs/gnomecanvas_la-canvas.o
mv -f .deps/gnomecanvas_la-canvas.Tpo .deps/gnomecanvas_la-canvas.Plo
/bin/sh ../libtool --tag=CC   --mode=link i686-pc-linux-gnu-gcc -pthread -pthread -D_REENTRANT -DQT_SHARED -I/usr/include/libgnomecanvas-2.0 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libpng15 -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/libdrm -I/usr/include/qt4/QtCore   -O3 -march=i686 -pipe -fomit-frame-pointer -Wall -std=c9x -fno-strict-aliasing -module -avoid-version -no-undefined -export-symbols-regex initgnomecanvas -Wl,-O1 -Wl,--as-needed -o gnomecanvas.la -rpath /usr/lib/python2.7/site-packages/gtk-2.0 gnomecanvas_la-canvasmodule.lo gnomecanvas_la-canvas.lo -pthread -lgnomecanvas-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -L/usr/lib -lm -lpthread -ldl  -lutil -lpython2.7
libtool: link: /usr/bin/nm -B  .libs/gnomecanvas_la-canvasmodule.o .libs/gnomecanvas_la-canvas.o   | sed -n -e 's/^.*[    ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[    ][    ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2 \2/p' | /bin/sed 's/.* //' | sort | uniq > .libs/gnomecanvas.exp
/usr/bin/nm: .libs/gnomecanvas_la-canvasmodule.o: File format not recognized
/usr/bin/nm: .libs/gnomecanvas_la-canvas.o: File format not recognized
libtool: link: /bin/grep -E -e "initgnomecanvas" ".libs/gnomecanvas.exp" > ".libs/gnomecanvas.expT"
libtool: link: mv -f ".libs/gnomecanvas.expT" ".libs/gnomecanvas.exp"
libtool: link: echo "{ global:" > .libs/gnomecanvas.ver
libtool: link:  cat .libs/gnomecanvas.exp | sed -e "s/\(.*\)/\1;/" >> .libs/gnomecanvas.ver
libtool: link:  echo "local: *; };" >> .libs/gnomecanvas.ver
libtool: link:  i686-pc-linux-gnu-gcc -shared  .libs/gnomecanvas_la-canvasmodule.o .libs/gnomecanvas_la-canvas.o   -Wl,--as-needed -lgnomecanvas-2 /usr/lib/libart_lgpl_2.so -lgtk-x11-2.0 -lgdk-x11-2.0 /usr/lib/libatk-1.0.so -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 /usr/lib/libfontconfig.so -lfreetype -lz -lbz2 -lexpat -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -L/usr/lib -lm -lpthread -ldl -lutil -lpython2.7  -pthread -pthread -march=i686 -Wl,-O1 -pthread   -pthread -Wl,-soname -Wl,gnomecanvas.so -Wl,-version-script -Wl,.libs/gnomecanvas.ver -o .libs/gnomecanvas.so
/usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../i686-pc-linux-gnu/bin/ld:.libs/gnomecanvas.ver:2: syntax error in VERSION script
collect2: ld returned 1 exit status
make[2]: *** [gnomecanvas.la] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/gnomecanvas'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7'
make: *** [all] Fehler 2
emake failed
 * ERROR: dev-python/libgnomecanvas-python-2.28.1 failed (compile phase):
 *   Building failed with CPython 2.7 in building() function
 *
 * Call stack:
 *     ebuild.sh, line   75:  Called src_compile
 *   environment, line 5745:  Called gnome-python-common_src_compile
 *   environment, line 2886:  Called python_execute_function '-s' 'building'
 *   environment, line 4123:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *
 * If you need support, post the output of 'emerge --info =dev-python/libgnomecanvas-python-2.28.1',
 * the complete build log and the output of 'emerge -pqv =dev-python/libgnomecanvas-python-2.28.1'.
 * The complete build log is located at '/var/log/portage/dev-python:libgnomecanvas-python-2.28.1:20120106-193834.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/temp/environment'.
 * S: '/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1'

>>> Failed to emerge dev-python/libgnomecanvas-python-2.28.1, Log file:

>>>  '/var/log/portage/dev-python:libgnomecanvas-python-2.28.1:20120106-193834.log'

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Last edited by Jefferson on Sun Jan 08, 2012 9:07 am; edited 1 time in total
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Fri Jan 06, 2012 8:10 pm    Post subject: Reply with quote

Hmm die Fehlermeldungen...

Code:
*****************************************************************************
*** WARNING: You are using a deprecated build system (autotools).
***          You should be using WAF instead; see the file INSTALL.WAF.
***          The autotools build system will be removed in a future version.
*****************************************************************************


Code:
Warning: Constructor for GnomeCanvas needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasItem needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasGroup needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasClipgroup needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasLine needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors
Warning: Constructor for GnomeCanvasPixbuf needs to be updated to new API
         See http://live.gnome.org/PyGTK_2fWhatsNew28#update-constructors


Sind doch interessant. Versuch mal

dev-python/gtkspell-python
dev-python/gtkhtml-python
dev-python/gnome-python-extras-base
dev-python/gnome-python-base
dev-python/gnome-python-desktop-base

Neu zu bauen, ODER schau einfach in die abhängigkeiten von dev-python/libgnomecanvas-python.

Das ist aber keine gezielte Lösung sondern eine Vermuteter-Schrotflinten-Tipp!
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Fri Jan 06, 2012 8:43 pm    Post subject: Reply with quote

Auch "Schrotflinten-Tips" sind willkommen ;-)

Hat aber nicht funktioniert.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Sat Jan 07, 2012 1:45 pm    Post subject: Reply with quote

Hast Du mal
Code:
python-updater

laufen lassen?
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sat Jan 07, 2012 2:10 pm    Post subject: Reply with quote

python-updater ist durchgelaufen, hat aber nix gebracht.

Habe hier python Version 2.7 und 3.1 installiert und es mit beiden Versionen erfolglos probiert.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jan 07, 2012 2:45 pm    Post subject: Reply with quote

Welche binutils-Version hast du installiert? Mit welchen USE-Flags?
Kannst du mal den Inhalt jenes ominösen "/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/gnomecanvas/.libs/gnomecanvas.ver" posten?
Ich hoffe die Datei liegt dort, wenn nicht, mach einfach
Code:
find /var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1 -name gnomecanvas.ver
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sat Jan 07, 2012 3:06 pm    Post subject: Reply with quote

Quote:

Welche binutils-Version hast du installiert? Mit welchen USE-Flags?

Ist die aktuellste Version die vorhanden ist.
Code:

sys-devel/binutils-2.21.1-r1  USE="nls zlib -multislot -multitarget -static-libs -test -vanilla"

Quote:

Kannst du mal den Inhalt jenes ominösen "/var/tmp/portage/dev-python/libgnomecanvas-python-2.28.1/work/gnome-python-2.28.1-2.7/gnomecanvas/.libs/gnomecanvas.ver" posten?

Der Inhalt ist ziemlich dürftig - nur die beiden nachfolgenden Zeilen
Code:

{ global:
local: *; };
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jan 07, 2012 6:47 pm    Post subject: Reply with quote

Tjo, und so sollte es ausschauen:
Code:
{ global:
initgnomecanvas;
local: *; };

Bissl auf b.g.o nach "syntax error in VERSION script" suchen, sagt mir:
* emerge -uDN world
* revdep-rebuild
* ccache aus den FEATURES nehmen
Hilft das?
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sun Jan 08, 2012 9:06 am    Post subject: Reply with quote

ccache hat geholfen :D

Am Ende hat portage die nachfolgende Warnung ausgegeben bzgl. file collision(s).

Code:

>>> Installing (1 of 1) dev-python/libgnomecanvas-python-2.28.1
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). Once again, please do NOT file
 * a bug report unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *    /usr/lib/python2.7/site-packages/gtk-2.0/gnomecanvas.so
 *    /usr/share/pygtk/2.0/defs/canvas.defs
 *    /usr/share/doc/libgnomecanvas-python-2.28.1/ChangeLog.bz2
 *    /usr/share/doc/libgnomecanvas-python-2.28.1/NEWS.bz2
 *    /usr/share/doc/libgnomecanvas-python-2.28.1/AUTHORS.bz2
 *    /usr/share/doc/libgnomecanvas-python-2.28.1/README.bz2
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * None of the installed packages claim the file(s).
 *
 * Package 'dev-python/libgnomecanvas-python-2.28.1' merged despite file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.
 * Compilation and optimization of Python modules for CPython 2.7 ...    [ ok ]


Warum stört den jetzt ccache beim kompilieren. Kannst du mich mal in kurzen Zügen schlau machen oder mal einen Link oder ähnliches posten wo man das nachlesen kann?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum