Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel Corporation 82437FX und Xorg Konfiguration
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Sat Jan 14, 2012 10:10 am    Post subject: Intel Corporation 82437FX und Xorg Konfiguration Reply with quote

Hallo,

ich möchte gerne xorg.conf für einen integrierten Grafikchip auf einem Corei7 2600 erstellen.

Was ich schon habe:

/etc/make.conf
Code:

INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="nvidia intel i128 i810"


der Fehler:
Code:


Xorg -configure

X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-gentoo-r1 x86_64 Gentoo
Current Operating System: Linux Serverneu 3.2.0-gentoo-r1 #1 SMP Fri Jan 13 20:32:18 Local time zone must be set--see zic  x86_64
Kernel command line: real_root=/dev/sda8
Build Date: 13 January 2012  10:02:25PM
 
Current version of pixman: 0.24.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 14 11:08:44 2012
Missing output drivers.  Configuration failed.
Server terminated with error (2). Closing log file.


lspci
Code:

00:02.0 VGA compatible controller: Intel Corporation 82437FX (rev 09)


Welchen Treiber braucht man?

G. Roland
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jan 14, 2012 10:40 am    Post subject: Reply with quote

Du brauchst den xf86-video-intel. Und vor allem: gar keine xorg.conf mehr!
Im kernel musst du CONFIG_DRM_I915_KMS anschalten.
Da sich bei den Treibern recht schnell was tut, fährst du am besten mit den aktuellsten Versionen von xf86-video-intel, mesa, kernel und xorg-server.

Ich hab hier nen i7 2600K, und es läuft alles recht gut. Nur macht das Compositing auf dem kde-Desktop mit qgraphicssystem=raster manche komischen Sachen (von Fenstern sieht man nur das "Blur", usw.) -> graphicssystem="native" geht super :)
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Sat Jan 14, 2012 1:57 pm    Post subject: Reply with quote

franzf wrote:
Du brauchst den xf86-video-intel. Und vor allem: gar keine xorg.conf mehr!
Im kernel musst du CONFIG_DRM_I915_KMS anschalten.
Da sich bei den Treibern recht schnell was tut, fährst du am besten mit den aktuellsten Versionen von xf86-video-intel, mesa, kernel und xorg-server.

Ich hab hier nen i7 2600K, und es läuft alles recht gut. Nur macht das Compositing auf dem kde-Desktop mit qgraphicssystem=raster manche komischen Sachen (von Fenstern sieht man nur das "Blur", usw.) -> graphicssystem="native" geht super :)



Hallo,

das hat gut funktioniert. Danke.

Noch ein Problem habe ich. Auf dem per VGA Kabel angeschlossenen Monitor ist das Bild verwaschen. bzw. wird alles doppelt und verschwommen angezeigt. Auf dem per DVI Kabel angeschlossenen Monitor ist alles OK. Das hatte ich aber schon bei der Installation unter Ubuntu.

Dann bräuchte ich noch einen Tipp. Wie funktioniert mit der Intel Grafik Xinerama? Habe unter gnome den 2. Monitor in Betrieb, aber die Fenster dehnen sich beim Maximieren über beide Displays aus. Das USE Flag xinerama steht in make.conf.

G. Roland

Edit: Verwende wie beschrieben keine xorg.conf. geht jetzt auch 3d (Stereoskopie)?
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Sun Jan 15, 2012 11:31 am    Post subject: Reply with quote

Hallo,

das erste Problem konnte ich durch Verwendung eines HDMI to DVI Adapters umschiffen. Die darstellung ist nun sehr gut.

Die Probleme XINERAMA und 3d Wiedergabe bleiben.


G. Roland

Edit: Verwende wie beschrieben keine xorg.conf. geht jetzt auch 3d (Stereoskopie)?[/quote]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum