Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ata4.00: unsupported CDB len
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Jan 22, 2012 1:48 pm    Post subject: ata4.00: unsupported CDB len Reply with quote

Seit heute spuckt mir mein kernel folgendes aus:
Code:
$ dmesg | grep ata4
[    4.070764] ata4: SATA max UDMA/133 abar m2048@0xfe505000 port 0xfe505280 irq 19
[    4.991250] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    5.004373] ata4.00: unsupported CDB len
[    5.005269] ata4: limiting SATA link speed to 1.5 Gbps
[   10.281145] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   10.294519] ata4.00: unsupported CDB len
[   15.572024] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 310)

Der Boot dauert ca. 10 Sekunden länger. Das DVD-Laufwerk blinkt beim Einlegen kurz, dann ist Sense. Alles was drin liegt, kann nicht abgespielt werden, es ist auch gar kein Device (/dev/sr0) vorhanden.
Jetzt die Preisfrage: Ist da das Laufwerk oder der SATA-Port überm Jordan? Oder was anderes?

Code:
00:1f.2 SATA controller: Intel Corporation Cougar Point 6 port SATA AHCI Controller (rev 05) (prog-if 01 [AHCI 1.0])
        Subsystem: ASRock Incorporation Device 1c02
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
        I/O ports at f0b0 [size=8]
        I/O ports at f0a0 [size=4]
        I/O ports at f090 [size=8]
        I/O ports at f080 [size=4]
        I/O ports at f060 [size=32]
        Memory at fe505000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [70] Power Management version 3
        Capabilities: [a8] SATA HBA v1.0
        Capabilities: [b0] PCI Advanced Features
        Kernel driver in use: ahci

Es ist ein ASRock Z68M-ITX/HT, es soll laut Hersteller bereits den SATA-Fix enthalten.
Kann mir dabei jemand helfen?
Danke!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Fri Jan 27, 2012 6:31 am    Post subject: Reply with quote

Hm.., hast du es schon mal mit einer älteren bisher funktionierenden Kernelversion, oder/und mit einer LiveCD getestet?
Eventuell könnte man so erst mal herausfinden ob es sich um einen HW-Defekt, oder doch eher um ein Kernel/Treiber Problem handelt?!
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Jan 27, 2012 6:01 pm    Post subject: Reply with quote

Das ist ja jetzt lustig. Da ich länger außer Haus war und der Wetterbericht meinte, es könnte Unwetter geben (jedenfalls war das noch gestern die Meinung) habe ich routinemäßig den Stecker gezogen - alles Saft weg. Und - tada - das Laufwerk tuts wieder! Ich weiß jetzt auch, dass es an einer Audio-CD liegt, diese "zerstört" reproduzierbar bei einem bestimmten Stück das Laufwerk. Irgend ein Bit ist gesetzt, das auch beim normalen Ausschalten nicht gelöscht wird. MMn. ist das ein Problem des Laufwerks - das schon lange zickt, das ich jetzt wohl endgültig auswechseln werde.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum