Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Desktop] Caractères Chinois (et autres...)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Feb 04, 2012 12:43 pm    Post subject: [Desktop] Caractères Chinois (et autres...) Reply with quote

Salut !

Bon, il y a un truc qui m'énerve, et j'arrive pas à le résoudre. Quand je vais sur une page web qui contient du Chinois (enfin, c'est ce qu'il me semble), j'arrive pas à voir les caractères. Par contre, pas de soucis pour l'Arabe (enfin, ce qu'il me semble).

C'est pas que j'arrive à lire du tout, mais c'est bcp plus joli :D

J'ai cherché dans les docs Gentoo, je n'ai trouvé que l'UTF8 et les locales en chinois, je suppose que c'est pas ça ?
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sat Feb 04, 2012 2:17 pm    Post subject: Reply with quote

Pour lire les caractères asiatiques, j'ai du installer media-fonts/unifont.
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Sat Feb 04, 2012 2:44 pm    Post subject: Reply with quote

Salut,

As-tu installé les fontes nécessaires? http://en.gentoo-wiki.com/wiki/X.Org/Fonts suggère d'installer au moins media-fonts/font-isas-misc mais tu peux en profiter pour installer celles pour le japonais et le coréen aussi.

Après dans un deuxième temps assure-toi que Firefox utilise le bon encodage, dans "Web Developer" -> "Character encoding". En général "Auto-detect" -> "Universal" fonctionne très bien mais si jamais les headers http et/ou les directives html se contredisent et sont différentes du vrai encodage de la page... faut tester à la main les autres possibilités.
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Feb 04, 2012 3:29 pm    Post subject: Reply with quote

Merci à tous les 2 !

Alors je ne sais pas pourquoi, font-isas-misc ne m'a pas ajouté le Chinois... en tous cas ça n'a pas marché (je teste avec la page Wikipedia sur le Mandarin). Par contre, avec unifont j'ai bien le Chinois et le Japonais (seuls test que j'ai effectué).

Mais je vais insister un peu sur font-isas-misc (et les autres) parce que unifont est en bitmap, et ça fait un peu bizarre...

EDIT : bin j'arrive pas à faire marche font-isas-misc et compagnie... restart de X, ajout du path (qui devrait déjà être par défaut, mais bon) dans Xorg.conf... rien...
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7940
Location: ~Brussels - Belgique

PostPosted: Sat Feb 04, 2012 7:47 pm    Post subject: Reply with quote

et avec
Code:
eselect fontconfig
?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Fri Feb 10, 2012 7:57 pm    Post subject: Reply with quote

Bonne piste, mais ça ne m'inspire pas des masses... voici le résultat d'un eselect fontconfig list. Ca vous semble correct ?

Code:

coyote ~ # eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf
  [10]  20-unhint-small-dejavu-sans-mono.conf
  [11]  20-unhint-small-dejavu-serif.conf
  [12]  20-unhint-small-vera.conf *
  [13]  25-unhint-nonlatin.conf
  [14]  30-metric-aliases.conf *
  [15]  30-urw-aliases.conf *
  [16]  40-nonlatin.conf *
  [17]  45-latin.conf *
  [18]  49-sansserif.conf *
  [19]  50-user.conf *
  [20]  51-local.conf *
  [21]  57-dejavu-sans.conf
  [22]  57-dejavu-sans-mono.conf
  [23]  57-dejavu-serif.conf
  [24]  60-latin.conf *
  [25]  65-fonts-persian.conf *
  [26]  65-khmer.conf
  [27]  65-nonlatin.conf *
  [28]  69-unifont.conf *
  [29]  70-no-bitmaps.conf
  [30]  70-yes-bitmaps.conf
  [31]  80-delicious.conf *
  [32]  90-synthetic.conf *

_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7940
Location: ~Brussels - Belgique

PostPosted: Fri Feb 10, 2012 9:59 pm    Post subject: Reply with quote

Tu as bien le USE unicode activé ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Sat Feb 11, 2012 5:15 am    Post subject: Reply with quote

Le problème avec Firefox c'est qu'on ne sait pas quelle fonte il utilise, donc je ne sais même pas si chez moi il utilise celle que j'aie citée. Pour référence j'ai toutes les fontes suivantes:
Code:
$ eix '-I*' --format '<installedversions:EQNAMEVERSION>' media-fonts/\*
=media-fonts/alee-fonts-12
=media-fonts/corefonts-1-r4
=media-fonts/dejavu-2.33
=media-fonts/encodings-1.0.4
=media-fonts/font-adobe-100dpi-1.0.3
=media-fonts/font-adobe-75dpi-1.0.3
=media-fonts/font-adobe-utopia-100dpi-1.0.4
=media-fonts/font-adobe-utopia-75dpi-1.0.4
=media-fonts/font-adobe-utopia-type1-1.0.4
=media-fonts/font-alias-1.0.3
=media-fonts/font-arabic-misc-1.0.3
=media-fonts/font-bh-100dpi-1.0.3
=media-fonts/font-bh-75dpi-1.0.3
=media-fonts/font-bh-lucidatypewriter-100dpi-1.0.3
=media-fonts/font-bh-lucidatypewriter-75dpi-1.0.3
=media-fonts/font-bh-ttf-1.0.3
=media-fonts/font-bh-type1-1.0.3
=media-fonts/font-bitstream-100dpi-1.0.3
=media-fonts/font-bitstream-75dpi-1.0.3
=media-fonts/font-bitstream-speedo-1.0.2
=media-fonts/font-bitstream-type1-1.0.3
=media-fonts/font-cronyx-cyrillic-1.0.3
=media-fonts/font-cursor-misc-1.0.3
=media-fonts/font-daewoo-misc-1.0.3
=media-fonts/font-dec-misc-1.0.3
=media-fonts/font-ibm-type1-1.0.3
=media-fonts/font-isas-misc-1.0.3
=media-fonts/font-jis-misc-1.0.3
=media-fonts/font-micro-misc-1.0.3
=media-fonts/font-misc-cyrillic-1.0.3
=media-fonts/font-misc-ethiopic-1.0.3
=media-fonts/font-misc-meltho-1.0.3
=media-fonts/font-misc-misc-1.1.2
=media-fonts/font-mutt-misc-1.0.3
=media-fonts/font-schumacher-misc-1.1.2
=media-fonts/font-screen-cyrillic-1.0.4
=media-fonts/font-sony-misc-1.0.3
=media-fonts/font-sun-misc-1.0.3
=media-fonts/font-util-1.2.0
=media-fonts/font-winitzki-cyrillic-1.0.3
=media-fonts/font-xfree86-type1-1.0.4
=media-fonts/thaifonts-scalable-0.4.13
=media-fonts/unfonts-1.0.2_pre080608-r1
=media-fonts/unfonts-extra-1.0.2_pre080608-r1
=media-fonts/urw-fonts-2.4.9
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Feb 11, 2012 6:58 am    Post subject: Reply with quote

XavierMiller wrote:
Tu as bien le USE unicode activé ?


Oui, je viens de le vérifier par un emerge --info | grep unicode
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum