Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoolkit und Python 2.6
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
bloedie
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2006
Posts: 88
Location: Germany

PostPosted: Sun Feb 05, 2012 10:17 am    Post subject: Gentoolkit und Python 2.6 Reply with quote

Hi.

Ich war gerade dabei einen neuen Server aufzusetzen und wollte
gentoolkit emergen und da wollte portage python auf 2.6 downgraden
und python 2.7 löschen.

Nachdem ich python 2.7 dann mit xml useflag compiliert hatte konnte
ich auch gentoolkit installieren. Im ebuild von gentoolkit steht auch noch
python-2.6 als Abhängigkeit drin.

Ist das richtig so?

Cu.
Bloedie
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Feb 05, 2012 10:50 am    Post subject: Reply with quote

Da steht:
>=dev-lang/python-2.6[xml]
!>=dev-lang/python-2.6[-xml]

Es wird also eine 2.7 Version mit xml benötigt.
Da steht nichts von 2.6.

Warum portage jetzt aber eine 2.6 Version installieren wollte, kann ich nicht verstehen.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
bloedie
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2006
Posts: 88
Location: Germany

PostPosted: Sun Feb 05, 2012 2:52 pm    Post subject: Reply with quote

Hi.

Das hatte ich schon gesehen das es >= 2.6 sein sollte, hatte mich da nur falsch ausgedrückt. *shameonme*
Ich wollte natürlich wissen warum gentoolkit auf python-2.6 downgraden wollte und nicht
verlangt hatte das ich python-2.7 mit xml flag recompilieren soll.

Cu.
Bloedie
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 761

PostPosted: Sun Feb 05, 2012 8:55 pm    Post subject: Reply with quote

Möglicherweise hast Du portage verboten python-2.7 mit xml zu bauen? (z. B. mit dev-lang/python:2.7 -xml in package.use)

edit: Wobei, das kann es nicht sein. Sonst hättest Du nicht inzwischen python 2.7 mit xml emergen können.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Feb 05, 2012 10:05 pm    Post subject: Reply with quote

Ich vermute das es am jeweils gesetzten --autounmask [ y | n ] Feature liegen könnte.
Mit
Code:
emerge --autounmask=y -av  gentoolkit
sollte es "normal" ein Hinweis darauf geben das python mit xml USE-Flag gebaut werden muss geben - in etwa
Code:
...
The following USE changes are necessary to proceed:
#required by app-portage/gentoolkit-0.3.0.4-r5, required by gentoolkit (argument)
>=dev-lang/python-3.2.2 xml

Doch warum ein Downgrade auf python:2.6 vorgenommen werden sollte kann ich mir auch nicht erklären.
So, ohne genauere Angabe der Versionen und gesetzter USE-Flags wird es aber auch nur sehr schwer sein es nachzuvollziehen bzw eine Erklärung dafür zu finden.
Back to top
View user's profile Send private message
bloedie
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2006
Posts: 88
Location: Germany

PostPosted: Mon Feb 06, 2012 8:12 am    Post subject: Reply with quote

Hi.

Hier die gesetzten USE-Flags aus der make.conf.
Ansonsten ist nichts weiter an USE-Flags gesetzt auch nicht in der package.use!

USE="bzip2 gif imagemagick imap jpeg jpeg2k json libwww maildir mime mmx
multilib mysql netboot pam-mysql php png sasl smtp sockets sse sse2 ssl tiff
unicode xml zip -X -gtk -sdl"


Es ist auserdem auch nichts in der package.keywords eingetragen, sodass es ein
komplettes stable System ist.

Cu.
Bloedie
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Mon Feb 06, 2012 10:46 pm    Post subject: Reply with quote

Hm, so ohne die genaue "Fehlermeldung" lässt sich da im nachhinein schwer was zu sagen. Anscheinend sind die python Versionen im verwendeten stage3 Archiv ja ohne xml Support gebaut worden. (siehe aktuell zb auch [SOLVED] Fehler beim installieren von gentoolkit )
Je nach verwendeten Profil sollte das xml USE-Flag eventuell auch schon vom Profil her gesetzt sein. (siehe zb in der emerge --info)
Zudem ist xml beim aktuellen stable python-2.7.2-r3.ebuild eh schon als default USE-Flag gesetzt:
Code:
grep IUSE /usr/portage/dev-lang/python/python-2.7.2-r3.ebuild
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
Somit hätte ein schlichtes re-emergen von python:2.7 eigentlich schon reichen sollen :P
Back to top
View user's profile Send private message
bloedie
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2006
Posts: 88
Location: Germany

PostPosted: Tue Feb 07, 2012 7:31 am    Post subject: Reply with quote

Hi Josef.

Quote:
Somit hätte ein schlichtes re-emergen von python:2.7 eigentlich schon reichen sollen :P


Das hat ja auch funktioniert und zum downgrade kam es ja auch nicht, aber angezeigt wurde es.
Komische Sache.

Cu.
Bloedie
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Feb 18, 2012 1:35 am    Post subject: Reply with quote

Hi bloedie

Jo, siehe hierzu auch Bug 399331
Back to top
View user's profile Send private message
bloedie
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2006
Posts: 88
Location: Germany

PostPosted: Sat Feb 18, 2012 9:40 am    Post subject: Reply with quote

Hi.

Danke für den Link Josef.

Cu.
Bloedie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum