Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vmware memory issues vith hugepages
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 27 Apr 2004
Posts: 120

PostPosted: Sat Feb 11, 2012 7:24 pm    Post subject: vmware memory issues vith hugepages Reply with quote

Hi everyone,

I upgraded to vmware-7.1.5-491717 (and no chance, apparently, of downgrading using portage) and I'm having this issue that I hadn't before with 7.0.0-203739:

The virtual machine is unable to reserve memory. If selecting Retry does not work, try closing programs on the host machine to free memory first. For more information about this error see our Web site at "".

of course retry doesn'work, so next msg sounds like:

Could not lock 4096 bytes of memory at 7F1654CE8000 (page 7F1654CE8000).

VMware Workstation unrecoverable error: (vcpu-0)
NOT_IMPLEMENTED /build/mts/release/bora-491717/bora/vmcore/vmx/main/monitorHosted32.c:932
A log file is available in "/shared/vmware/daily-use/vmware.log".  Please request support and include the contents of the log file. 
To collect data to submit to VMware support, select Help > About and click "Collect Support Data". You can also run the "vm-support" script in the Workstation folder directly.
We will respond on the basis of your support entitlement.

On my laptop there is a huge amount of ram (8GB) and, as a user and a fan of kvm, I reserve 3GB with hugepages that somehow helps performance in running my kvm machines. I do this with the right mounting in /etc/fstab plus the following lines in sysctl.conf:

Code: = 5
vm.oom_kill_allocating_task = 1
vm.swappiness = 20
# 3GB + 256MB reserved out of about 8GB:
vm.nr_hugepages = 1664
# Required by >=vmware-7.1.5

Following suggestions on a vmware related forum, I could track down the cause for the errors above to those lines in sysctl.conf. Commenting them and rebooting made the trick. But I'd like to have the old good configuration, where vmware and kvm where peacefully living together, me being able to run them at the same time with no loss of performance on the kvm side.
I'm forced to use both virtual environments for work (testing softwares), cannot just kick out vmare.

I guess that vmware looks at the first bytes of a certain memory area to lock there 4MB, and cannot do it because that area is already fenced by hugepages. Is there a way to more finely configure hugepages, or to bypass this vmware behaviour?
Already tried disabling "Memory page trimming", doesn't help, playing with undocumented items in /etc/vmware/config neither.

adding some info: i tried the ebuild in portage to find that vmware stops in stupor (with no msgs whatsoever) for the same reason when a virtual machine is started, if the hugepages are activated as above. If the host machine is rebooted without hugepages everything works.
I'm definitley sick and tired with this crap, so next week will try vmgl and fvd stuff for kvm-qemu with the hope to switch to it completely.
The free men's path is always obstructed by mediocrity.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum