Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dateioperationen lasten das System total aus.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LL0rd
l33t
l33t


Joined: 24 May 2004
Posts: 652
Location: Schlundcity

PostPosted: Mon Feb 13, 2012 1:17 pm    Post subject: Dateioperationen lasten das System total aus. Reply with quote

Hallo Leute,

ich habe gerade ein Problem mit einem Server. Dateisystemoperationen lasten das System irgendwie total aus. Ich habe gerade ein Verzeichnis gelöscht, tausendirgendwas Dateien, 100MB das ganze. Der Load der Kiste ging auf 140 hoch und dann konnte ich nichts mehr machen. Nachdem ich das Löschen abgebrochen habe, ging der Load wieder runter.

Habt ihr eine Idee, was das sein kann?
_________________
Alte Mathematiker sterben nicht - sie verlieren nur einige ihrer Funktionen.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Feb 13, 2012 6:27 pm    Post subject: Reply with quote

Was ist das für ein Dateisystem?
Hast Du komische Meldungen im Syslog?
Wie ist denn die Auslastung verteilt (sys/user/wait).

Ich denke mal der Wait wird recht hoch sein, oder?
Sowas kenn ich nur von langsamen Notebookplatten.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
LL0rd
l33t
l33t


Joined: 24 May 2004
Posts: 652
Location: Schlundcity

PostPosted: Mon Feb 13, 2012 6:49 pm    Post subject: Reply with quote

tazinblack wrote:
Was ist das für ein Dateisystem?

ich nutze ext4
tazinblack wrote:
Hast Du komische Meldungen im Syslog?



tazinblack wrote:
Wie ist denn die Auslastung verteilt (sys/user/wait).

Ich hab mal ein 2 min Video aufgenommen, wie es aussieht, wenn ich die Files lösche.
http://screencast.com/t/YlLkEMudVB

tazinblack wrote:

Ich denke mal der Wait wird recht hoch sein, oder?

Der wait ist nicht sonderlich hoch, "nur" ca. 17% im Schnitt.

tazinblack wrote:

Sowas kenn ich nur von langsamen Notebookplatten.


In der Kiste sind zwei 1.5TB Platten drin, laufen als Raid-1. Wobei ich sagen muss, dass gerade der Sync läuft.
_________________
Alte Mathematiker sterben nicht - sie verlieren nur einige ihrer Funktionen.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Feb 13, 2012 6:53 pm    Post subject: Reply with quote

LL0rd wrote:
... Wobei ich sagen muss, dass gerade der Sync läuft.


Das könnte doch die Ursache sein?
Ich würde mal warten, bis der fertig ist und dann nochmal testen.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Tue Feb 14, 2012 7:52 am    Post subject: Reply with quote

Hi

Mach das ganze mal mit rm. Ist es dann auch so schlimm?

Sebastian
Back to top
View user's profile Send private message
LL0rd
l33t
l33t


Joined: 24 May 2004
Posts: 652
Location: Schlundcity

PostPosted: Tue Feb 14, 2012 9:00 am    Post subject: Reply with quote

Die Synchronisation des Raids ist nun abgeschlossen. An den Verhalten hat sich aber leider nichts geändert. Habe ich ehrlich gesagt auch nicht erwartet, da ich wegen genau diesem Verhalten den Stecker ziehen musste.

rm ist noch schlimmer. Wenn ich den rm Prozess nicht zeitig abwürge, steigt der Load ins unermessliche. Komischerweise sind nur einige Dateien davon betroffen. 100 Files haut die Kiste so weg, bei der 101en Datei steigt der Load, irgendwann geht es dann wieder. Ähnlich ist es mit dem ganz normalen Schreiben auf die Platte. Ich habe mal eine etwas größere Datei kopiert. Ein ppar GB kopiert die Kiste mit Vollspeed, irgendwann geht es dann runter in den einstelligen kb Bereich und dann geht es mit MB/s weiter.

Etwas ähnliches habe ich schon einmal beobachtet, bei einem alten Linux Server einer schweizer Käsemanufaktur. Da hat die Platte des Servers das lustige Spiel "Wer hat mehr Löcher" mit dem Käse gespielt. Da war aber schon von weitem akkustisch zu hören, dass die Platte im A. ist. Die Lesefehler in den Logs haben den Verdacht bestätigt. Aber jetzt habe ich nix in den Logs, auch keine Ausgabe an der Konsole.
_________________
Alte Mathematiker sterben nicht - sie verlieren nur einige ihrer Funktionen.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Tue Feb 14, 2012 10:01 am    Post subject: Reply with quote

Klingt für mich, als würde er solange schnell arbeiten, bis irgendein Cache voll ist und dann gehts eben nur langsam weiter.

Was für einen IO-Scheduler verwendest Du für diese Platte?
Mach mal das hier:
Code:
# cat /sys/block/{DEVICE-NAME}/queue/scheduler

also z.B. auf die erste SCSI Platte:
# cat /sys/block/sda/queue/scheduler


Das zeigt, welche Scheduler vorhanden sind und welcher aktiv ist (der in eckigen Klammern).
Vielleicht hilft es mal einen anderen zu testen.

Ändern kannst Du den Scheduler zur Laufzeit mit
Code:
echo {SCHEDULER-NAME} > /sys/block/{DEVICE-NAME}/queue/scheduler

also z.B.:
echo noop > /sys/block/hda/queue/scheduler

_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Tue Feb 14, 2012 11:00 am    Post subject: Reply with quote

Mit Kernel 3.2.x erlebe ich gelegentlich einen swap-storm - vielleicht ist das ja auch bei Dir das Problem. Eeinige Kernel-devs haben Fixes eingesandt, die schon in -next sind. Das wird dann noch ein Weilchen dauern, bis diese im Vanilla-Kernel erscheinen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum