Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Udev 180/181 with dracut - no devices created
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Uzytkownik
Guru
Guru


Joined: 31 Oct 2004
Posts: 399
Location: Bay Area, US

PostPosted: Wed Feb 22, 2012 10:44 am    Post subject: Udev 180/181 with dracut - no devices created Reply with quote

When I try to use udev 180/181 with dracut 16 no devices are created during early boot as udev cannot settle. Any idea what may be wrong?
_________________
I've probably left my head... somwhere. Please wait untill I find it.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43546
Location: 56N 3W

PostPosted: Wed Feb 22, 2012 8:53 pm    Post subject: Reply with quote

Uzytkownik,

udev 180/181 is broken with a separate /usr and or /var but dracut is supposed to build an initrd that fixes this, because of these issues, these version of udev are hard masked.

Your kernel needs DEVTMPFS to make /dev entries before udev gets started.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Uzytkownik
Guru
Guru


Joined: 31 Oct 2004
Posts: 399
Location: Bay Area, US

PostPosted: Wed Feb 22, 2012 9:01 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Uzytkownik,

udev 180/181 is broken with a separate /usr and or /var


Are you sure? I've used udev 180/181 without problems with separate /var (I have /usr on / partition).

NeddySeagoon wrote:

but dracut is supposed to build an initrd that fixes this,


It fails however with information that udev couldn't settled :(

NeddySeagoon wrote:
because of these issues, these version of udev are hard masked.


That's why it is in unsupported software forum.

NeddySeagoon wrote:

Your kernel needs DEVTMPFS to make /dev entries before udev gets started.


I have both DEVTMPFS and DEVTMPFS_MOUNT.
_________________
I've probably left my head... somwhere. Please wait untill I find it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum