Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
kosovafan
n00b
n00b


Joined: 26 Feb 2011
Posts: 23

PostPosted: Fri Feb 24, 2012 10:39 pm    Post subject: Portage Reply with quote

Hallo,

ich wollte einmal das Update ausprobieren wie es in der Portage Docu erklärt wird.

Jetzt stehe ich aber vor den Problem das pciutils einmal mit Zlib und einmal ohne
Zlib als Abhängigkeit verlangt wurde bei Paketen. Er führt das Update also nicht durch.

Wie kann ich das den jetzt am besten lösen, so ganz verstehe ich das jetzt nicht so ganz.


Code:

gentoo-desk siefke # cat /etc/portage/package.use | grep pciutils
sys-apps/pciutils zlib

gentoo-desk siefke # emerge --update --deep --newuse world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "sys-apps/pciutils[-zlib]".
!!! One of the following packages is required to complete your request:
- sys-apps/pciutils-3.1.7::gentoo (Change USE: -zlib)
(dependency required by "sys-fs/udev-171-r5[hwdb]" [installed])
(dependency required by "net-wireless/bluez-4.98-r1" [installed])
(dependency required by "gnome-base/gvfs-1.10.1[bluetooth]" [installed])
(dependency required by "xfce-base/thunar-1.2.3[dbus,xfce_plugins_trash]" [installed])
(dependency required by "xfce-extra/thunar-archive-plugin-0.3.0" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Code:

gentoo-desk siefke # cat /etc/portage/package.use | grep pciutils
sys-apps/pciutils -zlib

gentoo-desk siefke # emerge --update --deep --newuse world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "sys-apps/pciutils[zlib]".
!!! One of the following packages is required to complete your request:
- sys-apps/pciutils-3.1.7::gentoo (Change USE: +zlib)
(dependency required by "xfce-extra/xfce4-cellmodem-plugin-0.0.5" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Wie kann ich das jetzt lösen, den Aktivieren oder Deaktivieren bringt nichts.
Würde mich freuen wenn jemand einen Tipp hat,


MFG
Silvio
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Fri Feb 24, 2012 10:54 pm    Post subject: Reply with quote

Hm, tja, dieses cellmodem-plugin ist mit version 0.0.5 wohl nicht sonderlich weit gekommen und scheint seit fast 5 Jahren auch nicht mehr weiterentwickelt zu werden. wäre es denn möglich, dass du dich davon trennst? eventuell gibt es auch was anderes, das die gewünschte funktionalität zur verfügung stellt.
Im prinzip ist das aber ein bug im portage tree, so was dürfte nicht auftreten.
Schöne Grüße
Christian
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum