Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiling compiz with kde support causes errors at 4%
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Tue Mar 06, 2012 2:49 pm    Post subject: Compiling compiz with kde support causes errors at 4% Reply with quote

As stated in the title, i'm having trouble very early in the compiling of compiz on amd64. All I can really do at this point is post the results and hope someone can help.

emerge --info "=x11-wm/compiz-0.9.2"
http://www.pastebucket.com/1839

emerge -pqv "=x11-wm/compiz-0.9.2"
Code:
[ebuild  N    ] x11-wm/compiz-0.9.2  USE="kde svg -gnome -gtk"


If you need any more info i can get it to you when I get home. This is all I could retreive remotely. Thanks in advance for the help!
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.


Last edited by jayseejc3191 on Wed Mar 07, 2012 1:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Tue Mar 06, 2012 9:02 pm    Post subject: Reply with quote

do people need more info? is that why they're not responding?
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 923
Location: halmstad

PostPosted: Wed Mar 07, 2012 6:01 am    Post subject: Reply with quote

jayseejc3191


i did not manage to get compiz-9.2 my self (using 0.9.5.2=9999) .

start with

MAKEOPTS="-j3" emerge -av compiz


regards hedmo
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Wed Mar 07, 2012 8:48 am    Post subject: Reply with quote

Without the build.log it is impossible to help.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Wed Mar 07, 2012 12:45 pm    Post subject: Reply with quote

OK, it's gotten to 55% this time before spitting out errors. All I did was a system update last night. Here's the build log:
http://www.pastebucket.com/1842

The only other thing i haven't posted yet is the environment file, so here that is too.
http://www.pastebucket.com/1843

Hope that helps! Gotta get to school now. I'll check when I get home
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 923
Location: halmstad

PostPosted: Wed Mar 07, 2012 4:31 pm    Post subject: Reply with quote

jayseejc3191

yes its the kde that fails.sometimes you have to compile compiz-fusion in right order to make compiz compile.
try to compile compiz-fusion without kde support and recompile it again with it.
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Wed Mar 07, 2012 5:27 pm    Post subject: Reply with quote

Ok, new problem. the compiz-plugins-extra are failing at 68%... here's the logs...

emerge --info =x11-plugins/compiz-plugins-extra-0.9.2
http://www.pastebucket.com/1845

emerge -pqv "=x11-plugins/compiz-plugins-extra-0.9.2"
[ebuild N ] x11-plugins/compiz-plugins-extra-0.9.2 USE="-gnome"

the build log
http://www.pastebucket.com/1846

enviroment hasn't changed.

Seems to be something about libboost this time...
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Thu Mar 08, 2012 6:40 pm    Post subject: Reply with quote

http://paste.pocoo.org/show/562985/
no?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Thu Mar 08, 2012 7:24 pm    Post subject: Reply with quote

It seems that the latest stable compiz version (0.8.8 ) is actually less outdated than the C++ rewrite (0.9*). There haven't been commits for months apparently.

Are you sure you want to go through the pain of emerging a compositing manager that is soon to be abandoned by the distros, over a DE like KDE-4 that provides just the same already?


Does revdep-rebuild come up with anything?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Thu Mar 08, 2012 9:22 pm    Post subject: Reply with quote

Didn't know the current version (0.9.5.x) was a rewrite or even that it was in beta. I'd prefer to run stable software but i also really like compiz-fusion, better than I like kwin. More customizable. I'll try the 0.8.8 from the pinkbyte overlay, get back to you.
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum