Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]Kmail Fehler
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3118
Location: Berlin

PostPosted: Thu Mar 08, 2012 9:44 pm    Post subject: [gelöst]Kmail Fehler Reply with quote

Hallo,
seit ich gestern auf von kde 4.8.0 auf 4.8.1 aktualisiert habe, ist virtuoso-t bei 100 % CPU Last. Auch, wenn der Datei-Indexer inaktiv ist. Ich hatte schon mal das Problem, das virtuoso-t den RAM ausgelastet hat. Auch die hohe CPU Last hatte ich irgendwann schon einmal. M.E. hatte sich das damals gelegt, wenn der Datei-Indexer inaktiv war.
(Es soll helfen, wenn ich ~/.kde4/share/apps/nepomuk/repository/main/data/virtuosobackend lösche. Aber dann muss die Datenbank neu erstellt werden. Da habe ich doch auch nichts gekonnt.)
Ich hatte c.a. 2500 SPam Mail und c.a. 2500 Mails im Mülleimer. Ich habe versucht die SPAM Mail in den Mülleimer zu verschieben und diesen dann zu leeren. (Kommt was zusammen, mit den täglichen SPAM Mails). Irgendetwas scheint da schiefgegangen zu sein. virtuoso-t CPU Last ist wieder im grünen Bereich. Kmail zeigt an SPAM Mail 1 und im Mülleimer noch 2328. Allerdings kann ich mit kmail nicht mehr arbeiten. Egak, auf welchen Ordner ich zugreifen will (inbox outboch trash SPAm) "Fehler beim Abholen" "unbekannter Fehler. (Unable to retrieve item flags). Akonadi Kontrollmodul berichtet, das alles in Butter ist.


Last edited by flammenflitzer on Mon Mar 12, 2012 7:23 pm; edited 2 times in total
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Mar 09, 2012 2:41 pm    Post subject: Reply with quote

Schau mal hier flammenflitzer,

https://bugs.kde.org/show_bug.cgi?id=289932

ob da für dich was dabei ist.
Aktueller Kurztipp für alle die (wie ich auch) schon 4.8.1 benutzen:
Sollte man noch alte Suchen /Suchergebnisse in Kmail haben, so soll man diese löschen.

Außerdem erfordert ein Patch der nun eingeflossen ist (ich hatte diesen schon auf 4.8.0 angewendet), das neu indiziert werden muss, so oder so.
Also auch ohne manuelles löschen.
Solange das läuft hast du natürlich eine hohe CPU-Last.


Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3118
Location: Berlin

PostPosted: Fri Mar 09, 2012 2:57 pm    Post subject: Reply with quote

Die CPU Last ist ja jetzt herunter. Aber KDE Pim funktioniert nicht mehr. In Akonadi gibt es aber keine Fehlermeldungen.
Code:
olaf@flammenflitzer ~ $ kmail
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kmail2(20414)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kmail2(20414)/kdepimlibs (mailtransport): Could not access Outbox.
olaf@flammenflitzer ~ $ kmail2(20414)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory!
kmail2(20414)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory!
kmail2(20414)/libakonadi Akonadi::EntityTreeModelPrivate::fetchJobDone: Job error:  "Unbekannter Fehler. (Unable to retrieve item flags)" for collection: 22
möglicherweise der Bug?
Code:
[Bug 285676] akonadi blocks kmail because of searching for bogus emails

Ich habe den Akonadi Server gestoppt, /home/olaf/.local/share/akonadi/ und /home/olaf/.config/akonadi/ umbenannt/entfernt und Akonadi neu gestartet. Bringt nichts
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3118
Location: Berlin

PostPosted: Sun Mar 11, 2012 10:17 pm    Post subject: Reply with quote

Ich habe jetzt alles in home *akonadi* und *kmail* gelöscht. Der Fehler kommt immer noch. Scheint an der externen mysql Datenbank zu liegen. Mit internem mysql kommt keine Fehlermeldung mehr.
Lag an der Datenbank von mysql.(Habe ich gelöscht und neu erstellt). Ich habe mein Adressbuch wiederherstellen können, die Mails habe ich auch gefunden. (Habe ich aus /home/olaf/.local/share/contacts/ und /home/olaf/.local/share/local-mail/ importiert). Jetzt fehlt mir noch der Kalender mit den Einträgen von Kalarm. Weiß jemand, wo die Geschichte standardmäßig liegt , bzw. wie ich das wiederherstellen kann?
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Mon Mar 12, 2012 4:34 pm    Post subject: Reply with quote

Hi flammenflitzer

Diese und weitere Antworten sollten eigentlich aus diesem Wiki hervor gehen:
http://wiki.gentoo.org/wiki/KDEPIM-4.7_upgrade


Viel Erfolg, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3118
Location: Berlin

PostPosted: Mon Mar 12, 2012 7:22 pm    Post subject: Reply with quote

Danke.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum