Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] problem installing net-zope/zope-fixers-1.0
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 13 Mar 2012
Posts: 13

PostPosted: Tue Mar 13, 2012 3:17 am    Post subject: [SOLVED] problem installing net-zope/zope-fixers-1.0 Reply with quote

Hi, I'm fairly new to gentoo and am trying to install deluged. I have a problem with a particular package, net-zope/zope-fixers-1.0. portage fails to install it and cancel the entire process. I leave the log file and some other file that portage mentions. I hope someone can help. thanks


 * Package:    net-zope/zope-fixers-1.0
 * Repository: gentoo
 * Maintainer:
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking zope.fixers-1.0.tar.gz to /var/tmp/portage/net-zope/zope-fixers-1.0/work
>>> Source unpacked in /var/tmp/portage/net-zope/zope-fixers-1.0/work
>>> Preparing source in /var/tmp/portage/net-zope/zope-fixers-1.0/work/zope.fixers-1.0 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-zope/zope-fixers-1.0/work/zope.fixers-1.0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-zope/zope-fixers-1.0/work/zope.fixers-1.0 ...
 * Building of net-zope/zope-fixers-1.0 with CPython 2.7...
python2.7 build -b build-2.7
Traceback (most recent call last):
  File "", line 19, in <module>
    from setuptools import setup, find_packages
ImportError: No module named setuptools
 * ERROR: net-zope/zope-fixers-1.0 failed (compile phase):
 *   Building failed with CPython 2.7 in distutils_building() function
 * Call stack:
 *, line   85:  Called src_compile
 *   environment, line 3681:  Called distutils_src_compile
 *   environment, line 1005:  Called python_execute_function 'distutils_building'
 *   environment, line 2069:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 * If you need support, post the output of 'emerge --info =net-zope/zope-fixers-1.0',
 * the complete build log and the output of 'emerge -pqv =net-zope/zope-fixers-1.0'.
 * The complete build log is located at '/var/tmp/portage/net-zope/zope-fixers-1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-zope/zope-fixers-1.0/temp/environment'.
 * S: '/var/tmp/portage/net-zope/zope-fixers-1.0/work/zope.fixers-1.0'

emerge --info =net-zope/zope-fixers-1.0

Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2-custom x86_64)
                         System Settings
System uname: Linux-3.2.1-gentoo-r2-custom-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 13 Mar 2012 02:30:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by mrtnfs on Tue Mar 13, 2012 4:06 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 06 Mar 2007
Posts: 14922

PostPosted: Tue Mar 13, 2012 3:31 am    Post subject: Reply with quote

Did you run python-updater after your last Python update?
Back to top
View user's profile Send private message

Joined: 13 Mar 2012
Posts: 13

PostPosted: Tue Mar 13, 2012 4:05 am    Post subject: Reply with quote

Hu wrote:
Did you run python-updater after your last Python update?

thanks, that help. update python because I thought that was the problem but do not run update-pynthon
Back to top
View user's profile Send private message

Joined: 30 Apr 2012
Posts: 1

PostPosted: Mon Apr 30, 2012 2:17 am    Post subject: Reply with quote

I ran “python-updater” several times with different options, but that problem isn’t solved…
Back to top
View user's profile Send private message

Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Feb 18, 2013 11:31 pm    Post subject: Reply with quote

Patterner wrote:
I ran “python-updater” several times with different options, but that problem isn’t solved…

you got the same issue or a Detected file collision(s) message ?

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message

Joined: 25 Apr 2005
Posts: 4
Location: New Hampshire, USA

PostPosted: Fri Dec 27, 2013 1:05 am    Post subject: Reply with quote

FWIW, I unmasked the three zope pacakages for amd64 and this problem went away.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 29 Jan 2004
Posts: 96

PostPosted: Sat Feb 22, 2014 10:05 pm    Post subject: Reply with quote

Was experiencing this issue as well. Running python-updater did not fix the problem. However adding "python3_2" to the PYTHON_TARGETS flags for dev-python/setuptools and reinstalling dev-python/setuptools did fix the issue.

I wasn't too fond of this solution, so I removed the python3_2 target, and tried unmasking net-zope/zope-fixers-1.0-r1. This also fixed the issue. Looks like the 1.0 ebuild is just broken.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum