Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
evdev ALTGR funktioniert nicht (geloest)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Wed Mar 14, 2012 11:11 am    Post subject: evdev ALTGR funktioniert nicht (geloest) Reply with quote

hallo,

ich kann unter xfce4 weder im terminal noch hier im FF (at) oder (pipe), eckige klammern, etc. eingeben ...
Alles was ALTGR benoetigt funktioniert nicht

Ich habe viele Wikis und uralte postings zum Thema gelesen und so ziemlich alles getestet, was ich finden konnte, komme aber dennoch einfach nicht weiter.


Meine derzeitige xorg.conf beinhaltet das

Code:

Section "InputClass"
    Identifier "keyboard-all"
    Driver "evdev"
    Option "XkbLayout" "de"
    Option "XkbVariant" "nodeadkeys"
    Option "XkbModel" "pc105"
    MatchIsKeyboard "on"
EndSection


wobei ich variant, model, matchis auch schon auskommentiert hatte (habe diesbzgl. alle Kombinationen durch)

ich hatte auch schon /etc/X11/xorg.conf.d/10-evdev.conf wie unter http://de.gentoo-wiki.com/wiki/Evdev beschrieben
angepasst - ohne Erfolg. (ist vermutlich auch egal, ob man das dort oder in xorg.conf eintraegt)

make.conf
Code:

INPUT_DEVICES="evdev keyboard mouse"


Code:

x11-base/xorg-server-1.11.2-r2
x11-drivers/xf86-input-evdev-2.6.0


Fehlt noch was an infos?

Achso, bevor ich mit startxfce4 X starte funktioniert ALTGR im Terminal, also an der Tastatur liegt es nicht ;)
aber langsam bin ich am verzweifeln :(

Ich hoffe Jemand kennt das Problem und kann helfen

Danke


Last edited by andi_s on Wed Mar 14, 2012 1:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Mar 14, 2012 11:29 am    Post subject: Reply with quote

Welche Grafikkarte + Treiber verwendest du? Wenns opensource-Treiber sind, kannst du auf eine xorg.conf nämlich KOMPLETT verzichten!
Ich hab eine intel-GPU, keine xorg.conf, dafür nur eine /etc/X11/xorg.conf.d/10-evdev.conf sowie eine 50-wacom.conf (für ein tablet).
Das hier ist der Inhalt meiner 10-evdev.conf:
Code:
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option  "XkbLayout" "de(nodeadkeys)"
        Option  "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

und bei mir gehen eigentlich alle Tasten (außer es liegt mal wieder ne Katze auf der Tastatur, dann geht gar nix mehr :D)
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Wed Mar 14, 2012 1:00 pm    Post subject: Reply with quote

Hallo,

Ja, auf meinem anderen PC habe ich dieses Problem nicht und gar keine xorg.conf

Hier benutze ich allerdings fglrx (ati-drivers...) und randr, d.h. ich benoetige eh eine xorg.conf

edit:
geloest... manchmal ist die Loesung so banal... ich habe jetzt erst bemerkt, dass unter /etc/X11/xorg.conf.d/ noch eine andere (nicht von mir erstellte) evdef.conf lag, die ebenfalls das keyboard definiert hat :oops: - nachdem ich die geloescht habe funktioniert nun alles so wie es soll... - danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum