Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Postfixadmin
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sat Apr 28, 2012 2:55 pm    Post subject: Postfixadmin Reply with quote

Hey Forum,

ich habe eben nach dem HowTo mir angefangen den Server zu bauen.

http://webcache.googleusercontent.com/search?q=cache:vXyQPyvXX7gJ:en.gentoo-wiki.com/wiki/Mail_server_using_Postfix_and_Dovecot+http://en.gentoo-wiki.com/wiki/Mail_server_using_Postfix_and_Dovecot&cd=1&hl=de&ct=clnk&gl=de&client=firefox-a

nun stehe ich beim Punkt 3.4 Setup ..

da ich die Domain erst erworben habe und noch nicht besitze kann ich sie nicht über http://mailadmin.domain.tld erreichen.

habe Sie über webapp-config installiert und die config.inc konfiguriert.

Code:
/var/www/domain.tld


Ich möchte den Server erstmal konfigureren ohne das er erreichbar ist von außen wie kann ich nun die Weboberfläche erreichen ?

Mit //192.168.178.xxx/mailadmin.domain.tld komme ich nicht sehr weit bitte helft mir.

Danke für eure Hilfe :)
Back to top
View user's profile Send private message
papahuhn
l33t
l33t


Joined: 06 Sep 2004
Posts: 623

PostPosted: Sat Apr 28, 2012 8:29 pm    Post subject: Reply with quote

In Deiner lokalen /etc/hosts (Linux) bzw. C:\Windows\System32\Drivers\etc\hosts (Windows) einen Eintrag ergänzen, der mailadmin.domain.tld der Server-IP-Adresse zuordnet.
Danach kannst Du im Browser herumkonfigurieren.
_________________
Death by snoo-snoo!
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sat Apr 28, 2012 8:35 pm    Post subject: Reply with quote

okay danke.. habe das nur für den localhost gemacht .. mhm sry
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sat Apr 28, 2012 9:02 pm    Post subject: Reply with quote

habe ich so eingerichtichtet:

Code:


IPv4 and IPv6 localhost aliases

192.168.178.50      hostname
192.168.178.50      mailadmin.domain.de


wenn ich jetzt auf gehe findet er die Seite nicht. Habe den Apache auch restartet. Was mach ich falsch?

Code:
mailadmin.domain.de/setup.php
Back to top
View user's profile Send private message
papahuhn
l33t
l33t


Joined: 06 Sep 2004
Posts: 623

PostPosted: Sat Apr 28, 2012 9:12 pm    Post subject: Reply with quote

Der Webserver steht aber in Deinem LAN, ja? Was ist, wenn Du die IP-Adresse im Browser aufrufst? Connection Timeout oder Apache Fehlermeldung?
_________________
Death by snoo-snoo!
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sat Apr 28, 2012 9:20 pm    Post subject: Reply with quote

Ja ich gehe ohne irgendwelche extras mit putty drauf

Code:
It works!


Phpmyadmin liegt in

Code:
/var/www/localhost/htdocs/phpmyadmin/


das kann ich Problemlos aufrufen

Code:
/var/www/localhost/htdocs/postfixadmin/setup.php/


funktioniert.

kann es vllt daran liegen das mein Verzeichnis in liegt

Code:
/var/www/mailadmin.lukasletitburn.de/htdocs/setup.php
 



Code:

http://192.168.178.50/postfixadmin/setup.php


Kann ich zugreifen allerdings liegt das auch in

Code:
/var/www/localhost/htdocs/postfixadmin/
Back to top
View user's profile Send private message
papahuhn
l33t
l33t


Joined: 06 Sep 2004
Posts: 623

PostPosted: Sat Apr 28, 2012 9:54 pm    Post subject: Reply with quote

Ich verstehe nicht, was Du da testest. Rufst Du wirklich Dateisystempfade auf? Warum?
Für die mailadmin.domain.de musst Du natürlich einen Virtualhost mit eigenem DocumentRoot "/var/www/localhost/htdocs/postfixadmin" anlegen.
_________________
Death by snoo-snoo!
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Sun Apr 29, 2012 6:55 am    Post subject: Reply with quote

lukasletitburn wrote:
habe ich so eingerichtichtet:

Code:


IPv4 and IPv6 localhost aliases

192.168.178.50      hostname
192.168.178.50      mailadmin.domain.de


wenn ich jetzt auf gehe findet er die Seite nicht. Habe den Apache auch restartet. Was mach ich falsch?

Code:
mailadmin.domain.de/setup.php


Du solltest das nicht auf deinem Server machen sondern auf deinem Client. Trag mal im Client (da wo du den Browser auf machst) diese Zeile in die /etc/hosts ein:
192.168.178.50 mailadmin.domain.de

Dann sollte es gehen mit der mailadmin.domain.de im Browser.

Sebastian
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sun Apr 29, 2012 9:33 am    Post subject: Reply with quote

Habe ich gemacht.

Jetzt geht es :D Daaaanke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum