Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg won't start (-disable-mmx error)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 29 Apr 2012
Posts: 2
Location: Richland, WA

PostPosted: Sun Apr 29, 2012 11:31 pm    Post subject: Xorg won't start (-disable-mmx error) Reply with quote

Good day,

I'm installing Gentoo for the first time. I picked an old Mac Mini PowerPC G4. I've gotten it up, kernel built and on the network, but the X server won't start. The weird thing is that it's failing with an error message that references MMX!

Am I doing something wrong? Any help and/or hints for this Gentoo n00b would be greatly appreciated.

Here's what happens when I try to run Xorg with a freshly-xac-created xorg.conf:


abby ~ # Xorg -config xorg.conf
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/abby:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.1-gentoo-r2 ppc Gentoo
Current Operating System: Linux abby 3.2.1-gentoo-r2 #4 Thu Apr 26 17:11:24 PDT 2012 ppc
Kernel command line: root=/dev/hda4 ro
Build Date: 24 April 2012  07:16:05AM

Current version of pixman: 0.24.0
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 29 16:07:15 2012
(++) Using config file: "xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] drm report modesetting isn't supported.
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.
  XRANDR name: DVI-0
  Connector: DVI-I
  DDC reg: 0x6c
  XRANDR name: S-video
  Connector: S-video
  DDC reg: 0x0
finished output detect: 0
finished output detect: 1
finished all detect
Entering TV Save
Save TV timing tables
saveTimingTables: reading timing tables
TV Save done
disable TVDAC
disable TVDAC
disable TV
disable TVDAC
init memmap
init common
init crtc1
init pll1
freq: 154000000
best_freq: 154000000
best_feedback_div: 154
best_frac_feedback_div: 0
best_ref_div: 27
best_post_div: 1
restore memmap
restore common
restore crtc1
restore pll1
finished PLL1
set RMX
enable TVDAC
prog: Unknown command line argument '-disable-mmx'.  Try: 'prog -help'

And here's the xorg.conf xac created:


### This file was generated by xac v0.6_pre3

Section "ServerLayout"
        Identifier      "XAC Configured"
        Screen          0 "Screen0" 0 0
        InputDevice     "Mouse0"        "CorePointer"
        InputDevice     "Keyboard0"     "CoreKeyboard"

Section "Files"
        ### Multiple FontPath entries are allowed (which are concatenated
        ### together as well as specifying multiple comma-separated
        ### entries in one FontPath command (or both methods)
        ### For X Font Server support, uncomment this and comment the
        ### other FontPaths. (This is not required for most configurations)
        # FontPath      "unix/:-1"

        FontPath        "/usr/share/fonts/dejavu"
        FontPath        "/usr/share/fonts/urw-fonts"

Section "Module"
        Load            "extmod"
        Load            "dbe"
        Load            "record"
        Load            "glx"
        Load            "type1"
        Load            "freetype"
        Load            "dri"

Section "ServerFlags"
        Option          "blank time"    "10"    # 10 Minutes
        Option          "standby time"  "20"    # 20 Minutes
        Option          "suspend time"  "30"    # 30Minutes
        Option          "off time"      "60"    # 60Minutes
        ### Uncomment so X doesn't fail when no mouse is available
        # Option                "AllowMouseOpenFail"    "true"
        ### Enable this option if X should not change resolutions
        ### This is useful if mode changing corrupts the X Server
        # Option                "DisableVidModeExtensions"      "true"

Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"
        ### Check /usr/share/X11/xkb/rules/xorg.lst for available models
        Option          "XkbdModel"             "pc105"
        ### Check /usr/share/X11/xkb/symbols/ for available layouts
        Option          "XkbLayout"             "us"
        Option          "XkbOptions"            "compose:rwin"

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "auto"

        ### Set driver options:
        ### No options set!

        ### Unset driver options:
        ### No options unset!

Section "Device"
        Identifier      "Card0"
        Driver          "radeon"
        ### Configured ATI Radeon 5962 at PCI Bus ID:
        # BusID         "PCI:0:16:0"

        ### Set driver options:
        Option          "EnablePageFlip"        "true"  # Increases Performance
        Option          "MergedFB"              "false" # Set to true if you want mirrored monitor output

        ### Unchanged, default driver options:
        # Option                "AccelMethod"   "XAA"   # XAA or EXA, but EXA is unstable"
        # Option                "AGPMode"       "1"     # Set to the AGP bus speed, 1 = 1x
        # Option                "AGPFastWrite"  "false" # Can be unstable
        # Option                "BackingStore"  "false" # Currently broken
        # Option                "BIOSHotkeys"   "false" # Enable this to switch outputs with a hotkey
        # Option                "BusType"       "auto"  # Force Video Bus to PCI, AGP or PCIE
        # Option                "MonitorLayout" "auto"  # Set to TMDS for some Apple Flat Panels
        # Option                "NoAccel"       "false" # Disables ALL hardware acceleration
        # Option                "RenderAccel"   "true"  # Hardware Render Acceleration"
        # Option                "ReverseDDC"    "false" # Some G5s require this
        # Option                "SWcursor"      "false"
        # Option                "UseFBDev"      "false" # Try enabling this if it does not work

        ### See "man radeon" for more information and options

Section "Monitor"
        Identifier      "Monitor0"
        UseModes        "Modes0"
        ModelName       "HH281"
        Option          "DPMS"
        Option          "ReducedBlanking"
        HorizSync       24-80
        VertRefresh     56-75

Section "Modes"
        Identifier      "Modes0"
        ### # 1920x1200 59.95 Hz (CVT 2.30MA-R) hsync: 74.04 kHz; pclk: 154.00 MHz
        Modeline "1920x1200"  154.00  1920 1968 2000 2080  1200 1203 1209 1235 +hsync -vsync
        ### # 720x400 59.55 Hz (CVT) hsync: 24.83 kHz; pclk: 22.25 MHz
        Modeline "720x400"   22.25  720 744 808 896  400 403 413 417 -hsync +vsync
        ### # 1152x2048 59.96 Hz (CVT) hsync: 126.33 kHz; pclk: 165.75 MHz
        Modeline "1152x2048"  165.75  1152 1200 1232 1312  2048 2051 2061 2107 +hsync -vsync

Section "Screen"
        Identifier      "Screen0"
        Device          "Card0"
        Monitor         "Monitor0"
        DefaultDepth    24

        SubSection "Display"
                Depth   8
                Virtual 1920 1200
                Modes   "1920x1200" "720x400" "720x400" "640x480" "640x480" "640x480" "640x480" "800x600" "720x400" "720x400" "640x480" "640x480" "640x480" "800x600" "800x600" "1152x2048"

        SubSection "Display"
                Depth   16
                Virtual 1920 1200
                Modes   "1920x1200" "720x400" "720x400" "640x480" "640x480" "640x480" "640x480" "800x600" "720x400" "720x400" "640x480" "640x480" "640x480" "800x600" "800x600" "1152x2048"

        SubSection "Display"
                Depth   24
                Virtual 1920 1200
                Modes   "1920x1200" "720x400" "720x400" "640x480" "640x480" "640x480" "640x480" "800x600" "720x400" "720x400" "640x480" "640x480" "640x480" "800x600" "800x600" "1152x2048"


Section "DRI"
        Group 0
        Mode 0666

I've put /var/log/Xorg.0.log on Dropbox at for your reference.

For completeness, here's emerge --info:


Portage (default/linux/powerpc/ppc32/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2 ppc)
System uname: Linux-3.2.1-gentoo-r2-ppc-7447A,_altivec_supported-with-gentoo-2.0.3
Timestamp of tree: Sun, 29 Apr 2012 22:00:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
CFLAGS="-O2 -mcpu=G4 -fno-strict-aliasing -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=G4 -fno-strict-aliasing -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppc ppds pppd pulseaudio qt3support qt4 readline sdl session socialweb spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis wxwidgets xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga nv r128 radeon savage tdfx trident dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

...and if you want to see my /usr/src/linux/.config, I've put it on Dropbox at .
Back to top
View user's profile Send private message

Joined: 05 Jul 2003
Posts: 45620
Location: 56N 3W

PostPosted: Mon Apr 30, 2012 6:30 pm    Post subject: Reply with quote


Welcome to Gentoo.

Even on PPC, xorg should start without a xorg.conf. udev will detect your input devices and xorg will try all of your open source video drivers.
Thats the first test. run startx with no xorg.conf. Don't delete xorg.conf, you will need a stub to set your keyboard layout, if you don't like the default USA.
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.
suggests a kernel problem but its not a fatal error. You just won't have any hardware acceleration. Xorg will still work.

The -disable-mmx is being passed to something as a command line argument.

What do you have in ~/.xinitrc if anything?
abby ~ # Xorg -config xorg.conf
shows that you are trying to run Xorg as root. This is a very bad thing but is probably harmless until it actually works.


Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message

Joined: 29 Apr 2012
Posts: 2
Location: Richland, WA

PostPosted: Mon Apr 30, 2012 9:44 pm    Post subject: Reply with quote

Googling around I found That referred to llvmpipe, which led me to the Gallium driver for Radeon video boards (

Then I remembered seeing this:

  Title                     Mesa r600 driver now defaults to gallium
  Author                    Chí-Thanh Christopher Nguyá»n
  Posted                    2011-08-28
  Revision                  1

This news item is relevant to you only if you have a Radeon graphics
chipset and use the free/open source driver.

The r600 driver that provides 3D acceleration for Radeon HD 2400 and
later cards comes in the "classic" and "gallium" variants. The gallium
driver is based on the new Gallium3D infrastructure and was chosen as
the default driver for media-libs/mesa-7.11.

Existing users will not be switched automatically. To switch to the
r600 gallium driver, use the following command:

    eselect mesa set r600 gallium

Gallium3D requires kernel modesetting (KMS). If your system is not yet
configured for KMS, consult the X Server Configuration HOWTO for
instructions prior to switching:

So for grins I ran these three commands to disable the Gallium driver:

sudo eselect mesa set r300 classic
sudo eselect mesa set r600 classic
sudo eselect mesa set sw classic

...and then re-emerged mesa and xorg-server. Now it works--Gnome starts up happily per the instructions at Unfortunately I had to catch an airplane this morning and won't get back to play with the machine until this weekend.

In the meantime I'll try to educate myself on emerge/portage to see what patches are applied to the base llvm-2.8. Maybe someone back-ported a patch from llvm-2.9 Subversion into Gentoo's llvm-2.8, causing the breakage reported in the freedesktop bugzilla entry above?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum