Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: Paludis, fail to interprete blockers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 188

PostPosted: Sat May 12, 2012 8:19 am    Post subject: [SOLVED]: Paludis, fail to interprete blockers Reply with quote

Gentlemen,

please may I ask you for explanation how to solve these blockers?
I fail to understand what is actually blocked and what is the cause.

Thank you a lot!

Code:

I encountered the following errors:

!   sys-devel/llvm
    Reasons: target (installed-packages::installed), media-libs/mesa
    Unsuitable candidates:
      * sys-devel/llvm-2.5:0::layman (in ::d-overlay)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.5:0::layman (in ::gnustep)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.5-r1:0::layman (in ::ibormuth)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.5-r71386:0::layman (in ::d-overlay)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.5-r79757:0::layman (in ::d-overlay)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.8-r1:0::layman (in ::v-fox)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.8-r2:0::gentoo
        Did not meet >=sys-devel/llvm-2.9, use existing if possible, installing to / from media-libs/mesa
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-2.9-r2:0::gentoo
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-3.0-r2:0::gentoo
        Did not meet >=sys-devel/llvm-3.1, use existing if possible, installing to / from media-libs/mesa
      * sys-devel/llvm-3.1.9999:0::layman (in ::FireBurn)
        Masked by unavailable (In a repository which is unavailable)
      * sys-devel/llvm-9999:0::layman (in ::d-overlay)
        Masked by unavailable (In a repository which is unavailable)
      * sys-devel/llvm-9999:0::layman (in ::ibormuth)
        Masked by unavailable (In a repository which is unavailable)
      * sys-devel/llvm-9999:0::gentoo
        Masked by keyword
            Keywords
!   x11-libs/gtk+
    Reasons: !<x11-libs/gtk+-2.21.3:2 from x11-libs/gdk-pixbuf, app-crypt/pinentry, app-misc/geoclue, 65 more
    Unsuitable candidates:
      * x11-libs/gtk+-2.18.3:2::layman (in ::gentoo-arm)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !<x11-libs/gtk+-2.21.3:2, use existing if possible, installing to / (nothing is fine too) from !<x11-libs/gtk+-2.21.3:2 from x11-libs/gdk-pixbuf
        Did not meet >=x11-libs/gtk+-2.20.0:2, use existing if possible, installing to / from media-libs/libcanberra
        Did not meet >=x11-libs/gtk+-2.20:2, use existing if possible, installing to / from xfce-base/exo (and 5 more)
        Did not meet >=x11-libs/gtk+-2.20:2[introspection?], use existing if possible, installing to / from x11-libs/mx
        Did not meet >=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from media-gfx/gimp
        Did not meet >=x11-libs/gtk+-2.24:2, use existing if possible, installing to / from dev-python/pygtk (and 3 more)
      * x11-libs/gtk+-2.21.5:2::layman (in ::rubenqba)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=x11-libs/gtk+-2.20:2[introspection?], use existing if possible, installing to / from x11-libs/mx
            Flag 'introspection' enabled if it is enabled for 'x11-libs/mx-1.4.2:1.0::installed'
        Did not meet >=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from media-gfx/gimp
        Did not meet >=x11-libs/gtk+-2.24:2, use existing if possible, installing to / from dev-python/pygtk (and 3 more)
      * x11-libs/gtk+-2.24.5-r1:2::gentoo
        Did not meet >=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from media-gfx/gimp
      * x11-libs/gtk+-2.24.8-r1:2::gentoo
        Did not meet >=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from media-gfx/gimp
      * x11-libs/gtk+-2.24.9-r1:2::gentoo
        Did not meet >=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from media-gfx/gimp
      * x11-libs/gtk+-2.24.10:2::layman (in ::stuff)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=x11-libs/gtk+-2.20:2[introspection?], use existing if possible, installing to / from x11-libs/mx
            Flag 'introspection' enabled if it is enabled for 'x11-libs/mx-1.4.2:1.0::installed'
      * x11-libs/gtk+-2.24.10-r1:2::layman (in ::sabayon)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet <=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from x11-terms/gnome-terminal
        Did not meet >=x11-libs/gtk+-2.20:2[introspection?], use existing if possible, installing to / from x11-libs/mx
            Flag 'introspection' enabled if it is enabled for 'x11-libs/mx-1.4.2:1.0::installed'
      * x11-libs/gtk+-2.24.10-r1:2::layman (in ::stuff)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet <=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from x11-terms/gnome-terminal
        Did not meet >=x11-libs/gtk+-2.20:2[introspection?], use existing if possible, installing to / from x11-libs/mx
            Flag 'introspection' enabled if it is enabled for 'x11-libs/mx-1.4.2:1.0::installed'
      * x11-libs/gtk+-2.24.10-r1:2::gentoo
        Did not meet <=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from x11-terms/gnome-terminal
      * x11-libs/gtk+-2.9999:2::layman (in ::gnome-live)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet <=x11-libs/gtk+-2.24.10:2, use existing if possible, installing to / from x11-terms/gnome-terminal
        Did not meet >=x11-libs/gtk+-2.20:2[introspection?], use existing if possible, installing to / from x11-libs/mx
            Flag 'introspection' enabled if it is enabled for 'x11-libs/mx-1.4.2:1.0::installed'



Last edited by are on Sat May 12, 2012 9:24 am; edited 1 time in total
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 188

PostPosted: Sat May 12, 2012 9:23 am    Post subject: [solved] Reply with quote

Solved,

gnome-terminal depended on gtk+ < 2.4.10 while everything else depended on gtk+ >= 2.4.10 --> block.
I uninstalled gnome-terminal and the update works now.


@Paludis Guys: I really liked paludis, but the output it produces is not really helpful anymore! I had to resolve for gtk+ manually to figure out the blocker.

Best regards
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5876

PostPosted: Sat May 12, 2012 4:38 pm    Post subject: Reply with quote

Install dev-util/gtk-builder-convert, as per `cave show -c gnome-terminal` output.
Quote:
Code:
*gtk+-2.24.10-r1 (13 Feb 2012)

  13 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
  gtk+-2.24.5-r1.ebuild, gtk+-2.24.8-r1.ebuild, gtk+-2.24.9-r1.ebuild,
  gtk+-2.24.10.ebuild, +gtk+-2.24.10-r1.ebuild:
  Split dev-util/gtk-builder-convert out of gtk+-2.24.10-r1 to get rid of
  python dependency (requested by Diego Elio Pettenò, bug #402905).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum